Announcement

Collapse
No announcement yet.

Why does RR always go back to music page on resume?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Why does RR always go back to music page on resume?

    Ok, I've really tried to figure this out, and tried to search here for the answer, all with no success. I know this has got to be simple.

    When RoadRunner resumes after Standby, it comes up exactly where it left off, for example if I have Nav running, which is perfect, except it only lasts for about 100 milliseconds, and then RR switches to the music player, just as if I had selected it. It does it no matter what I had running when it went into standby. It always resumes and immediatly goes to the Music player. I don't want it to do this, I want it to stay where it left off, like if I was navigating, I want it to resume navigating.

    I've searched for any "onresume" statements, and found nothing.

    I've looked through the .ini files, and just don't see it. There has to be something in there doing this. Help!

  • #2
    Have you tried other skins?

    If you are using the BMV2 skin, perhaps your screen has debris there?
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

    Comment


    • #3
      Using iDrive. Haven't tried another skin yet. I did not use to have this problem with RR and iDrive though, prior to switching over to a new computer and a fresh load of RR.

      Comment


      • #4
        Can you post your ini file?

        Do you use iGuidance? Do you have that autoswitch to last screen thing set? It is the only one I know of that switches a screen like that...
        Fusion Brain Version 6 Released!
        1.9in x 2.9in -- 47mm x 73mm
        30 Digital Outputs -- Directly drive a relay
        15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
        Buy now in the MP3Car.com Store

        Comment


        • #5
          It should stay in the same screen as before hibernating -- and I've always used it like that without a problem. Either some application is sending a command to RR, or the skin is, or you have something on the ONRESUME event in exectbl.ini that is triggering that screen to come up.
          Ride Runner RR's Myspace

          "Being happy is not about having what you want, it's about wanting what you have."
          "The best things in life are always free - but that doesn't mean money can't buy you good things."

          Comment


          • #6
            Skin problem.
            I never have this problem.
            2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
            89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
            Y2K Accord Dell GX150
            RoadRunner is the best FE PERIOD
            EmoRebellion is a SCAMMER

            Comment


            • #7
              Thanks everyone for the help. Unfortunately, I still have yet to figure out the problem. Haven't had much time to work with the carpc, although i am using it everyday and Roadrunner is just great! Hoping to have some time to tackle the canbus interface in Oktober, so want to get this minor stuff out of the way.

              Here are my .ini files. If anyone see's anything, please let me know. This is really making me nuts. Also, I don't have the problem with other programs when I go into standby and then resume. Only roadrunner. It's got to be something really simple.


              ExecTBL.ini

              [deleted the comments...]

              "QUIT","SendMsg;RRCDRip;showplugin||bye"
              "BYE","QUIT"

              /, Set Bellow the Path to the CDRip plugin (if used)
              "CDRIP","PLUGIN;RRCDRip;D:\VBStuff\Road Runner\CDRip\CDRip.exe"

              /, You can add commands to execute before suspend
              /, and after resume, using the codes bellow:

              "ONSUSPEND",""
              "ONRESUME",""
              "ONFILECLICK",""
              "ONDIRCLICK",""
              "ONPLCLICK",""
              "ONDLCLICK",""
              "ONPBCLICK",""

              resume.ini

              -1
              -1
              False
              True
              C:\Program Files\Road Runner\skins\iDrive\
              26212
              False





              rr.ini

              voice=true
              musicpath=C:\Music\
              videopath=D:\DVDs\
              dvdpath=C:\Program Files\InterVideo\DVD6\WinDVD.exe
              dvdname=InterVideo WinDVD 6
              launchpath=C:\Program Files\Road Runner\Launch\
              winamppath=C:\Program Files\Winamp\
              skinpath=C:\Program Files\Road Runner\skins\iDrive\
              nightskin=C:\Program Files\Road Runner\skins\iDrive Night Red\
              mpcpath=C:\Program Files\Road Runner\mplayerc.exe
              screentype=16:9
              videoautohide=true
              videohidetime=4
              audiofiles=.mp3,wma,wav,cda
              hidemouse=false
              coverfile=*.jpg
              albumart=*.txt
              useid3=3
              showid3playlist=true
              showid3browse=true
              gpsmode=2
              gpsport=6
              mapmonkeypath=C:\DestinatorApps\Map Monkey\MapMonkey.exe
              gpspath=C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe
              gpsname=iguidance
              exitmode=0
              showicons=true
              showextensions=false
              titlesafter=-
              listfollowssong=true
              resumemusic=0
              audiorepeat=off
              audioshuffle=on
              gammamode=1
              gammapath=C:\Program Files\Road Runner\Gamma\GammaControl.exe
              dateformat=MM/DD/YYYY
              timeformat=HH:MM:SS
              id3listformat=%artist% / %title%
              id3browseformat=%artist% / %title% / %genre% / %album%
              mastervolmap=2
              listnumbers=false
              noformat=false
              hidewinamp=true
              visuname=!Winamp Gen!AVS
              overspeed=80
              scrollmode=1
              builtinvideo=true
              disableinternat=true
              locale=0
              hidetaskbar=false
              hidedesktop=true
              radiomode=0
              radioline=0
              playlistpath=C:\Music\
              lazytag=false
              allowallfreqs=false
              browsertype=1
              browserpath=C:\Program Files\Internet Explorer\iexplore.exe
              mapvol=50
              standardphonebook=0
              maxcalllistentries=100
              xmport=2
              xmline=1
              xmlineinplugin=true
              xmlineinpar=line://title=XM,srate=44100,bps=16,nch=2
              debugmode=false
              hibernateaware=true
              enableclipping=true
              soundcard=0
              nozoom=0
              ipoddrive=Click here to set drive
              resolution=800x600x32x60
              usegestures=false
              leavemousealone=false
              hibernatereload=false
              forcehibernate=true
              closeapps=true
              cityweather=piketon, oh
              weatherunits=USA


              Here are the iDrive skin .ini files

              execTBL.ini

              /, You can add commands to execute before suspend
              /, and after resume, using the codes bellow:

              /"ONSUSPEND",""
              /"ONRESUME",""
              "ONLINE",""
              "OFFLINE",""
              "ONFILECLICK",""
              "ONDIRCLICK",""
              "ONPLCLICK",""
              "ONDLCLICK",""
              "ONPBCLICK",""
              "ONPLSELCLICK",""
              "ONDLSELCLICK",""
              "ONSONGSTART","SETVARBYCODE;curtrack;trackpath "
              /"ONSKINSTART","SETVAR;NIGHT;0||SETVAR;SNIGHT;0||RU N;$skinpath$DNSwitch.exe||AUDIO"

              "TIMER","BYVAR;NIGHT;MM;Set_Color_Mode|1||SETVAR;N IGHT;1<<",destinator_gps.skin
              "TIMER","BYVAR;NIGHT;SENDMSG;FreeDrive;day||SETVAR ;NIGHT;1<<",external_gps.skin
              "TIMER","BYVAR;SNIGHT;ACTIVATE;- Microsoft Streets & Trips||SENDKEY;%vmd||SETVAR;SNIGHT;1<<",external_g ps.skin
              "TIMER","BYVAR;SLIDESHOW;<<NEXTPIC",PICVIEWER. SKIN

              "CAMALERT","",external_gps.skin
              "CAMALERT","MENU;camalert.skin"


              iDrive.ini

              iGuidance
              SpeedFan
              Internal
              GAMES=True,=Games,LOAD;games.skin,
              TV=True,=TV,TV,
              CDRIP=True,CD Rip,CDRIP,
              RADIO=False,=Radio,RADIO,
              PHOCO=True,=Phone,PHOCO,
              MOBILEWEB=True,=MobileWeb,LOAD;mobileweb.skin,
              RADAR=True,=Valentine 1,LOAD;valentine.skin,
              WEATHER=True,=Weather,LOAD;weather.skin,
              SIRIUS=False,=Sirius,SIRIUS,
              XM=True,=XM,XM,
              TRAFFIC=False,=Traffic,LOAD;traffic.skin,
              TRAFFICC=True,=Traffic Cam,LOAD;trafficcam.skin,
              GAS=True,=Gas Prices,gaspricefinder,
              PICTURES=True,=Pictures,PICS,
              TRIPMETER=True,=TripMeter,tripmeter,Milage
              RREARTH=True,RREarth,GE_START,
              MOTIONLOCK=True,MotionLock,MotionLock,
              DRAW=True,Draw,LOAD;draw.skin,
              CALENDAR=False,,LOAD;Calendar.skin,
              END


              general.ini

              OriginalWidth=800
              OriginalHeight=600
              ShowWidth=800
              ShowHeight=600
              XPosition=0
              YPosition=0
              ApplyToVideo=True
              ApplyToVisu=False
              AutoSwitch=False
              DayTime=08:00:00
              NightTime=17:00:00
              GammaDayRed=0
              GammaDayGreen=0
              GammaDayBlue=0
              GammaNightRed=0
              GammaNightGreen=0
              GammaNightBlue=0

              Comment


              • #8
                Well you have slashed out the onskinstart line which is the only line I could think of that might cause it to do that. But even then if it did that would be a RR problem, because onskinstart commands shouldn't run on a resume.

                BTW by slashing out that line you have stopped the skin switcher from runnng, which switches the skins of some of the other programs/plugins.

                Comment


                • #9
                  Well you have slashed out the onskinstart line
                  Yes, I know. I was just stabbing at different things. I am running this under Vista, and I suppose maybe it has something to do with it. However, other programs running under vista seem to resume just fine.

                  Thanks for looking it over, I do appreciate your time and the super cool skins that look so perfectly correct in my vehicle

                  Comment


                  • #10
                    Your answer is probably
                    Attached Files
                    .______
                    | '_ |__\___
                    [(o)|___(o)] XB
                    ._________
                    | I__I I_I|_\__I
                    [(o)______(o)]b VanPimpin'

                    LostReceptions Apps D/L Here

                    GPSGasoline- Rewriting

                    Draw- SkribblePad for Touchscreens

                    iGQwerty-iG3.0 Qwerty Keyboard

                    CarPCNetwork

                    Comment


                    • #11
                      add debugmode=true to RR.INI... run it, standby/resume (causing it to go to the audio player right?) then post a ZIP of your Debug log file from RR's folder.
                      Ride Runner RR's Myspace

                      "Being happy is not about having what you want, it's about wanting what you have."
                      "The best things in life are always free - but that doesn't mean money can't buy you good things."

                      Comment


                      • #12
                        Originally posted by lostreception View Post
                        Your answer is probably
                        LOL! Thats priceless!!!
                        Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                        My Fiero Build Thread

                        Comment


                        • #13
                          I think I've had a breakthrough. The problem only occurs when gammacontrol is set to switch RoadRunner. My theory, (and please understand that all this skinning stuff is very new to me) is that the skin's ExecTbl.ini is being executed every time Gammacontrol sends its day/night control command, which it apparently is doing on everytime on Resume. And then in the skin's ExecTbl.ini file is this line:

                          "ONSKINSTART","SETVAR;NIGHT;0||SETVAR;SNIGHT;0||RU N;$skinpath$DNSwitch.exe||AUDIO"

                          I completely removed the "||RUN;$skinpath$DNSwitch.exe||AUDIO" part of the line, and it appears to have fixed my problem, I think.

                          I would really appreciate it if someone more knowledgeable could confirm this, or explain it, or tell me I'm nuts. I do have the Roadrunner Debug file, and I'll post it here if it will still help.

                          Thanks.

                          Comment


                          • #14
                            Well.....poop. Put it in the car and problem is not fixed. Not sure what the difference is between living room and car, other than a touchscreen. And now I've got a new even stranger problem. I did an IG3 theme.ini file in order to improve the levels of roads displayed, and it works great until the gammacontrol kicks in to dim the screen, and then all the nice new details roads disappear, instantly and permanently, until I restart IG3, and not becuase the screen just dimmed too much. Just not my day with the carputer. I guess I'm going to have to really learn this stuff.

                            Comment


                            • #15
                              That: ||AUDIO bit is what "should" be causing it, but if you say not using gamma control "fixes it" -- How about you try something like GammaPanel or Built-In Gamma ??

                              It most definitely has to do with something GammaControl is sending to RR.. That's why I asked for a debug log -- so I could see what's causing it. I don't know much about GammaControl honestly, but looking at the debug log I could have a bettter idea of where the AUDIO command is coming from.
                              Ride Runner RR's Myspace

                              "Being happy is not about having what you want, it's about wanting what you have."
                              "The best things in life are always free - but that doesn't mean money can't buy you good things."

                              Comment

                              Working...
                              X