Announcement

Collapse
No announcement yet.

Multiple Winamp Class names

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Multiple Winamp Class names

    I am having a little difficulty determining the the class name for the different instances of winamp.
    I have already created separate instances of Winamp by copying & renaming the "Program Files" directories. I have also check the "allow multiple instances" option & different output devices per each instance. Outside of RR I can run both instances of Winamp at the same time, playing different music, to different outputs... completely separate.
    I created 2 separate versions of RR the same way and while attempting to determine the "CLASS NAME" for each winamp instance I get the same result.
    PS. to get the CLASS NAME I use winspector.

    Was wondering if someone could help

    Thanks in advance,
    Tony
    Hardware: VIA-SP13000, M2-ATX, Voom case, HQCT, Linksys WiFi, Bluetooth, 512MB, 80GB, Dynamix 706.
    Software: XP Pro (stripped), Drivers only, Road Runner, CentriFuse, EzSync
    99% done... [never completely finished... a continuing hobby]

  • #2
    You don't even have to have multiple copies of winamp.. you just have to have two copies of RR (you can even point them to the same skins path and same applications). And set winampclass=<classname> or playerid=<InstanceID> on at least of them and run the 2nd copy of RR with a /2 in the command line. This should allow you to run two RRs each with its own copy of winamp (which if you want to use different sound cards for instance, yes, you'd have to have two copies as well).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

    Comment


    • #3
      Guino,
      Thanks for the quick response.

      I must be just to tired.

      I have tried multiple installs of Winamp... all the same CLASSID. I set the "Winamp CLassID" I tried 1, 2 and both RR installs. No go.
      If I run the 2 separate Winamps at the same time without RR, all is OK... separate songs and separate sound devices.
      When I run through RR it seems like the settings for Winamp are taken from the first instance run.
      I have tried with 2 versions of RR--> complete copies of RR directory in "c:\program files\". I start RR1, and play music... OK. Then I start RR2, music them mimics what is on RR1.

      Maybe that is it... When RR starts Winamp, were does it take its settings from? If it uses the winamp.ini from the "Winamp directory" then I am lost.

      Could someone help?
      TIA,
      Tony
      Hardware: VIA-SP13000, M2-ATX, Voom case, HQCT, Linksys WiFi, Bluetooth, 512MB, 80GB, Dynamix 706.
      Software: XP Pro (stripped), Drivers only, Road Runner, CentriFuse, EzSync
      99% done... [never completely finished... a continuing hobby]

      Comment


      • #4
        post both of your RR.INI files in a zip file here so I can look at them. This has nothing to do with winamp settings, as I posted above, it's all a matter of setting the winampclass setting in RR.INI
        Ride Runner RR's Myspace

        "Being happy is not about having what you want, it's about wanting what you have."
        "The best things in life are always free - but that doesn't mean money can't buy you good things."

        Comment


        • #5
          Thanks for your help.

          Here are the rr.ini files.
          Attached Files
          Hardware: VIA-SP13000, M2-ATX, Voom case, HQCT, Linksys WiFi, Bluetooth, 512MB, 80GB, Dynamix 706.
          Software: XP Pro (stripped), Drivers only, Road Runner, CentriFuse, EzSync
          99% done... [never completely finished... a continuing hobby]

          Comment


          • #6
            As I suspected in both RR.INI files you have this line:

            winampclass=winamp v1.x

            while you should have them different so that RR runs them on an "exclusive" and dedicated manner.

            Just try something like (1st RR.INI):

            winampclass=frontwinamp

            and (2nd RR.INI):

            winampclass=backwinamp
            Ride Runner RR's Myspace

            "Being happy is not about having what you want, it's about wanting what you have."
            "The best things in life are always free - but that doesn't mean money can't buy you good things."

            Comment


            • #7
              Guino

              Thanks to you, the GURU of car computers, I am now able to run 2 screens with totally different outputs.

              I am now going deeper into the multiple screen realm... When I am running both screens, GPS on #1 and a movie on #2... If you click on screen #1, the video lower video menu on screen #2 is brought up. Is there any way to halt this action?

              PS, I am using the BMV2 skins, and also tried the shocker skin.

              TIA,
              Tony
              Hardware: VIA-SP13000, M2-ATX, Voom case, HQCT, Linksys WiFi, Bluetooth, 512MB, 80GB, Dynamix 706.
              Software: XP Pro (stripped), Drivers only, Road Runner, CentriFuse, EzSync
              99% done... [never completely finished... a continuing hobby]

              Comment


              • #8
                I my self have alway kinda wondered about that setting...so I see that its really an 'rr' class for the winamp that it startup.

                @guino
                I would def change the wording in the Readme.txt(INI) so that it better describes what you said above. I think that would help for future inquiries...
                RideRunner...The #1 FE, PERIOD.

                Current Project: DFXVoice [v1.0 Released]
                Next in line: RRMedia v2.0

                DFX 5.1.1 Skin
                Appstore Link

                My RideRunner Plugins
                RRMedia
                RRExtended
                DFXVoice

                "There are no bugs - only undocumented features."

                Comment


                • #9
                  Originally posted by tonysch View Post
                  Guino

                  Thanks to you, the GURU of car computers, I am now able to run 2 screens with totally different outputs.

                  I am now going deeper into the multiple screen realm... When I am running both screens, GPS on #1 and a movie on #2... If you click on screen #1, the video lower video menu on screen #2 is brought up. Is there any way to halt this action?

                  PS, I am using the BMV2 skins, and also tried the shocker skin.

                  TIA,
                  Tony
                  Only real way to two different screens running nicely is to use two separate sound cards, then set 1 winamp to control 1 card, the 2nd to control the other, and set each RR to control each mixer.. that's the only way I can think of it.
                  Ride Runner RR's Myspace

                  "Being happy is not about having what you want, it's about wanting what you have."
                  "The best things in life are always free - but that doesn't mean money can't buy you good things."

                  Comment


                  • #10
                    Originally posted by tonysch View Post

                    When I am running both screens,
                    GPS on #1
                    movie on #2...
                    If you click on screen #1, the video lower video menu on screen #2 is brought up.
                    Is there any way to halt this action?

                    TIA,
                    Tony

                    Guino

                    I'm looking for this one too. Can the Video Player Menu be made to only pop-up when you click the video screen itself?

                    Mike

                    Comment


                    • #11
                      holy dead thread batman!

                      Comment


                      • #12
                        True, but has this been answered?

                        Comment


                        • #13
                          the answer is probably not. the video menu will always pop up when there is mouse movement. any time you touch on any RR, the mouse must move there. you could create a video_player.skin which is completely filled by the video screen and has no buttons on it. then, when you touch on your gps screen, the video screen "menu" will still pop up, but there actually will not be one since you filled the whole screen with video. hard to explain, but a simple concept. the only other thing i can think of is maybe setting your video player menu to disappear after 0 seconds or some small amount of time. that way when you touch on the other screen, the video menu disappears very quickly. just keep playin with it and messing with it and see what you can come up with... sorry if that doesnt help.

                          Comment


                          • #14
                            That's to bad. With Centrafuse you have to touch the screen to bring up the player menu.

                            Maybe redesign the popup so it isn't all the big so not to cover the video that much. Kinda a bummer, I like it when the menu only shows when you want it to..

                            Mike

                            Comment

                            Working...
                            X