Announcement

Collapse
No announcement yet.

Having Trouble With The Weather

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having Trouble With The Weather

    I am a complete Noob here and I am trying to play with a bunch of different features before installing my system into the car. I can't seem to get the weather skin to display any information. I am using the BMV2 skin that came with RR and I changed the XM button to the weather button. I even tried downloading another skin (Digital FX2.0) and I still saw no weather features.

    I have searched throughout this forum and found that other people had the problem of not having their city set, which I checked. I can't find any other solutions though.

    I got the gas price and traffic cams plugins working, so I know the internet connection is good.

    Does anyone have any ideas?

  • #2
    Do you have the weather images (downloaded from my website) ? Also, it helps trying a known city for instance like: Chicago, IL for instance... then if it works with a known place, try a different city of your liking.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

    Comment


    • #3
      Originally posted by guino View Post
      Do you have the weather images (downloaded from my website) ? Also, it helps trying a known city for instance like: Chicago, IL for instance... then if it works with a known place, try a different city of your liking.
      Thank you for the quick reply! But alas, I have tried that and it doesn't seem to be working. For some reason I feel like the commands in the skin are not going through. None of the "labels" (as discovered in the skin editor) are showing anything. For example, this code "w0dayicon", displays nothing when I am in RR. Do I need to add these commands to my ExecTBL.ini?

      Thanks again for your help!

      Comment


      • #4
        normally, setting the city weather and weather unit in RRConfig is all it takes -- as long as you have all the weather files in place. Are you by any chance using a stripped down version of the OS or anything like that? you could be missing some requires OS files to parse the weather information..
        Ride Runner RR's Myspace

        "Being happy is not about having what you want, it's about wanting what you have."
        "The best things in life are always free - but that doesn't mean money can't buy you good things."

        Comment


        • #5
          Nope, full xp install.

          Comment


          • #6
            Please, try the following:

            -Look in RR's folder for any .XML files.. if you find them, delete them.
            -Launch RR and open the Weather screen
            -Close RR
            -Look in RR's folder for any .XML files.. see if any were created.
            Ride Runner RR's Myspace

            "Being happy is not about having what you want, it's about wanting what you have."
            "The best things in life are always free - but that doesn't mean money can't buy you good things."

            Comment


            • #7
              I deleted a file called "commands.xml" (I might have put it there when I was getting the voice plugin to work). I opened up RR and went to the weather screen (still nothing) then closed it all and I don't see any new xml files.

              Sorry I am being such a hassle.

              Comment


              • #8
                sounds like a problem with the internet connection allright.. do you use a PROXY server to access the internet on your machine ?? If not, check for wininet.dll in your machine, make sure it exists and it's registered.
                Ride Runner RR's Myspace

                "Being happy is not about having what you want, it's about wanting what you have."
                "The best things in life are always free - but that doesn't mean money can't buy you good things."

                Comment


                • #9
                  I don't think I am using a proxy server (mostly because I am not sure what it is). I located the wininet.dll file in "C:\WINDOWS\system32" but when I tried to register it, I got an error message "C:\WINDOWS\system32\wininet.dll was loaded, but DllRegisterServer entry point was not found." I am not sure what any of this means.

                  PS - Are you sure it is the internet, my traffic cams and gas prices seem to be pulling information off the web?

                  Comment


                  • #10
                    Try opening this in your web browser:
                    http://xoap.weather.com/weather/loca...350c85242b4278

                    If it works, set your cityweather=Vila Velha, Brazil

                    See if it works in RR, if it doesn't, check your proxy settings on your browser:
                    IE - Menu Tools->Internet Options->Connections->Lan Settings (See if use proxy server is checked)
                    FireFox - Menu Tools->Options->Network->Settings (see if it's set to direct connect to the internet)
                    Ride Runner RR's Myspace

                    "Being happy is not about having what you want, it's about wanting what you have."
                    "The best things in life are always free - but that doesn't mean money can't buy you good things."

                    Comment


                    • #11
                      I checked through firefox and the "direct connect to the internet" is checked

                      Comment


                      • #12
                        I was able to go to that page as well.

                        Small sample of what I saw:
                        <weather ver="2.0">
                        <head>
                        <locale>en_US</locale>
                        <form>MEDIUM</form>
                        <ut>C</ut>
                        <ud>km</ud>
                        <us>km/h</us>
                        <up>mb</up>
                        <ur>mm</ur>
                        </head>

                        Comment


                        • #13
                          set your cityweather as I posted above, try it in RR, and if it still doesn't show anything, post your RR.INI (zipped preferably)
                          Ride Runner RR's Myspace

                          "Being happy is not about having what you want, it's about wanting what you have."
                          "The best things in life are always free - but that doesn't mean money can't buy you good things."

                          Comment


                          • #14
                            Thanks for your help!
                            Attached Files

                            Comment


                            • #15
                              NOTE: Guino, Just to cover one of the bases, he said he installed my DigitalFX skin. This also installs the weather icons that come with my skin in the Road Runner/Weather folder, so it should not be an icon problem.
                              Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                              My Fiero Build Thread

                              Comment

                              Working...
                              X