Announcement

Collapse
No announcement yet.

iGuidance and Volume -odd problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • iGuidance and Volume -odd problem

    Hello. I have tried everything to get my music to mute or lower the volume when iGuidance speaks however I have not been able to resolve it. Let me tell you what I have done to eliminate the possiblity to get flamed with the "search" term. Alright, here we go:
    • I am using the newest RR (9/7/2007) with the Blue ZX3 config util on Win XP.
    • I have my GPS settings set for External GPS with IG4 for the path. I have IG Native selected along with "Reduce Sound Volume to 10%".
    • Under the iG Native config, everything is checked including "Pause current player when voice directions are given".
    • Most importantly, I have lowered my iGuidance volume at least one notch below Winamp's.

    My ExecTBL has the line entered at the bottom as:

    Code:
    /,ADDED BY CONFIG "IGPAUSE","!PRESET;IG3;WINAMP||SETVOL;WINAMP;100"
    "IGRESUME","PRESET;IG3;WINAMP"
    (I have tried different values other than 100)

    My RR file looks like:

    Code:
    [General]
    winamppath=C:\Program Files\Winamp\
    hidewinamp=true
    launchpath=C:\Program Files\Road Runner\Launch\
    startcommand=
    voice=false
    disableinternat=true
    exitmute=true
    showicons=true
    showextensions=false
    hidemouse=false
    hidetaskbar=true
    hidedesktop=false
    hidedots=true
    gpstime=false
    gpsusadate=false
    exitmode=0
    dateformat=DD/MM/YYYY
    timeformat=HH:MM
    locale=0
    screentype=4:3
    debugmode=true
    enableclipping=true
    nozoom=false
    usegestures=false
    leavemousealone=false
    closeapps=false
    fastmode=-1
    usedualmon=false
    soundcard=0
    screenlimit=3
    mastervolmap=0
    hibernateaware=true
    forcehibernate=false
    hibernatereload=true
    usbsound=false
    browsertype=0
    browserpath=C:\Program Files\Mozilla Firefox\firefox.exe
    usevoicecontrol=false
    usecar2pc=false
    fadeinvolume=true
    
    [GPS]
    gpsmode=2
    mapmonkeypath=Click here to set path
    gpspath=C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe
    gpsname=iGuidance
    overspeed=55
    gpsport=4
    mappointmap=1
    mapcountry=United States
    mapcity=
    mapautozoom=true
    isunits=true
    usegpsserv=false
    gasfinderautorefresh=false
    mapvol=10
    
    [IG Native]
    ignative=true
    igautosw=true
    gpsonvoice=true
    pauseonvoice=true
    lastscreenswitchtime=0
    Can anybody help me please? My debug file has no instances of sending the IGPAUSE or IGRESUME command when IG speaks. I have tried this on new installs of RR with no success. Thank you.

  • #2
    iG4 and volume lowering does not work by many reports.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

    Comment


    • #3
      I notice that the 'added by config' line hopefully does not look like that exactly in you exectbl file. There should be a total of three lines like this:
      Code:
      /,ADDED BY CONFIG 
      "IGPAUSE","!PRESET;IG3;WINAMP||SETVOL;WINAMP;100"
      "IGRESUME","PRESET;IG3;WINAMP"
      RideRunner...The #1 FE, PERIOD.

      Current Project: DFXVoice [v1.0 Released]
      Next in line: RRMedia v2.0

      DFX 5.1.1 Skin
      Appstore Link

      My RideRunner Plugins
      RRMedia
      RRExtended
      DFXVoice

      "There are no bugs - only undocumented features."

      Comment


      • #4
        Thanks blue, there are really 3 seperate lines. i missed fixing that after I copied and pasted. i just upgraded to 4 a few days ago. i actually created the content for the post when i was using iG3. everything above was the exact configuration I had for iG3 and it wouldn't work. I'll try any suggestions on either an iG3 install or iG4 install.

        Comment


        • #5
          I do know that some have had trouble with those lines and have subsituted others for them using iG3. I don't have 4 so Im sure sonic is correct in that there is an issue with it.

          I cant remember where those other lines that might work might be at...try a little search and see if you can quickly find them.
          RideRunner...The #1 FE, PERIOD.

          Current Project: DFXVoice [v1.0 Released]
          Next in line: RRMedia v2.0

          DFX 5.1.1 Skin
          Appstore Link

          My RideRunner Plugins
          RRMedia
          RRExtended
          DFXVoice

          "There are no bugs - only undocumented features."

          Comment


          • #6
            I have been using iG4 with the native features for around a month, with no issues. It lowers the volume, as well as auto switches to iGuidance from another screen when a turn is detected.

            This worked perfectly soon as i installed iG4, and made no alterations at all. (I had it working with iG3 so it was all setup) I have found it is usually just a matter of getting the volume lines set correctly. I leave iGuidance at 100% volume, and reduce the wave line to like 80% or so. This has worked well for me.
            Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

            My Fiero Build Thread

            Comment


            • #7
              I also have IG4 and it works for me...i have my IG volume very low and my wave line at 100% and winamp at max (outside of RR)

              in EXECTBL.INI i have:

              "IGPAUSE","SETVOL;WINAMP;192"
              "IGRESUME","SETVOL;WINAMP;255"

              in RR.INI

              pauseonvoice=true
              gpsonvoice=true
              igautosw=true

              Comment


              • #8
                Hey Blue, are these the lines you were referring to?

                Code:
                "IGPAUSE","!PRESET;IG3;WINAMP||SETVOL;WINAMP;20||BYIND;LINEMUTE;MUTE;Line in<<||BYIND;AUXMUTE;MUTE;Aux Volume<<"
                
                "IGRESUME","PRESET;IG3;WINAMP||BYIND;LINEMUTE;<<MUTE;Line in||BYIND;AUXMUTE;<<MUTE;Aux Volume"
                Tried those, still no go.

                JohnWPD, my volume settings are just like yours but it does not make a difference.

                Does anybody think this could be an issue with sound card settings? Both my RR and iG use the WAVE input on my soundcard. When the iG lady speaks and lets say my iG volume is at 50%, my RR music volume goes down to 50% and iG speaks at 50%. Is this correct or should they be separate?

                Comment


                • #9
                  Ya, that would probably be the reason. Most users use the master vol in RR, so try setting it like that and see if you get better results.
                  RideRunner...The #1 FE, PERIOD.

                  Current Project: DFXVoice [v1.0 Released]
                  Next in line: RRMedia v2.0

                  DFX 5.1.1 Skin
                  Appstore Link

                  My RideRunner Plugins
                  RRMedia
                  RRExtended
                  DFXVoice

                  "There are no bugs - only undocumented features."

                  Comment


                  • #10
                    Nah, I was incorrect. RR was already set to Master volume...I remember I had it as WAVE when I first installed but changed it to Master after I got my Powermate knob a few months ago. Any other suggestions? Is there something I should look at in the debug that I may be missing or is there any way to test the sensitivity of RR for detecting iG's voice?

                    Comment


                    • #11
                      To the people who say it's working for them: Is the music actually pausing or is it just lowering in volume?

                      Comment


                      • #12
                        Someone posted on the DigitalFX thread that this has something to do with the volume set in iGuidance itself -- doesn't hurt to check/try it.
                        Ride Runner RR's Myspace

                        "Being happy is not about having what you want, it's about wanting what you have."
                        "The best things in life are always free - but that doesn't mean money can't buy you good things."

                        Comment


                        • #13
                          Well, I got mine working somehow. I updated my skin to Polaris and updated to the newest config file from Blue and its working. Strange but thanks for all the help!

                          Comment


                          • #14
                            Originally posted by sparkyssb View Post
                            Well, I got mine working somehow. I updated my skin to Polaris and updated to the newest config file from Blue and its working. Strange but thanks for all the help!
                            Are you saying iGuidance is pausing during directions or that the volume is just decreasing? It is decreasing for me as well, but those of us who are frustrated want it to pause like it used to.

                            Guino, you are right that pausing depends (or at least used to depend) on the relative volume levels of iGuidance and the system.

                            Comment


                            • #15
                              It is decreasing in volume.

                              Comment

                              Working...
                              X