No announcement yet.

iG and RR - GPS Port Issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • iG and RR - GPS Port Issue

    Alright...iG works fine stand alone. It uses the GPS on com 6. I am using Blue's config utility to setup iG with RR and I have no probs embedding iG with RR, except that it does not see the GPS data, even though I had the GPS port set to 6 within the RR config utility. So then I setup Xport and told com 6 to duplicate into com 10. Then I setup RR with the GPS port of 10........still no go. Any ideas on what I'm doing wrong? Thanks.

  • #2
    you have to think of it as a splitter. Xport has to send the COM data from port #6 to 2 other ports. Then iGuidance needs one of those split ports and RR needs one of those split ports. If iG is using #6, then Xport cannot, and then cant send it out tothe other ports.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the Store


    • #3
      Sparky, here's what you need to do:

      Close Xport. Open iGuidance outside of RR. Go to tools/GPS Options/autodetect. After a minute or so it will tell you what com port iGuidance is using (should be 6 per your post). That's the port your GPS receiver is using and should be the port set as input in Xport. Exit iG.

      Now load Xport. In Xport set the input port to the port determined above. In Xport hit scan. Then pick two available com ports in the output section. Make a note of the two outputs you have chosen. The first output port will be for iG and the second will be for RR. Hit enable in Xport. (Try to make the port you use for iG only one digit as some have reported problems with iG if using a two digit port.)

      Open iGuidance outside of RR. Go to tools/GPS Options/com port and select the first output port selected in Xport per the above. Exit iGuidance. Go into RRConfig and in the GPS section put the number of the second output port in Xport per above. Save config. All should now work.


      • #4
        Awesome. Thanks to both of you guys, I got it to work! Take care.