Announcement

Collapse
No announcement yet.

Whats wrong with my album art?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Whats wrong with my album art?

    I searched and didn't find anything so sorry if this has been covered.

    I recently re organized all my music files and used google images to download album art into the artist folders and the album folders. The problem I'm having is that a few artist won't have any album art showing in road runner. Also it only show the album art that is in the artist folder and not the album folder. I used the .bat command in the FAQ and that didn't help and I have double checked the files when the art doesn't show up and it's there. All files are labeled folder.jpg or image.jpg
    Anyone know whats wrong?

  • #2
    artist folder.. album folder??? you are confusing me.... U just need one folder.jpg per folder... u can call that folder whatever u want, artist, album... doesn't really matter..

    if a folder contains a sub folder and you want to represent the sub folder with a different jpg then you should have a different folder.jpg in that sub folder.... Otherwise, what's in the root folder will be used for all folders under it.. The way i setup, I have the total number of folder.jpgs equels the total number of my music folders...

    Comment


    • #3
      rr.ini
      coverfile=*.jpg
      Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

      Comment


      • #4
        Originally posted by brandensin View Post
        artist folder.. album folder??? you are confusing me.... U just need one folder.jpg per folder... u can call that folder whatever u want, artist, album... doesn't really matter..

        if a folder contains a sub folder and you want to represent the sub folder with a different jpg then you should have a different folder.jpg in that sub folder.... Otherwise, what's in the root folder will be used for all folders under it.. The way i setup, I have the total number of folder.jpgs equels the total number of my music folders...
        yeah sorry thats what I mean, I have an artist image in the root folder and album images in all the sub folders.

        Comment


        • #5
          If they are all .jpg files (I once had a couple of BMP files that were mislabeled), and you have the setting Sal R. said to implement, then my guess is some still have a hidden file flag set. The batch file method to fix it did not work for me after I had once let Zune software have it's way with the images. I had to download and use a piece of software to force the issue. There are probably many that can do it, but the specific one I used is called albumartfixsetup.msi

          Comment


          • #6
            i think you're right. I used the ini setting and I am still having problems. Pretty much 1 out of 5 sub folders displays it's album arts and the rest just show the root folder art. Can it still have a hidden flag if it shows up when you view the folder?

            Comment


            • #7
              ok I checked the properties on some of the album art files that weren't showing and sure enough they where checked as hidden and grayed out so they couldn't be unselected. I will try that program tonight. Thanks for the help.

              Comment


              • #8
                Does anyone have any better ideas on how to get these files unhidden? I don't have the time to use that program to go through every album folder.

                Comment


                • #9
                  Try the cmd line I posted in this thread:

                  http://www.mp3car.com/vbulletin/1151429-post1849.html

                  That should fix you up.

                  Cheers
                  For once you have tasted flight you will walk the earth with your eyes turned skywards, for there you have been and there you will long to return.
                  Leonardo Da Vinci

                  Comment


                  • #10
                    no that didn't work, thats like the command line in the album art FAQ. This is driving me nuts! No matter what I do i can't unhide the album art files. They show up in explorer but when you check the properties the hidden check bok is selected and can't be unchecked.

                    Comment


                    • #11
                      something (likely to be windows media player) is hiding/protecting your images. If attrib is not working to remove the hidden flags, you may need to login as Administrator before you can do it (or give yourself enough rights to modify the files).
                      Ride Runner RR's Myspace

                      "Being happy is not about having what you want, it's about wanting what you have."
                      "The best things in life are always free - but that doesn't mean money can't buy you good things."

                      Comment


                      • #12
                        I have logged in as the administrator and no matter what i do I can't uncheck it as a hidden file. It says in the properties I should have full control but the hidden flag is uncheckable.

                        Comment


                        • #13
                          Try putting this in a file named unhide.bat place this file in your main music folder and run it. It will go to all your subfolders and change all the jpg files to be unhidden. If you have bmp or png files then change the extension.

                          unhide.bat
                          Code:
                          attrib *.jpg -h -s /S
                          Enjoy!
                          Rich

                          Comment


                          • #14
                            Originally posted by RichP714 View Post
                            Try putting this in a file named unhide.bat place this file in your main music folder and run it. It will go to all your subfolders and change all the jpg files to be unhidden. If you have bmp or png files then change the extension.

                            unhide.bat
                            Code:
                            attrib *.jpg -h -s /S
                            Enjoy!
                            Rich

                            I've been having the same problem and found this solution:


                            Take the following script and put into a text editor and save it as UnHide.vbs. You can put it anywhere.

                            Then using windows explorer drag the root directory of your music folders onto the icon for the saved file. This will traverse that entire directory turning off the Hidden attribute on all hidden files.

                            Code:
                            Dim FSO, Arg 
                            On Error Resume Next 
                            Arg = WScript.Arguments(0) 
                            Set FSO = CreateObject("Scripting.FileSystemObject") 
                            If FSO.FolderExists(Arg) = False Then DropIt 
                            UnHide Arg 
                            DropIt 
                            
                            Sub UnHide(FPath) 
                                Dim oFol, oFols, oFol1, oFils, oFil, iAt 
                                On Error Resume Next 
                                Set oFol = FSO.GetFolder(FPath) 
                                Set oFils = oFol.Files 
                                For Each oFil in oFils 
                                    '-- To remove all attributes - read-only, hidden, 
                                    '-- system, etc. - use this line: 
                                    ' oFil.Attributes = 0 '--all 
                            
                                    '-- To only unhide files, use these 3 lines: 
                                    iAt = oFil.Attributes '--hidden 
                                    If (iAt And 2) Then iAt = iAt - 2 '--hidden 
                                    oFil.Attributes = iAt '--hidden 
                                Next 
                                Set oFils = Nothing 
                            
                                Set oFols = oFol.SubFolders 
                                For Each oFol1 in oFols 
                                    Unhide oFol1.Path 
                                Next 
                                Set oFols = Nothing 
                                Set oFol = Nothing 
                            End Sub 
                            
                            
                            Sub DropIt() 
                                Set FSO = Nothing 
                                WScript.Quit 
                            End Sub
                            BTW - I did this on mine and it changed the attributes but I still have some folders where the art doesn't show...

                            Comment


                            • #15
                              Originally posted by RichP714 View Post
                              Try putting this in a file named unhide.bat place this file in your main music folder and run it. It will go to all your subfolders and change all the jpg files to be unhidden. If you have bmp or png files then change the extension.

                              unhide.bat
                              Code:
                              attrib *.jpg -h -s /S
                              Enjoy!
                              Rich
                              yeah this doesn't work for me, somehow my older album art work got permanently flagged as hidden. It makes no sense to me, I am just going to re download the the album art.

                              Comment

                              Working...
                              X