No announcement yet.

Weird problem with USB sound card

  • Filter
  • Time
  • Show
Clear All
new posts

  • Weird problem with USB sound card

    Recently my sound card (on mobo) started acting up so I decided to reinstall my Phillips PSC805 Aurilium USB External Sound Card. As soon as I installed it, for some reason everything started crawling. I am using Digital Fx 3.0 and as soon it starts my CPU goes 100%.

    I uninstalled the Philips software and used the default USB sound card driver in XP but same result. Outside RR, everything works fine so I'm not sure what's causing the CPU to go 100% as soon as RR starts. Before installing the sound card, everything was working fine.

    I've already tried RR setting of mapping sound to "all lines" and "master vol" but nothing changed

    Any idea ?
    04 Accord Coupe Carputer

  • #2
    Anyone ?????
    04 Accord Coupe Carputer


    • #3
      did you disable the built-in sound card? chances are the drivers/files you loaded overwrote something previously installed.
      Ride Runner RR's Myspace

      "Being happy is not about having what you want, it's about wanting what you have."
      "The best things in life are always free - but that doesn't mean money can't buy you good things."


      • #4
        Yea, i had the same problem a couple months ago. It was the driver like guino said. I uninstalled the onboard driver and then disabled it through the BIOS.