Announcement

Collapse
No announcement yet.

clicking button through a label

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • clicking button through a label

    when i have a label over my button, some buttons work just fine, but some do not. pretty much only experiencing this problem with labels which are variables.

    what happens is this:
    -when i click on some of my buttons which have labels (of variables) over them, it acts like i clicked and held. however, this phenomena only occurs if i click specifically on the label. if i click on the button part that is not covered by a label, it works fine. something about some of my labels is causing my button press to simulate a button press+hold. it even happens in flash. however, it doesnt happen in every situation, only some.... any ideas?

  • #2
    Don't use a button over a label. Use a Label over the Label with the code
    "Lxxxx"EXEC;LOAD;<<YOUR COMMAND HERE>>"

    Comment


    • #3
      Originally posted by MGD View Post
      Don't use a button over a label. Use a Label over the Label with the code
      "Lxxxx"EXEC;LOAD;<<YOUR COMMAND HERE>>"
      i'll give that a whirl. thanks

      EDIT: not sure i understand. in my label i put "EXEC;LOAD;EDIT"
      -EDIT is my RR command

      EDIT again: tried "EXEC;EDIT" still nothing. im confused....

      Comment


      • #4
        As long as EDIT is defined in your exectbl.ini it should work. (EXEC on a label doesn't support click and hold, so that should solve the isse.)
        2007 Chrysler PT Cruiser TE
        Car PC Progress:
        Planning.......[---------X-] 95%
        Parts...........[---------X-] 90%
        Fabrication...[---------X-] 90%
        RR Skin........[---------X-] 95%
        View my
        Worklog
        Road Runner Skins
        Website
        Favorite thread EVER!

        Comment


        • #5
          Try this example in this format:
          L,245,445,310,35,,,,,,"EXEC;EDIT||=",
          ...JJG

          Comment


          • #6
            Oh, yeah, I forgot that the label has to contain characters of some sort. So either it can be:

            L,245,445,310,35,,,,,,"EXEC;EDIT||=",

            or

            L,245,445,310,35,,,,,,"EXEC;EDIT||=Edit",

            Either one should work.
            2007 Chrysler PT Cruiser TE
            Car PC Progress:
            Planning.......[---------X-] 95%
            Parts...........[---------X-] 90%
            Fabrication...[---------X-] 90%
            RR Skin........[---------X-] 95%
            View my
            Worklog
            Road Runner Skins
            Website
            Favorite thread EVER!

            Comment


            • #7
              ok, got it working. problem.

              i have three labels that cycle on a timer event (TAGTITLE, TAGARTIST, & TAGALBUM). i have tried a byvar event and adding my command to each condition of the byvar statement. i have also tried creating 3 separate labels, using SHOWLABEL, and putting the EXEC;command on each. however, i have different commands for each label, and if i hide the top label to show the second or third label, and then click on it, it will use the command from the top label, whether it's hidden or not. anybody think of another way around this?

              EDIT: figured it out. i dont wanna type it out as to how i did it, but if someones curious just let me know and ill do my best to explain


              >>The purpose of all this creates this effect:
              -An area cycles through the Current Song Playing, the Artist, and the Album. Clicking on the area when it shows the label allows you to edit the track ID3 info, when it shows the artist to edit the artist ID3 info, and when it shows the album to edit the album ID3 info.

              Comment


              • #8
                Also, figured out specifically when this happens. if you have a label over a button set to "Scroll-Center" (idn about scroll left or right), the button doesnt work as it should

                Comment


                • #9
                  Strange things happen with the "Scroll" Stuff. The text isn't Transparent, so if you have a label on top of a label, then it will only show the top label. Glad you got it working.
                  2007 Chrysler PT Cruiser TE
                  Car PC Progress:
                  Planning.......[---------X-] 95%
                  Parts...........[---------X-] 90%
                  Fabrication...[---------X-] 90%
                  RR Skin........[---------X-] 95%
                  View my
                  Worklog
                  Road Runner Skins
                  Website
                  Favorite thread EVER!

                  Comment

                  Working...
                  X