No announcement yet.

RR with GMPC

  • Filter
  • Time
  • Show
Clear All
new posts

  • RR with GMPC

    What skins are those of you with Garmin Mobile PC using to get this to look right. I'm having the darndest time getting a good screen layout with the few I have tried, Crystal blue, DFX, carwings, ect.....

    any tweaks I can do with RR Config to get the rez/win sizes to mesh and look right?

  • #2
    I use the default skin with the GMPC and everything works and looks OK.


    • #3
      i just dont like how whenever something is done in RR it flashes and goes to the front...

      this doesnt happen when i use IG4


      • #4
        Yea! I can't figure that out either... I thought it was a setting I missed.

        Is there anyone using GMPC successfully embedded in RR?


        • #5
          DFX 4.0 has screens for GMPC; nst6563 created them


          • #6
            Originally posted by Machinehead View Post
            DFX 4.0 has screens for GMPC; nst6563 created them
            i using it and it still flickers... :-/


            • #7
              I'm (very) new to this forum, let alone skinning for RR, but I managed to hack together a skin based on nst6563's GARMIN_WIDE (see this post) that also incorporates an OSK that's working pretty well so far for my 7" touchscreen.

              The changes:
              • Replaced song title with OSK button
              • Clipped slightly less off the top of the app

              The OSK is just a button on the bottom; when you're searching by city or POI, this will clear anything already in the text field, giving you a blank field, and then placing the text from the OSK. It's not quite as nice as being able to spell one letter at a time and seeing results (which their POI search would normally do) but hey, it works!

              Feel free to make modifications, in particular, if anyone has a better idea for how to clear the POI search text field other than sending a bunch of SENDKEY;{BS} signals?
              Attached Files


              • #8
                GMPC really needs a OSK anyone!


                • #9
                  Originally posted by dmistry View Post
                  GMPC really needs a OSK anyone!
                  I know! And out of desperation I hacked a simple OSK button into nst6563's GARMIN_WIDE skin (integrates nicely with Digital FX 4.0). I tried posting it as an attachment, but it's awaiting moderator approval.

                  In the meantime, for folks who are itching to use GMPC on their touchscreen (like I was) here's my modification:

                  ---> Garmin_Wide (edited by kuranuk)

                  I just added a button to the garmin gps screen that clears the text input field, calls up a OSK, then puts it into GMPC. It's not a perfect solution, as you can't type and watch the search results narrow as you add letters, or change a spelling as you type, but it works enough to use on the touchscreen!

                  To install, refer to the included readme, and nst6563's original post.


                  • #10


                    • #11
                      Some screenshots, FTW

                      EDIT: I hope noone regards this as solved, my build is very new, so this was just a quick hack. If anyone could implement a transparent, immediate entry keyboard that would be much better!


                      • #12
                        Working on it...
                        New Age Garmin - Skin for RR
                        New Age Slider - RR SKin In Progress
                        "It's called CODE because I don't want you to know"


                        • #13
                          DFX 4.0 does....however i can't really get it work.

                          Anyone else have this issue:
                          - attached the "Garmin GPS" button
                          - change the ini file so it points to drive C instead of I

                          But when i push the GPS button nothing happens just blank screen.
                          However if you start GMPC manually, then the button on the DFX skinn does work and you can go in and out of the menus without issue.

                          SO the problem is that GMPC won't start up using dedicated "garmin GPS" button.
                          But if i change the GPS button to iGuiadance, Garmin will start.

                          Any special config to make GMPC work correctly?


                          • #14
                            Originally posted by CannonBaller View Post
                            Any special config to make GMPC work correctly?
                            I haven't had that issue, but I have a working config, so I'll share...

                            First, in the Exectbl.ini I have this for the Garmin entry:
                            "MyApp48","Load;;Garmin;C:\GarminMobilePC\Que.exe;Garmin||ACTIVATE;Garmin Mobile PC"
                            Then, in rr.ini, I have iGuidance set up (for "normal" GPS, in case GMPC is being weird)
                            gpspath=C:\program files\iNav\iGuidance\iGuidanceUMPC.exe
                            I actually only just now noticed the ""Garmin","LOAD;;!CDP_FIELD_WND;I:\ GarminMobilePC\Que.exe;!CDP_FIELD_WND" in the external apps section, and actually I haven't changed the I: and my setup is working, though my app is located in c:.

                            I guess I'm not using that method to load GMPC? Maybe that's the issue.


                            • #15
                              Rr gmpc & osk

                              Hi All,

                              My first post here...

                              I have been putting my carpc together for a while collecting as much info as possible. Thank you.

                              Anyway last night while doing some more benchtop testing, i managed to get the std BMV2 OSK to work by adding the following in the file;


                              I know that I will not see any button there (until the actual graphic is changed) but now if a press and hold in the location next to the close button the OSK appears and able to enter the text.

                              I thought that was a great win for me considering it was my very first attempt and all.

                              My next quest is to have the text cleared when the OSK opens and the backspace to work correctly for entered text (I am sure some here has a fix for this)