Announcement

Collapse
No announcement yet.

ID3 versions, what does RR use?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ID3 versions, what does RR use?

    I have nearly 5,000 songs tagged using a Tagrunner. Problem is cetain ones just won't seem to show up in RR. Certain bands typically. I will clear their Id3 tags out completely and use this software that automatically tags them. In RR only the file name seems to show up and no Artist or album info. I have tried to set RR to use all versions. What versions of Id3 1 and 2 can RR see?

  • #2
    Originally posted by Dougw133 View Post
    I have nearly 5,000 songs tagged using a Tagrunner. Problem is certain ones just won't seem to show up in RR. Certain bands typically. I will clear their Id3 tags out completely and use this software that automatically tags them. In RR only the file name seems to show up and no Artist or album info. I have tried to set RR to use all versions. What versions of Id3 1 and 2 can RR see?
    Doug, Mine does the same thing and like you, I erased and re-tagged them and even switched between the id3's, no dice. I had been trying to figure that out for a while but no big deal for me, I can live with it. However if their is a solution
    If you cant DODGE em, RAM em.

    Comment


    • #3
      what tag settings do you have selected in rrconfig? try using id3v1 tags mixed with id3v2 and check the settings that your tagging software is using. rr does not like the tags with unicode in them, the tags will show up with strange characters in the name (speaking only for some of the older versions of rr).

      Comment


      • #4
        It's also possible that Tagrunner is the problem and isn't creating compliant tags.

        Comment


        • #5
          what tag settings do you have selected in rrconfig? try using id3v1 tags mixed with id3v2 and check the settings that your tagging software is using. rr does not like the tags with unicode in them, the tags will show up with strange characters in the name (speaking only for some of the older versions of rr).
          It's also possible that Tagrunner is the problem and isn't creating compliant tags.
          Speaking for myself (Sorry Doug not trying to thread-jack) I've tried manually editing the tags when they didn't display correctly in rr and the out come was the same also in my case, the mixed setting is checked in the config.
          If you cant DODGE em, RAM em.

          Comment


          • #6
            Originally posted by Ramanator View Post
            Speaking for myself (Sorry Doug not trying to thread-jack) I've tried manually editing the tags when they didn't display correctly in rr and the out come was the same also in my case, the mixed setting is checked in the config.
            Exactly my problem too...I have tried manually editing them in windows by clicking properties. Redo it all and it still won't work. This is why I am wondering if sometimes Tagrunner might grab some ID3's from itunes or something and tag them with an incompatible Id3 as Machinehead said above. So I am curious if it's possible even though I try to manually edit them etc... if they might be of an incompatible tag regardless if the song, artists, etc.. is correct. I know there is several kinds of each version, like ID3 V1.2 , V1.3 , V.1.4 and then V2 has it's own separate few.

            Comment


            • #7
              try tagscanner.. it is the best out there and it is free

              Comment


              • #8
                I use a program called Tag&Rename, it isn't free but it does have a free trial period. It does give me tags that work in Road Runner.

                Comment


                • #9
                  I had this problem also with ID3's not showing up in RoadRunner. I download ID3-TagIT 3 and when i opened the program the ones that werent working in RR didnt show the tag information in ID3-TagIT... and usially it would only say there was a version 1 tag or ver 2 tag but not both... it would try to convert the tag versions and edit the tags in the software but it would go back to how it was... Oh yea and all the music came out of itunes...

                  I don't know how i came about to finding this but it worked - I opened the folder in windows that had the songs, right clicked on them then clicked properties, then chose the Summary tab. In there (under simple not advanced) if there is anything in the comments box erase it, if there is nothing just click in the box hit backspace once then hit ok... I did this to all my MP3s that werent showing tags right and now they work perfectly... I don't understand it, but it worked for me. Give it a try!

                  Comment


                  • #10
                    Just a note:

                    If you are manually editing the tags with Media Player, it just changes the tags in the library, and does not write the tag info into the MP3 itself.
                    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                    My Fiero Build Thread

                    Comment


                    • #11
                      Originally posted by Machinehead View Post
                      I use a program called Tag&Rename, it isn't free but it does have a free trial period. It does give me tags that work in Road Runner.
                      Yeah I just got this and hoping it will give me more options for which versions of the tags I can save. I read somewhere else a while back RR only recognizes V.3 or lower, and V2.2 or lower. Itunes and newer stuff tags Id3 V2.4 or something. I don't use Itunes or media player so this must happen with where i get my files from"

                      Comment


                      • #12
                        Alrighty....I am finding something in common with all the ones that don't seem to work. They are .wma files and not mp3's. I am able to tag them correctly using Tag&Rename.

                        Comment


                        • #13
                          Okay, I'll hit the dumb question first, do you have the wma file extension type set up in RRconfig?

                          Comment


                          • #14
                            Originally posted by Machinehead View Post
                            Okay, I'll hit the dumb question first, do you have the wma file extension type set up in RRconfig?
                            Haha yes sir...From what I can gather is that the WMA's I have must have been tagged by Windows Media or some other program and in an incompatable version. If I open them in Tag&Rename and not touch anything but clicking "Save" it saves them to it a different version of ID3 which is showing up in RR and working for me.

                            Comment


                            • #15
                              We'll.....It seems to me that Itunes is the culprit. All my problems also seem to find Tag and Rename stating the file was tagged with Itunes version. who cares. My how I hate itunes.

                              Anyhow I can't seem to get a sucessful readable tag out of these files even when I clean the tag out and retag it.

                              Comment

                              Working...
                              X