Announcement

Collapse
No announcement yet.

DTR signal COM1 during boot?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DTR signal COM1 during boot?

    I will show my situation :

    Got IBUSCOMM configured to set DTR signal COM1 high when a certain IBUS (BMW Vechicle Bus signal) is received (when i press a button on the dash),
    Then the BMW thinks when DTR is high (connected to module in car) reverse drive is activated and switchs o Rear Camera input (which is connected to TV-Out of car-pc)
    It works good! But during boot-up of windows now and then (even when logged in) windows sets COM1 DTR signal a few times to High (so see parts of booting of windows xp) until fully booted up,then it works as its supposed to be.

    Already did /fastdetect
    and SkipEnum in Regedit to avoid windows to search for serial attached devices and this way set DTR signals sometimes to HIGH during boot.

    Someone got same situation or any advice ? I am desperate,
    System works but dont want to see boot proces on screen till fully booted up.

  • #2
    From what I know this is a problem with either para/ser ports in windows, and there is no way to work around it, just random data sent to port at startup.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

    Comment


    • #3
      I solved this problem back in 2007. A later later when I made a second carpc, it took me a while to locate the article on how to fix this, but I posted it on here for future reference.

      http://www.mp3car.com/vbulletin/1200508-post126.html

      Comment


      • #4
        Thanks both,
        But like i said i already modified the registry with the Serenum and it doesnt work,what value DWORD did you use ? (HEX)?
        Also a tool from microsoft COMDISABLE (doesnt disable port itself but scanning, but that doesnt do the job either, drives me craxy
        anyone ? Blackstealth?

        Comment


        • #5
          Below is an example of what I use for COM6 on my FTDI USB to serial adapter.

          ------------------------------
          Windows Registry Editor Version 5.00

          [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\F TDIBUS\VID_0403+PID_6010+5&64cc6dc&0&2&1\0000\Devi ce Parameters]
          "PortName"="COM6"
          "PollingPeriod"=dword:00000000
          "ConfigData"=hex:11,00,3f,3f,10,27,00,00,88,13,00, 00,c4,09,00,00,e2,04,00,00,\
          71,02,00,00,38,41,00,00,9c,80,00,00,4e,c0,00,00,34 ,00,00,00,1a,00,00,00,0d,\
          00,00,00,06,40,00,00,03,80,00,00,00,00,00,00,d0,80 ,00,00
          "MinReadTimeout"=dword:00000000
          "MinWriteTimeout"=dword:00000000
          "LatencyTimer"=dword:00000010
          "SkipEnumerations"=dword:ffffffff

          Comment


          • #6
            Here's COM1 for my on board serial port.

            -----------------------------------
            Windows Registry Editor Version 5.00

            [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\A CPI\PNP0501\1\Device Parameters]
            "FirmwareIdentified"=dword:00000001
            "PortName"="COM1"
            "PollingPeriod"=dword:00000000
            "SkipEnumerations"=dword:ffffffff

            Comment

            Working...
            X