Announcement

Collapse
No announcement yet.

Can't get DVDs to play within RR

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get DVDs to play within RR

    I can play DVDs with Mplayerc.exe or VLC when launching outside of RR. But if I try to launch a DVD from within RR it does not even get my DVD drive to trigger.

    I have tried setting up RRConfig to use built in VLC option and have also tried with the MPC option.

    I have tried with CArwings skin and Elite Lite skin.

    Can any of you folks help me figure what i am doing wrong?

    VLC : 1.0.1 Goldeneye
    MPC: 6.4.9.0 (supplied by RR)
    OS: WXP
    PC: Dell Insprion E1505

    Excerpts from RR.ini file:

    [Video Player Setup]
    videoplayer=VLCVidRR
    mpcpath=C:\Program Files\Road Runner\mplayerc.exe

    [Video]
    videopath=D:\VIDEO_TS\
    videoautohide=true
    videohidetime=4
    videofiles=.asf,.avi,.m2v,.mpeg,.mpg,.nsv,.vob,.wm v
    videoshuffle=false

    [DVD Player Setup]
    dvdplayer=MPCVidRR

    [Extra's]

    hddebug=false
    hibernatereload=true
    builtinvideo=true

    Thanks,
    randy

  • #2
    What skin are you using ?
    Did you try another skin ?
    Can you make a debug log ?
    From your INI settings, seems like you are trying (or tried) to play DVDs from the VIDEO player -- which is NOT possible. DVD playback has to be done using the DVD command.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

    Comment


    • #3
      Hi Guino, thanks for the response.

      I tried the following skins with same results: Carwings, Elite Lite, and DigitalFX. I just downloaded those last two within past week so I figure they are current.

      Yes I did try playing DVD via Video at one time, but realized my error after reading through the forum.

      I will try and create a debug log later today. I guess I can make that happen by editing RR.ini under
      [Extra's]
      hddebug=false (change this to True?)

      thanks

      Comment


      • #4
        I just finished trying again using Digital FX skin. I am attaching my debug file.

        thanks
        randy
        Attached Files

        Comment


        • #5
          Is there any other information that I can provide to help figure out what might be happening here?

          thanks,
          randy

          Comment


          • #6
            humble bump?

            Comment


            • #7
              Wasn't RR changed to have a dedicated dvd_player.skin for DVDs?
              Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

              Comment


              • #8
                Indeed.

                Comment


                • #9
                  I am trying to launch from within the the DigitalFX 4.0 skin with menu item labeled "DVD". It opens a screen that looks like its dedicated to DVDs. Maybe I am misunderstanding how things are supposed to work, admittedly, I am a total nube.

                  randy

                  Comment


                  • #10
                    Originally posted by randy80 View Post
                    I am trying to launch from within the the DigitalFX 4.0 skin with menu item labeled "DVD". It opens a screen that looks like its dedicated to DVDs. Maybe I am misunderstanding how things are supposed to work, admittedly, I am a total nube.

                    randy
                    Based off the debug, RR doesn't looke like it's loading dvd_player.skin. The skin might not have been updated to accomodate it.
                    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

                    Comment


                    • #11
                      Thanks Sal. R. I will pursue that track.


                      thanks again
                      randy

                      Comment


                      • #12
                        Did you set the DVD drive setting in VLC before trying to use it in RR?
                        Ride Runner RR's Myspace

                        "Being happy is not about having what you want, it's about wanting what you have."
                        "The best things in life are always free - but that doesn't mean money can't buy you good things."

                        Comment


                        • #13
                          The default drive for DVD was not set in VLC or MPC. AFter the above Guino post I went and made sure those were set and retried. Tried with VLC as DVD player of choice and also tried with MPC as player of choice in RRconfig. Still neither one will launch a DVD from within RR.

                          On SAl. R.'s suggestion of making sure dvdplayer.skin is loading, I am not sure how to check that. Within DFX4 when i click the DVD menu item, a screen loads and then after a second or two the controls at bottom of screen go away and a full screen of black appears with aspect ratio displayed for another second or two. I can click the black screen and it displays the word Controls and I can click that and get the DVD controls back at the bottom of the screen. If i click the Browse button on those controls - nothing happens. I can click the Aspect Ratio button and on the black part of the screen the different ratios are toggled through as i click the button.

                          As a side note in case it is relevant: When i access the Video menu item from main menu, that works and i can play videos from my hard drive AND use the browse button, etc.

                          So if it still sounds like my DVDPlayer.skin is not loading when i click the DVD button on main menu, can you tell me how/where i can check to confirm that? Again i apologize for my newbiness.

                          thanks,
                          randy

                          Comment


                          • #14
                            Looking at your debug.txt it seems that DigitalFX4.0 opens the video_player.skin when the command DVD is executed.
                            This may just happen when the DVD command has been changed in the ExecTBL.ini.

                            Go to your DigitalFX4.0 skin directory. Is there a file called dvd_player.skin ? If not, then DVD-functionality hasn't been added to the skin.
                            If the file is there, change the "DVD","...... entry in the ExecTBL.ini (I suppose it has such an entry then) to load the dvd_player.skin, instead of video_player.skin.

                            Comment


                            • #15
                              There is no dvd_player.skin in any if the skin directories i have downloaded: DsFX4, Carwings (came in with RR install) or Elite Lite. So I guess that is my issue. Thanks Kadron for for calling that out.

                              So now the question is where can i get a dvd_player.skin to use?

                              randy

                              Comment

                              Working...
                              X