Announcement

Collapse
No announcement yet.

What does rr.ini setting usbsound=true do actually?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • What does rr.ini setting usbsound=true do actually?

    From settings.txt

    "This tells RR to wait and restart the mixer when resuming from Hibernation. Mainly used to improve support of USB Sound cards. Default=false (use standard sound card)."

    Does it disable/enable the sound card on hibernate/resume?

    The reason I ask is I'm having some resume issues w/ my old Creative Soundblaster usb soundcard and am looking for a solution to it.

    TIA!
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  • #2
    it waits up to 5 seconds while trying to open the mixer
    and if it finds the mixer, it opens it
    also any mixerfound this will pass through that wait...

    it is also after resumedelay

    basicly id think if resumedelay is set to give the usb device a few seconds to come back online... usbsound prob isnt needed
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

    Comment


    • #3
      K, thanks.

      Looks like I'm gonna have to play around w/ resumedelay to give my script time to reset my usb soundcard...
      Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

      Comment


      • #4
        Does "CLOSEWINAMP/STARTWINAMP" still work since RR's player choices have been modularized?
        Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

        Comment


        • #5
          yes, the close/start functions should work for any player.
          Ride Runner RR's Myspace

          "Being happy is not about having what you want, it's about wanting what you have."
          "The best things in life are always free - but that doesn't mean money can't buy you good things."

          Comment


          • #6
            *sigh* I don't remember this USB soundcard being so problematic on my last carPC...

            Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

            Comment


            • #7
              me either! I got soundblaster 5.1 usb and it just gives me trouble its not reliable on resume volume whatsoever with delay set to 10 and usb restart...
              Did it.. Done it... now I got to keep the neighbors kids away!!

              Comment


              • #8
                I've never tried a USB card (and prob. never will) -- all I hear about them is that they're a headache with drivers and that they have very poor handling of suspend/resume procedures.
                Ride Runner RR's Myspace

                "Being happy is not about having what you want, it's about wanting what you have."
                "The best things in life are always free - but that doesn't mean money can't buy you good things."

                Comment


                • #9
                  Sal: What is the exact issue you have?

                  Guino: I been using all kinds of different USB solutions in my setups.
                  I've never had any kinds of problems. You should give it a try...

                  Comment


                  • #10
                    Originally posted by Aze View Post
                    Sal: What is the exact issue you have?

                    Guino: I been using all kinds of different USB solutions in my setups.
                    I've never had any kinds of problems. You should give it a try...
                    My issue is described here.
                    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

                    Comment


                    • #11
                      SAL: Are you using a VIA chipset?

                      Comment


                      • #12
                        Yes.
                        Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

                        Comment


                        • #13
                          Originally posted by Aze View Post
                          SAL: Are you using a VIA chipset?
                          Before speculations start: I use a VIA M10000 board an a USB-SoundBlasterConnect without any problems (standard WinXP SP2 installation).

                          Comment


                          • #14
                            Originally posted by Konrad View Post
                            Before speculations start: I use a VIA M10000 board an a USB-SoundBlasterConnect without any problems (standard WinXP SP2 installation).
                            I used this card on my VIA M10K with no hibernate/resume problems. That was a HORM system too.
                            Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

                            Comment

                            Working...
                            X