Announcement

Collapse
No announcement yet.

[slvd] CPU/memory/temps not displaying

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [slvd] CPU/memory/temps not displaying

    Well...They display, just not correctly. Temps show as 32 degrees all around, CPU as -1 constantly, and the physical memory as 1.8gigs out of 1.2. As you might imagine, having 4gigs of physical, that might be amiss. =)

    I thought it might have just been something I did, didn't do, or something specific to my motherboard, but it's doing the same thing on this laptop with windows 7 64-bit (same OS on both). Skin doesn't matter, I've tried a couple now. But default is DFX4.

    I'd just straight post this to bugs section, but someone else stated they didn't have an issue in 64bit win7, so I'm probably just missing some directx or activex plugin. Can someone tell me how it's getting the info? I probably just need to get some ocx that isn't installed by default, but I have no true idea how it's getting the info.

    Thanks!
    2008 Ford Mustang GT/CS CARPC(99%)
    Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

  • #2
    Are you running speedfan? Speedfan has to be running, and the labels set up correctly for it to work right.

    Comment


    • #3
      Originally posted by barnyard View Post
      Are you running speedfan? Speedfan has to be running, and the labels set up correctly for it to work right.
      I suspected that for the temps perhaps, but the memory and CPU in use? Don't recall installing that for my XP 32bit install where everything worked.

      Just installed speedfan on the laptop here, nothing changed.
      2008 Ford Mustang GT/CS CARPC(99%)
      Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

      Comment


      • #4
        The Temperature Displays require either SpeedFan, MBM or a HARDWARE (32F = 0C which is the default value). The CPU and memory don't require any other software, however I personally haven't tried it on Win7 64bit -- which may be an issue (?). CPU may be a permission issue, while the memory may be a limitation with the APIs we use -- we'd probably need to upgrade somehow.

        Are you running RR as the administrator ? (just want to be sure)
        Ride Runner RR's Myspace

        "Being happy is not about having what you want, it's about wanting what you have."
        "The best things in life are always free - but that doesn't mean money can't buy you good things."

        Comment


        • #5
          fixed for vista/windows 7 x86 and x64
          -Thanks
          Mitch
          www.rush2112.net

          "Did you test it in carwings??"

          Sun, Come shine my way
          May healing waters bury all my pain
          Wind, Carry me home
          The fabric of reality is tearing apart
          The piece of me that died
          Will return To live again

          Comment


          • #6
            Originally posted by guino View Post
            Are you running RR as the administrator ? (just want to be sure)
            I have UAC set to the lowest on it, which is essentially turning it off, correct? But I tried here and the car running it as such, no change. CPU in use/load and Memory are still wrong.

            The OS version, main drive size, in use values for it, and the CPU speed are correct.

            Temps are unchanged by installing speedfan, which does display them running by itself. I assume that's just a case of the labels being wrong.
            2008 Ford Mustang GT/CS CARPC(99%)
            Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

            Comment


            • #7
              wayne613,
              yes, you have uac off
              its fixed for next release of RR (CPU useage that is)
              it was using OLD APIs, i updated the code to if OS is Vista or Win7
              it will use the new API

              speedfan 4.40 is working fine
              use skintool, and explore ur labels

              SFT0
              SFT1

              SFF0
              SFF1

              like that... i noticed for volts every other had data

              SFV0
              SFV2
              SFV4
              -Thanks
              Mitch
              www.rush2112.net

              "Did you test it in carwings??"

              Sun, Come shine my way
              May healing waters bury all my pain
              Wind, Carry me home
              The fabric of reality is tearing apart
              The piece of me that died
              Will return To live again

              Comment


              • #8
                Originally posted by mitchjs View Post
                wayne613,
                yes, you have uac off
                its fixed for next release of RR (CPU useage that is)
                it was using OLD APIs, i updated the code to if OS is Vista or Win7
                it will use the new API

                speedfan 4.40 is working fine
                use skintool, and explore ur labels

                SFT0
                SFT1

                SFF0
                SFF1

                like that... i noticed for volts every other had data

                SFV0
                SFV2
                SFV4

                Yeah, this took some research as I've never actually altered or really messed with much of any of these skins, settings and such before. I got it sussed for this part though.

                DFX uses the MBM5 label (motherboard monitor) in the task_man skin, so just needed to change it to the speedfan one and alter the appropriate Tvalue for the temperature.

                Making me learn stuff, bastids!
                2008 Ford Mustang GT/CS CARPC(99%)
                Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

                Comment


                • #9
                  I did a quick search, and I think I know the answer. But just for s**ts and giggles...

                  Is there a repository available to get the current dev version? I'm going with no, but never hurts to ask, I assume it's only available to the rest of us through the current NISU cart down-loadable version, correct? It is just once per month barring a major bug-fix as well, right?
                  2008 Ford Mustang GT/CS CARPC(99%)
                  Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

                  Comment


                  • #10
                    Originally posted by Wayne613 View Post
                    I did a quick search, and I think I know the answer. But just for s**ts and giggles...

                    Is there a repository available to get the current dev version? I'm going with no, but never hurts to ask, I assume it's only available to the rest of us through the current NISU cart down-loadable version, correct? It is just once per month barring a major bug-fix as well, right?
                    There's a SVN repository, but it has controlled access. We're actually trying to get things OUT of the core code and put it into plugins, so contributions are best made in the form of plugins. In regards to bugs: when a buf is reported/fixed, we generally can send out a beta version with that bug fixed before the next release -- at request.
                    Ride Runner RR's Myspace

                    "Being happy is not about having what you want, it's about wanting what you have."
                    "The best things in life are always free - but that doesn't mean money can't buy you good things."

                    Comment

                    Working...
                    X