No announcement yet.

GPS causes RR to lock up

  • Filter
  • Time
  • Show
Clear All
new posts

  • GPS causes RR to lock up

    Hello all, long time lurker here with a question I hope you can answer.

    Set up RR (the mose recent version) with Digital FX4 in a 68 mustang with a liliput slide out screen. Have a USB GPS connected which works lovely in autoroute.

    if I set the GPS port that RR uses, RR will lock up in a few mins (can't use any buttons, have to kill it in task manager), however the GPS works fine for MS autoroute, but I want the GPS for the gauges which do work for the few mins. So I thought it was the way xport handled the stream, so I tried it without xport, set up the port in RRConfig and the same story, works for a few mins and then locks up, but fine in autoroute

    Any thoughts on where I can start to look to fix this, I'm not afraid to dive into config files/code and I have done a few searches here.


  • #2
    XPort is working fine and used by most people. What makes you think that it's GPS that lockups RideRunner ? You did set the gps port in RR to a different port than AutoRoute, did you ?


    • #3
      Originally posted by Konrad View Post
      XPort is working fine and used by most people. What makes you think that it's GPS that lockups RideRunner ? You did set the gps port in RR to a different port than AutoRoute, did you ?
      Yep, xport seems to be working fine, no problems there, I shall provide a bit more detailed information:

      I believe that the GPS locks up RR because during my investigation:

      I eliminated xport by uninstalling and reboting (no xport)
      Found what port the GPS was on and verified it worked in a little GPS app that came with it.
      Went to RRConfig set the GPS COMM port to same (think it was about 3 or 4)
      In RRConfig removed the GPS Path
      Started RR (not clicking on the GPS app, autoroute) which worked for a few mins, but after a few button presses failed to respond to any input, same as when I had poth ports going with xport.
      I shutdown RR, set the GPS port to 0 in RRconfig and started up again, RR didn't lock up again.


      • #4
        I had the same issues until I realized that I had xPort picking up the GPS signal and spitting it out to 2 separate virtual COM ports like I'm supposed to. Unfortunately I wasn't paying attention when I assigned the ports because I assigned both Road Runner and iGuidance to use the same port and it caused immediate lockups and blue screens.
        Ampie Case
        2.5" Hard Drive 80GB Samsung 5400RPM
        256 MB DDR2 PC5400
        Xenarc 700TSV - VGA Monitor
        Intel D945GCLF Motherboard

        2005 Honda Civic


        • #5
          When you tried just RR and GPS (without xport or autoroute), you said after a few clicks it froze -- did you look in task manager to see what the CPU load looked like ? also, did you try just pulling off the USB plug to see if RR would come back by any chance ? lastly, are you using a USB hub for the GPS, if so, can you try plugging it straight into the machine (without the hub) ?
          Ride Runner RR's Myspace

          "Being happy is not about having what you want, it's about wanting what you have."
          "The best things in life are always free - but that doesn't mean money can't buy you good things."


          • #6
            Thanks very much for your replies, I shall do that and report back my findings.


            • #7
              A rather late reply, but here is what I found,

              CPU hits about 27% for RideRunner when it becomes unresponsive, the GPS is plugged straight into the computer, no hub. Removing the GPS still leaves things as they were. Is there any more details that you would like?



              • #8
                I used to have the same problem with GMPC, XPort and RR. My GPS was on real port com3, RR on virtual com7 and GMPC on virtual com8.

                What would happen is when coming out of hibernation, GMPC would start before XPort was initialized. Problem is GMPC will start searching all your com ports if it doesn't see a GPS on the configured port so it would connect to com3. With both XPort and GMPC connected to com3 at the same time the system would practically lock up.

                I don't think the issue had to do with any application in particular, just that two of them were connected to the same com port at the same time.


                • #9
                  Following on from some other threads I believe that the issue is with the version of flash that I'm running, seems like the up to date version isn't playing nice with RR and Digital FX, I'll get a chance to play with some different versions and hopefully have a resolution on the thread (I really don't like it when a question thread fades out without a resolution)


                  • #10
                    Look for "zips.dll" in the RR folder, if it is there DELETE IT! I would do a search of the entire RR folder, and sub folders as well.

                    This has caused problems like this many times, for many people.

                    Also, you can check for the "Locate=xxx" in the rr and skin.ini's. If you find this line, delete it as well and test again.

                    I would be willing to bet it is one of those 2 things.
                    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                    My Fiero Build Thread


                    • #11
                      Bit more of an update:
                      • I searched for zips.dll and that wasn't there
                      • I did the full uninstall, reboot and reinstall of flash10 though ie and still have the same issue
                      • I uninstalled, rebooted and installed flash8 as per this but when I started RR with DigitalFX the clock and the guages looked terrible (blockly, sections missing etc.) I didn't get to test if that would fix the hanging problem as it would have been an unusable solution.

                      So looks like Flash8 is too old and Flash10 causes the hanging problems, according to the DigitalFX guide "You can also reduce your hardware acceleration, and this has helped cure the flash problem for many people." so I'll give that a try next. I'm open to any other ideas


                      • #12

                        just use the installer in the sticky


                        and maybe its 1 flash element in digitialFX4 (god that skin, so help us)
                        try to narrow down the issue... try another skin, other skin with flash, but not that one

                        "Did you test it in carwings??"

                        Sun, Come shine my way
                        May healing waters bury all my pain
                        Wind, Carry me home
                        The fabric of reality is tearing apart
                        The piece of me that died
                        Will return To live again


                        • #13
                          Addition to Mitch's

                          I'd keep things simple till you figure out the issue, like only use RR is connected to the GPS com port.

                          Try the default RR Carwings skin (has no flash but would tell is that is part of the problem or not)

                          You never said if you looked at this from Johns posting:
                          Also, you can check for the "Locate=xxx" in the rr and skin.ini's. If you find this line, delete it as well and test again.
                          Also, if it still freezes, run RR a few times, noting the time between you start RR and when it freezes to see if its consistently around the same time frame.
                          RideRunner...The #1 FE, PERIOD.

                          Current Project: DFXVoice [v1.0 Released]
                          Next in line: RRMedia v2.0

                          DFX 5.1.1 Skin
                          Appstore Link

                          My RideRunner Plugins

                          "There are no bugs - only undocumented features."


                          • #14
                            Right, thanks for the input, I'm back with more info!
                            • I can't find a Locate= anywhere in a skin.ini
                            • It does it with the crystalSilver and the Beta skin too
                            • It only happens if the GPS is connected and a port selected
                            • The guages do work before it hangs
                            • You don't have to go to the guages for it to hang
                            • The time to hang is rough about 30-40secs
                            • I've swicted off hardware acc.,
                            • There is only one port occupied
                            • I'm running Flash 10,0,45,2

                            Hope someone can shed more light on this!


                            • #15
                              try another gps splitter like GPSGATE.. download the demo version or the cracked one (if you want to go to jail )