Announcement

Collapse
No announcement yet.

Latest RR problem with Album art

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Latest RR problem with Album art

    Dear all,

    The album art no longer shows on RR with recent version (I remember they used to work in 2009 release). I have read the FAQ and following the instruction to name them folder.jpg in every album folders under the artist's folder. The jpg files are all non-hidden and not read-only. I have tried different skins and all have the same problem. Please helps. Thanks in advance.

    Jguy

  • #2
    approved the post

    this is for sure not the case
    you provide no real information...
    the RR version, the OS and so fourth
    Album art is working fine, if you are using the mp3art plugin, for embedded artwork.. i would uninstall that, and get the newest

    also in rr.ini

    coverfile=*.jpg
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

    Comment


    • #3
      I am using Windows 7 32-bit, RR is the April release. It's a fresh install because I was running 64-bit of Windows 7 and I thought it's why I got problem with it. I used to able to see the album art prior to 2010 release. The jpg are not embedded and I put the image together with the MP3's. The rr.ini setting is what you're suggesting. I can post a screenshot if requires. Thanks.

      Jguy

      Originally posted by mitchjs View Post
      approved the post

      this is for sure not the case
      you provide no real information...
      the RR version, the OS and so fourth
      Album art is working fine, if you are using the mp3art plugin, for embedded artwork.. i would uninstall that, and get the newest

      also in rr.ini

      coverfile=*.jpg

      Comment


      • #4
        I have this issue too. Main PC and CarPC both running RR with exactly the same skin, same version, using same mp3s with same albumart files in the same folder locations. Main PC shows album art, CarPC doesn't. And I can't for the life of me work out where the difference lies.
        http://sticksout.blogspot.com

        Comment


        • #5
          Originally posted by mitchjs View Post
          this is for sure not the case
          Be careful Mitch I have been proven wrong on a statement like that many time now hahah
          Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

          My Fiero Build Thread

          Comment


          • #6
            john, now now

            did u guys look at your coverfile setting in rr.ini?
            how about looking in Skin Tool, at the albumart indicator
            like
            Attached Files
            -Thanks
            Mitch
            www.rush2112.net

            "Did you test it in carwings??"

            Sun, Come shine my way
            May healing waters bury all my pain
            Wind, Carry me home
            The fabric of reality is tearing apart
            The piece of me that died
            Will return To live again

            Comment


            • #7
              I have attached my rr.ini. I checked it using Skin Tool and it says contain no data at the audio player skin.

              Originally posted by mitchjs View Post
              john, now now

              did u guys look at your coverfile setting in rr.ini?
              how about looking in Skin Tool, at the albumart indicator
              like
              Attached Files

              Comment


              • #8
                post a debug session too... cant even tell if media is playing
                if winamp is stopped and no track info is available, u get no albumart...

                also... post a rrpl.m3u8
                -Thanks
                Mitch
                www.rush2112.net

                "Did you test it in carwings??"

                Sun, Come shine my way
                May healing waters bury all my pain
                Wind, Carry me home
                The fabric of reality is tearing apart
                The piece of me that died
                Will return To live again

                Comment


                • #9
                  how about some poorly programmed plugin, destroying albumart indicator
                  thats why i need to see a debug.txt of a session!
                  -Thanks
                  Mitch
                  www.rush2112.net

                  "Did you test it in carwings??"

                  Sun, Come shine my way
                  May healing waters bury all my pain
                  Wind, Carry me home
                  The fabric of reality is tearing apart
                  The piece of me that died
                  Will return To live again

                  Comment


                  • #10
                    some questions about album art itself.

                    i see in some skins that the coder use the command....J,140,203,227,203 other use
                    I,140,203,227,203,"ALBUMART"


                    what makes the difference ?
                    i thought the >J< command will show all arts, like radio, album, aso.
                    and the >I< command will only show the "albumart"
                    that was not true. its unimportant what command i code, it shows in both the same.

                    another missunderstanding is the name "AlbumArt". as i translate it, i thought it shows me, like in older riderunner versions the pic which i integrate inside my mp3 file, if there is no pic inside...it shows the .jpg which is in the musicfolder ive opend.
                    momentary i cant see the pic which is in my musicfolder.

                    so, as i read your notes, and i see whats happend on my screen...i MUST give every mp3 file a pic, otherwise i see an empty field.

                    dont say i must give every mp3 file a pic.

                    Comment


                    • #11
                      no difference, the J gets turned into a Indicator called "ALBUMART"
                      infact i would say the I command is the perferred way

                      if you have your Mp3s organized by folder, Albumart art will use the 1st image it finds in the folder be it, cover.jpg or folder.jpg

                      if you want to use mp3 artwork that is embedded inside mp3s thats completly different and you need to install the the mp3art embedded artwork plugin
                      -Thanks
                      Mitch
                      www.rush2112.net

                      "Did you test it in carwings??"

                      Sun, Come shine my way
                      May healing waters bury all my pain
                      Wind, Carry me home
                      The fabric of reality is tearing apart
                      The piece of me that died
                      Will return To live again

                      Comment


                      • #12
                        Just to be clear: J is supported for compatibility only. The recommended way is using indicators as Mitch said. The problem with J is that it doesn't provide ways of using certain objects within the same screen (i.e. ALBUMART & COVERART) -- plus it assumes certain screens will always use the same type of art.
                        Ride Runner RR's Myspace

                        "Being happy is not about having what you want, it's about wanting what you have."
                        "The best things in life are always free - but that doesn't mean money can't buy you good things."

                        Comment


                        • #13
                          Hi Everyone,

                          I have solved the problem of unable to display album art in RR. It is because all my artists' folder name are not in English but Chinese, and I didn't change the "Language for non-Unicode programs" according to it. The album art shows after the fix even they are not named folder.jpg. I appreciate everone's help here. I hope this thread can serve as someone's tips in the future in similar situation. Thanks! =)

                          Jguy

                          Comment


                          • #14
                            Originally posted by mitchjs View Post

                            this is for sure not the case
                            Originally posted by JohnWPB View Post
                            Be careful Mitch I have been proven wrong on a statement like that many time now hahah
                            Originally posted by mitchjs View Post
                            john, now now

                            The following changes were made to the [RideRunner] code:

                            Author:
                            mitchjs

                            Log of Changes:
                            unicode folder names for ALBUMART
                            updated for unicode folder...needs to be completed for file read

                            Files Changed:
                            U _Plugins/Mp3Art/Mp3Art.vbp
                            U _Plugins/Mp3Art/RRExtension.cls
                            U _Plugins/Mp3Art/cMP3ID3v2.cls
                            A _Plugins/Mp3Art/cUnicodeFiles.cls
                            as I was saying??
                            Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                            My Fiero Build Thread

                            Comment


                            • #15
                              if he had his non unicode applications settings correct
                              [ http://www.mp3car.com/vbulletin/rr-f...upport-rr.html ]
                              , he wouldnt have an issue
                              and this plugin isnt even in the picture here

                              but no one reads the FAQ, even I forgot all about this
                              and we hate to have it so "un-automatic"

                              but when someone says it "NO LONGER" works.... its how about It NEVER WORKED
                              cause of the the unicode...

                              but now in RR 5/1 it will
                              -Thanks
                              Mitch
                              www.rush2112.net

                              "Did you test it in carwings??"

                              Sun, Come shine my way
                              May healing waters bury all my pain
                              Wind, Carry me home
                              The fabric of reality is tearing apart
                              The piece of me that died
                              Will return To live again

                              Comment

                              Working...
                              X