Announcement

Collapse
No announcement yet.

Playlists and Winamp

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Playlists and Winamp

    Question 1)
    I have done a fresh install and I am having a problem loading in playlists, to be specific one playlist that has links to internet radio stations. Previously I could just double click on the radio.m3u file and all 10 stations would be loaded in correctly. Now when the file is loaded into Winamp it has the local path appended to the front of the link.

    i.e looking at the playlist properties from within Winamp I see:-
    "C:\Music\_internet Radio\[url]http://82.201.100.23/Radio538"


    If I use winamp directly to open the file it is correct:
    "http://82.201.100.23/Radio538"

    Normal playlists open properly without any problems, its only this one with web-radio stations. I believe that I'm using the standard Sxx,xxx xxx command to scroll and load files.


    To work around this I can select the m3u file and use the "SELECT" command and this seems to add the playlist OK


    Question 2),
    When I restart RR is doesnítí automatically update the playlist variables i.e "TRACKNAME" etc. I now have to go to the Audio Browser and then it refreshes.
    I have tried putting a hidden list on my skin but that doesn't help?

    <S01,0,0,0,0,255,255,255,255,255,255,255,255,255,2 55,255,255,0,0,0,TRUE,20,"Arial>
    My Projects:-

    2010 BMW X1 install

    1955 Austin A30 install

  • #2
    First, what skin?

    Question 2),
    When I restart RR is doesn’t’ automatically update the playlistvariables i.e "TRACKNAME" etc. I now have to go to the Audio Browserand then it refreshes.
    I have tried putting a hidden list on my skin but that doesn't help?
    What do you have your music resume setting set to? When you first startup RR it doesn't know what audio source is being played if you setting is not the "ALWAYS" setting. RR's audio source is screen based for the most part and until you go to one of the defined audio source screens.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

    Comment


    • #3
      Thanks for the reply,
      I'm using my own skin that was initially based on the excellent BMW E36 skin.
      It should be noted that I have never felt the need to update my RR version (in my BMW) as it has always performed really well. I have upgraded from an old Sept 2008 version. The only reason that I'm upgrading now is that I want to add some flash animations,

      I have a 2nd Car Computer in an old classic car. I think that I am using a version of RR from May 2010 and I don't recall having these problems with that install
      My Projects:-

      2010 BMW X1 install

      1955 Austin A30 install

      Comment


      • #4
        I do know that at some point the playing/selecting of audio files changed slightly, meaning that before the change, RR would include playlist files when selecting a folder, as to now will exclude them when adding a folder. That is really the only thing that comes to mind with changes to the playlist topic.
        RideRunner...The #1 FE, PERIOD.

        Current Project: DFXVoice [v1.0 Released]
        Next in line: RRMedia v2.0

        DFX 5.1.1 Skin
        Appstore Link

        My RideRunner Plugins
        RRMedia
        RRExtended
        DFXVoice

        "There are no bugs - only undocumented features."

        Comment


        • #5
          if ur using the newest rr, it does update its trackname, WHEN and only WHEN you actually have WINAMP set to supply it... it has been discussed many times...
          i have posted screen shots of the setting in winamp
          -Thanks
          Mitch
          www.rush2112.net

          "Did you test it in carwings??"

          Sun, Come shine my way
          May healing waters bury all my pain
          Wind, Carry me home
          The fabric of reality is tearing apart
          The piece of me that died
          Will return To live again

          Comment


          • #6
            post that PL please

            ATTACH IT, add .txt if needs be
            -Thanks
            Mitch
            www.rush2112.net

            "Did you test it in carwings??"

            Sun, Come shine my way
            May healing waters bury all my pain
            Wind, Carry me home
            The fabric of reality is tearing apart
            The piece of me that died
            Will return To live again

            Comment


            • #7
              Thanks for all the advice, I now have it set to 'Resume' on start. This mostly solves the problem that I had with the initial update of the Trackname etc.
              The only problem with this solution is the internet radio m3u playlist. My broadband dongle doesn't connect until about a minute after RR has started. By which point Winamp had ploughed through the playlist and said that they canít play.
              I am pretty happy with the solution at the moment.


              FYI the playlist is attached
              Attached Files
              My Projects:-

              2010 BMW X1 install

              1955 Austin A30 install

              Comment


              • #8
                The only problem with this solution is the internet radio m3u playlist.My broadband dongle doesn't connect until about a minute after RR hasstarted. By which point Winamp had ploughed through the playlist andsaid that they can’t play.
                Well, one solution in the end could be maybe a small plugin that would have some logic built in. When RR is started up, and the song that is trying to be resumed from is a internet sream, first checks the inet status, and if is considered offline, then would stop playing until it comes online, at which time, would then try to resume the current playlist item.

                [Edit]

                Actually, this could possibly be added right into the player plugin, which would benefit anyone else that would have this same issue with connectivity to the net.
                RideRunner...The #1 FE, PERIOD.

                Current Project: DFXVoice [v1.0 Released]
                Next in line: RRMedia v2.0

                DFX 5.1.1 Skin
                Appstore Link

                My RideRunner Plugins
                RRMedia
                RRExtended
                DFXVoice

                "There are no bugs - only undocumented features."

                Comment


                • #9
                  Originally posted by TrevorC2 View Post
                  Thanks for all the advice, I now have it set to 'Resume' on start. This mostly solves the problem that I had with the initial update of the Trackname etc.
                  The only problem with this solution is the internet radio m3u playlist. My broadband dongle doesn't connect until about a minute after RR has started. By which point Winamp had ploughed through the playlist and said that they can’t play.
                  I am pretty happy with the solution at the moment.


                  FYI the playlist is attached
                  thanks, all fixed...

                  would you like the newest RR, with this fix, just PM me

                  (play list issue that is)
                  -Thanks
                  Mitch
                  www.rush2112.net

                  "Did you test it in carwings??"

                  Sun, Come shine my way
                  May healing waters bury all my pain
                  Wind, Carry me home
                  The fabric of reality is tearing apart
                  The piece of me that died
                  Will return To live again

                  Comment


                  • #10
                    Thanks Mitch for the fix and thanks Blue ZX3 for the resume advice. I'm now happy with just setting 'resume' in RRconfig, I can live with it flitting through the stations. The new install is almost there.
                    My Projects:-

                    2010 BMW X1 install

                    1955 Austin A30 install

                    Comment

                    Working...
                    X