Announcement

Collapse
No announcement yet.

RR issue with USB screens

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RR issue with USB screens

    Hey Guys,
    I'm a bit new here and I have been trying to get some advice for a few days. I posted this first in the LCD/monitor forum but we haven't had much luck figuring the issue out. I was hoping that maybe the experts here with RR have come across this issue before:
    ---------------------------------
    Hey Guys,

    Iím very new to the hobby and Iíve found a wealth of information in these forums. So much, in fact, that this is the first time that Iíve needed to post and ask for help. Iím trucking along on my first build and Iíve run into an issue with my monitor that I was hoping someone else might have come across.

    Iím trying out one of those newer 7Ē Lilliput USB powered touch screens (Lilliput UM-70T) and up until now it has been working great. Showing Windows 7 Home Premium, and other CarPC programs like Centrafuse perfectly. My issue lies with running the Ride Runner front end.

    Sometimes (about 85% of the time) when I switch between selections in RR, parts of the previous screen will stay visible in the new one. They only disappear when I ďeraseĒ them by mousing over the old screen that shouldnít be there. Itís similar to erasing something in MSpaint.

    I thought that this might be a settings issue in RR or a limitation of the onboard graphics (Iím using the onboard of an Intel D510mo) but I canít recreate this issue with a different monitorÖeverything works fine. The more I dig, the more it seems related to my screen.

    Odd thing is, I tried to take screen caps to post a visual of what Iím seeing, and apparently according to my machine, there is no problem. The screen cap I took of the problem RR screen shows a perfectly normal screen when I pasted it in paint of how its supposed to look.

    Anyone ever run into this kind of screen corruption before, and if so, is there anything that can be done about it?

    Thanks so much for all the help!
    -----------------------------------

    If it helps, the original thread is here:

    http://www.mp3car.com/lcd-display/14...ut-um-70t.html

    We thought maybe it was a direct X issue or a graphical limitation of the screen, but we've been able to play video and streaming fine on these screens from traditional desktop run programs (WMP, VLC, ect...) and Windows 7 itself is running fine. This was all we could come up with so far. Thanks again!

  • #2
    There is a limited amount of bandwidth when using USB for transporting video. This unfortunately is just the nature of USB video. When you take a screen capture, it is capturing what is in memory for the display, and not what you are actually seeing. The fact that the screen capture comes out correctly, proves that the system & RR are drawing it correctly, it is just getting lost between the computer and the display. Unfortunately, there is no easy fix for it, other than making sure that you have the latest drivers for the screen.

    The bottom line is, that it boils down to the monitor itself, and it's drivers. The Gfx card, motherboard and RR are not to blame.

    There was another post a week or so back, with a very similar problem. The screen was not refreshing iLists correctly. In his case, after trying just about everything, he decided to return the monitor and go with a standard VGA/HDMI monitor.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

    Comment


    • #3
      I have experienced what you're talking about with my testing of a Samsung SPF-87H display. I preload FreeDrive in the background when RRstarts up. Almost everytime, just as FreeDrive finishes loading it corrupts the screen. When I don't preload FreeDrive, I can go for quite a while if I dont change screens. If I do change screens in RR, it eventually corrupts just like you explained. I considered the possible causes: DirectX, screen drivers, etc., but much like John described, I thought its a USB bandwidth issue. But something kept nagging me in the back of my mind about the slow response of my mouse when using this screen.

      Just on a whim, I installed 4Gb of ram (maxes out the tablet) and turned off the paging file (virtual memory). Voila! no more corrupt screens in RR (so far, I've only tested briefly on short trips around town). Just something to consider.
      HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

      Comment


      • #4
        since you mentioned windows7...Is desktop composition on when you run RR? that could cause similar issues

        Comment


        • #5
          If using a current release or last few anyway of rr, it defaults to turning off that upon startup.
          RideRunner...The #1 FE, PERIOD.

          Current Project: DFXVoice [v1.0 Released]
          Next in line: RRMedia v2.0

          DFX 5.1.1 Skin
          Appstore Link

          My RideRunner Plugins
          RRMedia
          RRExtended
          DFXVoice

          "There are no bugs - only undocumented features."

          Comment


          • #6
            unless the have an old rr.ini!!!
            which was defaulted wrong
            rr.ini
            disabledc=true

            but not sure this is his problem... but cant hurt

            Sometimes (about 85% of the time) when I switch between selections in RR, parts of the previous screen will stay visible in the new one. They only disappear when I “erase” them by mousing over the old screen that shouldn’t be there. It’s similar to erasing something in MSpaint.

            bad background setting?

            test with carwings
            -Thanks
            Mitch
            www.rush2112.net

            "Did you test it in carwings??"

            Sun, Come shine my way
            May healing waters bury all my pain
            Wind, Carry me home
            The fabric of reality is tearing apart
            The piece of me that died
            Will return To live again

            Comment


            • #7
              Originally posted by mitchjs View Post
              test with carwings
              Knew that lil devil was surface very quickly...LOL
              RideRunner...The #1 FE, PERIOD.

              Current Project: DFXVoice [v1.0 Released]
              Next in line: RRMedia v2.0

              DFX 5.1.1 Skin
              Appstore Link

              My RideRunner Plugins
              RRMedia
              RRExtended
              DFXVoice

              "There are no bugs - only undocumented features."

              Comment


              • #8
                Originally posted by Blue ZX3 View Post
                Knew that lil devil was surface very quickly...LOL
                But of course! As you know, each skin has its own dedicated graphics engine in the RR source to draw them LOL LOL
                Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                My Fiero Build Thread

                Comment

                Working...
                X