Announcement

Collapse
No announcement yet.

is it me or rr?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • is it me or rr?

    when i first setup my carpc 3 years ago, everything worked perfect-- i am thinking it was a miracle.

    but since then every time i reinstall rr to get the latest version, i loose features.

    i have been staring at my carpc screen for nearly 4 hours now, searching tons of threads with no helpful results, and a system that is in worse condition then it was before when the nag screen was bothering me..

    i guess i just need someone to hold my hand and show me exactly what i am doing wrong that i can so consistently screw rr up..

    all i need out of rr is to: play music(mostly just select playlists), custom background, and black buttons with white text. as long as i have these three things, i'm good.

    i can't get my music to show up, and the color change is not working. but i can change the backgrounds!!


    programs:
    fresh download/install of the latest version of rr--july 2011 version
    fresh download/install of dfx 5.1+ donation patch

    before installing the new versions, i uninstalled the older versions of both, cleaned the registry, manually deleted the riderunner folder form my program files, and rebooted.

    after rebooting after everything installed, i configured rr to what i believe is identical settings to what it had before the update.


    now, many buttons will not work:
    • rescan database--i can get to the screen to rescan the database, the button will highlight, but nothing else happens.
    • color changer-- if i go directly to 'settings' and then 'color changer', the button will not work. if i change the background, and go back to the 'settings' window, i can access the color changer menu, but cannot select any color but black.

      also, once i access the color changer screen, the sample image on top freezes and stays there after rr is shut down.


    attached is my rr debug and ini files

    thanks.
    Attached Files
    My OLD 2001 Mitsubishi Eclipse GT:
    "The Project That Never Ended, until it did"


    next project? subaru brz
    carpc undecided

  • #2
    Welcome to my world!

    Hey Mitch! Get over here!

    HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

    Comment


    • #3
      One huge issue I see is that I don't think RR has loaded the skin's exectbl.ini file. No where in that debug log, do I see a "EXECTBL Translation:" line, for which just loading the skin you should see several

      Example, 2 lines from my debug log:

      7/25/2011 9:12:16 PM: Que Exec: True, menu.skin, "ONSKINSTART", False
      7/25/2011 9:12:16 PM: EXECTBL Translation: ONSKINSTART -> DFXDLLCHECK||PreloadCheck||ONSCREENCHANGE||ReLock| |SpeedIndicatorLoader||GreetingPlay||GreetingPopUp ||SAVENSETTOSKIN;SKINRELOADING;0||FBCONNECT||WAIT; 2

      Same two lines from your debug log:

      7/25/2011 10:45:39 PM: Que Exec: True, menu.skin, "ONSKINSTART", False
      7/25/2011 10:45:39 PM: Que Exec: True, menu.skin, "ONSOURCECHANGE", False

      Notice any difference? Not a whole lot of stuff is gonna work in DFX if RR isn't loading its exectbl file. Which i believe is your main issue. Dbl check that it is in your skin folder and is in fact full. Got corrupted?

      There is an issue with the DFX installer and W7 or any setup that is using Profile mode, but i can see looking at your debug log that your running the old legacy mode, and should not present any issues here.
      Last edited by Blue ZX3; 07-26-2011, 03:21 AM.
      RideRunner...The #1 FE, PERIOD.

      Current Project: DFXVoice [v1.0 Released]
      Next in line: RRMedia v2.0

      DFX 5.1.1 Skin
      Appstore Link

      My RideRunner Plugins
      RRMedia
      RRExtended
      DFXVoice

      "There are no bugs - only undocumented features."

      Comment


      • #4
        This may seem stupid but are your skins in C:\users\"username"\documents\riderunner\skins\? or in C:\program files\riderunner\skins? If you haven't updated in 3 years I'm betting they are in program files.

        I am fairly new to ride runner and when I first installed everything was in program files and a lot of things were screwy. I moved all my skin files to profile mode and a lot of things started working better. I don't know why this would make a difference but it did for me.

        Comment


        • #5
          This moving of file locations was to make RR UAC compliant. According to how MS wants programs set up is that no program under any circumstance is supposed to store any setting type files or any files that will be written to in the program files folder. Which was the way RR used to be for a long time and now known as Legacy mode verse Profile mode of which puts only program type files in the program files folder and all others in your docs\RideRunner folder.
          RideRunner...The #1 FE, PERIOD.

          Current Project: DFXVoice [v1.0 Released]
          Next in line: RRMedia v2.0

          DFX 5.1.1 Skin
          Appstore Link

          My RideRunner Plugins
          RRMedia
          RRExtended
          DFXVoice

          "There are no bugs - only undocumented features."

          Comment


          • #6
            well, you helped, but not in the way that you would have expected.

            in the rr installer, one of the options is "install in profile mode" it was checked by default, so not knowing what it was, i had left it checked.

            it seems that is what was causing the problems.

            once i reinstalled and unchecked that option, everything works as it should.


            now i just need to care enough to update all my song metadata so they display correctly...

            Thanks again!!
            My OLD 2001 Mitsubishi Eclipse GT:
            "The Project That Never Ended, until it did"


            next project? subaru brz
            carpc undecided

            Comment


            • #7
              Originally posted by soundman98 View Post
              now i just need to care enough to update all my song metadata so they display correctly...
              Yeah, I had to do that when I switched from CF to RR. What a time consuming PITA, but at least everything I have is now good to go!
              1999 Mercury Grand Marquis GS with: ASRock E350M1 w/4GB RAM, 80GB Intel SSD, Opus DCX3.120, Visteon HD Radio + HDR-USB, PL-18N wifi, OBDLink Scan Tool, BTA6210 BT, BU-353, Win 7 Ultimate, CF 4.0, Alpine MRP-F240 + MRP-T220, RF Punch 1572s, Kicker 8" Comp.

              Comment


              • #8
                You want to hear a PITA, try having to tag all of your MP3's when you have 45,000! It was a nightmare! 100% of my MP3's are now correctly tagged, have embedded artwork, folder.jpg in each album folder, and around 85% with embedded lyrics. "Tag & Rename" is an INDEFENSIBLE program for this! It just takes lots and lots of time!
                Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                My Fiero Build Thread

                Comment


                • #9
                  my music library seems so small now(5k songs)....
                  My OLD 2001 Mitsubishi Eclipse GT:
                  "The Project That Never Ended, until it did"


                  next project? subaru brz
                  carpc undecided

                  Comment


                  • #10
                    there is nothing wrong with profile mode...
                    its best to use it...

                    the issue is right now, the DFX5.x installer, doesnt see that RR is installed in profile mode
                    (this will be fixed when DFX5 installer gets updated, which i think is really soon)

                    [long story]

                    soundman98, there are NO less features in RR... there are TOOOONS more
                    -Thanks
                    Mitch
                    www.rush2112.net

                    "Did you test it in carwings??"

                    Sun, Come shine my way
                    May healing waters bury all my pain
                    Wind, Carry me home
                    The fabric of reality is tearing apart
                    The piece of me that died
                    Will return To live again

                    Comment


                    • #11
                      ok, so instead of making a new thread, i'll piggyback off my old one. i know for sure that this is a dfx5 issue, just not sure where to go with it.


                      my dsatx went bad a couple months ago, and i finally got everything reinstalled in the car. while it was out, i had updated to either the june/july version of rr, and updated the dfx skin to 5.1 as well.

                      after getting it reinstalled in the car, i found that i could not load any playlists. tested in carwings-- works, so it was def a issue with dfx5. but i let it go-- the random-50 songs still worked, so i just used it till i had time to trouble shoot.


                      today, the notification popped up that rr needed to be updated.

                      i downloaded the september version of rr, and downloaded a fresh copy of dfx 5.1 skin and dfx5.1R patch.

                      i then uninstalled dfx5 and rr in that order, then cleaned the registry, and deleted the rr folder in the Crogram files directory.

                      i also had a notification that there was a newer version of winamp, so i uninstalled that, wiped the registry, and downloaded, installed, and configured the newer version.

                      i reinstalled rr, and then installed dfx5, but did not patch it yet.

                      after reinstalling, i ran the rrconfig and set it up.

                      i launched it, and everything worked perfect-- until i tried exiting..(eventually got the windows 'program not responding' error)

                      for some reason rr w/ dfx 5 will not exit.

                      i restarted rr using carwings, and everything works correctly, including exit.

                      any ideas?

                      lunch is ready, so i dont have time to post the debug/ini now, but will update later this afternoon.

                      edit: added rr ini and debug log. it also appears that the song info and current time and end time of a song are also not displaying in dfx5
                      Attached Files
                      Last edited by soundman98; 10-02-2011, 02:42 PM.
                      My OLD 2001 Mitsubishi Eclipse GT:
                      "The Project That Never Ended, until it did"


                      next project? subaru brz
                      carpc undecided

                      Comment


                      • #12
                        I HIGHLY recommend you read post#2 in the dfx5 thread! Did you NOT read the note directly above the link to the NISU site in the Sept RR release thread?
                        RideRunner...The #1 FE, PERIOD.

                        Current Project: DFXVoice [v1.0 Released]
                        Next in line: RRMedia v2.0

                        DFX 5.1.1 Skin
                        Appstore Link

                        My RideRunner Plugins
                        RRMedia
                        RRExtended
                        DFXVoice

                        "There are no bugs - only undocumented features."

                        Comment


                        • #13
                          Originally posted by JohnWPB View Post
                          "Tag & Rename" is an INDEFENSIBLE program for this!
                          You sir, are a hero!

                          Comment


                          • #14
                            And just an FYI for those using Tag & Rename:

                            When you are viewing an album, you can use the pull-down menu's Tools>Get Album Titles From Amazon/Tracktype.org. You can put the artist and album name in there and it will get all of the tags for you, including the album art 98% of the time, embed the album art in the individual MP3's and save it as Folder.jpg as well.

                            IF the tracks are out of order and do not match up, you can drag them up and down in the lost to organize them correctly.
                            Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                            My Fiero Build Thread

                            Comment

                            Working...
                            X