Announcement

Collapse
No announcement yet.

Best OS for Ride Runner?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Best OS for Ride Runner?

    I've been trying to test RR on Windows 8 dev build and I'm having issues with inputs and what not from my sound card, so I think it might be OS related? What is generally the best OS to run RR on. What boots the fastest and uses the least resources? Would running a stripped down version of XP be best?

  • #2
    my first rr install was on XPembedded, very stripped down, onto a high speed 2gb compact flash. my boot time was great - less than 10 seconds - however setting up roadrunner and all the applications i needed on XPe was very, very time consuming. and any time i needed to update something, i had to rebuild XPe because of how it worked. i now use a solid state drive and hibernation now anyway, so boot time no longer concerns me.

    I cant say from experience with vista or 7 or 8, but personally i would always prefer xp on a system such as this. the OS footprint will definatly be smaller, and the drivers for old/legacy devices are more abundant. unless there is some feature that a newer OS can provide that xp cant, and you cant live without it, i would stick with xp

    be careful what you strip out too. i can't remember off the top of my head, but there are some components that are definatly needed by RR and or plugins or their dependencies (i.e. .net3.5) that need to stay in the xp install, otherwise you will spend tons of time having to reinstall windows with those components.

    on xp bootup times, you can try searching for "minilogon" i believe, its from the XPe system, it will cut a lot of time logging into windows. it would replace winlogon.exe. you can also set a custom shell to be riderunner.exe instead of explorer.exe, but that can also present some problems depending on what functions you need

    Comment


    • #3
      I wouldn't run anything on windows 8. It is not ready. I use xp but 7 would be fine too.

      Comment


      • #4
        Thanks, I have this XP version called Performance edition. It's stripped down but not nearly as much as XPembedded I don't think.

        Comment


        • #5
          Originally posted by dmcdlrn View Post
          I wouldn't run anything on windows 8. It is not ready. I use xp but 7 would be fine too.
          Well 8 is pretty similar to 7, so I'm not sure it would work any better in 7. But yes I agree I was just tinkering, wasn't planning on leaving 8 on it.

          Comment


          • #6
            I have been running the TinyXP revisions for about the last 5 years, Rev 9 being the last one and have no problems with any b/c of the extra crap being stripped out..
            RideRunner...The #1 FE, PERIOD.

            Current Project: DFXVoice [v1.0 Released]
            Next in line: RRMedia v2.0

            DFX 5.1.1 Skin
            Appstore Link

            My RideRunner Plugins
            RRMedia
            RRExtended
            DFXVoice

            "There are no bugs - only undocumented features."

            Comment


            • #7
              I'll look at that. The one thing I'm having an issue with is that my CarPC doesn't have an optical drive......I found several guides on making a bootable install flash disk, but they don't like that I'm not using a regular XP disk as the ones I'm trying to use are modified.

              Comment


              • #8
                Mine doesn't either, only time(s) are when installing the OS, then its disconected and everyting else needed is installed from the network.
                RideRunner...The #1 FE, PERIOD.

                Current Project: DFXVoice [v1.0 Released]
                Next in line: RRMedia v2.0

                DFX 5.1.1 Skin
                Appstore Link

                My RideRunner Plugins
                RRMedia
                RRExtended
                DFXVoice

                "There are no bugs - only undocumented features."

                Comment


                • #9
                  I've been running W8 since last fall (DP then CP). The only issue I've had is with the Griffin PM. Using DP on my media machine in the livingroom, I had driver issues with the onboard sound in but haven't updated it yet to CP to see if there is a solution. Lightening fast boot times with sleep mode and no tweaking on both.
                  My 2007 Ford F350 Work Log located HERE

                  Comment


                  • #10
                    I forgot that XP doesn't support more then 3.25gb's of memory on the 32bit version lol.

                    Comment


                    • #11
                      Well...I really don't see the need for more than that, in a car pc, unless one plans on doing a huge setup. But for just the everyday things, music/GPS/Videos(when not driving...) its a bit of over kill, to each his own...
                      RideRunner...The #1 FE, PERIOD.

                      Current Project: DFXVoice [v1.0 Released]
                      Next in line: RRMedia v2.0

                      DFX 5.1.1 Skin
                      Appstore Link

                      My RideRunner Plugins
                      RRMedia
                      RRExtended
                      DFXVoice

                      "There are no bugs - only undocumented features."

                      Comment


                      • #12
                        Well it's ram I had laying around. I got it installed and setup but it won't see my HD radio for some reason.

                        Also I'll be doing processing on the PC for a 4 way setup (3 way front + sub) so that'll require a bit more power. Eventually I'd like to do at least 2 zones if not 3. But I have to wait until the ability is more ready or go to something like the beagle/Raspberry PI.

                        Comment


                        • #13
                          Windows 3.11 for workgroups
                          Former author of LinuxICE, nghost, nobdy.
                          Current author of Automotive Message Broker (AMB).
                          Works on Tizen IVI. Does not represent anyone or anything but himself.

                          Comment


                          • #14
                            Originally posted by tripzero View Post
                            Windows 3.11 for workgroups
                            ......?

                            Comment


                            • #15
                              Well I found one thing I don't like about XP, or at least it may be a problem since I'm doing processing on the CarPC for a 3 way setup with subs. In Windows 7 I can see each individual audio channel in windows volume control, but in XP it seems to group them all together? If AudioMulch can't see each channel then that may be a problem? I haven't messed with that yet though still got other things to work out.

                              Comment

                              Working...
                              X