Announcement

Collapse
No announcement yet.

GPS Volume Bug

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GPS Volume Bug

    Mitch,

    Found a bug in either RR Config or RR main program (tested and confirmed with RR Config v1.0.0.15; RR build 01-01-2013).

    Bug: Selecting "Adjust volume based on speed form GPS" (which is misspelled in RR Config, btw) causes the following behavior in the RR program:

    1. Upon initial start or restart of RideRunner, master volume is set to 50%
    2. Pressing Volume Up/Down buttons results in click but no volume change (and percentage remains at 50%)
    3. If user presses 'Mute' button, and then presses either 'Mute' again, or either Volume button (up or down), then volume functionality returns to normal behavior (i.e. it works)

    I've reproduced this behavior several times. Tested and confirmed with CarWings Lite (default skin), fresh installs of both WinXP SP2 (32 bit) and WinXP SP3 (32 bit).

    If I un-check the "Adjust volume based on speed form GPS" box in RR Config (GPS Services > Native GPS), RR functions normally.

    Note that the test PC has GPS installed, but it's not receiving a signal during testing (the antenna wire is not plugged in, since it's out of the vehicle). However, the software should still not function like this (at least not IMHO).

  • #2
    GPS volume wasnt actually programmed by the CORE RideRunner team...
    myself i never could actually test it in realy world...
    (for if you dont know, i dont have a carpc, while i do have a gps puck, i just never had GPS volume on)

    my advice is turn it off

    im sure its buggy

    but good you solved your own problem...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

    Comment


    • #3
      also noting people have used it, so it must work somewhat.... ill be it im sure with a bug or two
      or more

      but i did fix the speeling errrorr
      -Thanks
      Mitch
      www.rush2112.net

      "Did you test it in carwings??"

      Sun, Come shine my way
      May healing waters bury all my pain
      Wind, Carry me home
      The fabric of reality is tearing apart
      The piece of me that died
      Will return To live again

      Comment


      • #4
        more i think about it, it might be working correctly
        just dont understand it...

        i see at 0mph volume is at 50%, thats a setting... so i guess its working

        till you figure it out, keep it off, unless someone else understands it more than me, chimes in...
        -Thanks
        Mitch
        www.rush2112.net

        "Did you test it in carwings??"

        Sun, Come shine my way
        May healing waters bury all my pain
        Wind, Carry me home
        The fabric of reality is tearing apart
        The piece of me that died
        Will return To live again

        Comment


        • #5
          Interesting... if it's WAD. I'll re-test in the car (with GPS receiver) as soon as I can get the PC in there. Should be a few days or so.

          Do you have the source code for the GPS parts, or are you skimming?

          Comment


          • #6
            yes... i have the source, but its a very complicated part of RR, and a bit hacked into RR's code i might add
            id just turn it off, besides you only need 1 volume level, thats MAX!!!!!!!!!!!!!!!!!!!!!!

            jam on!
            -Thanks
            Mitch
            www.rush2112.net

            "Did you test it in carwings??"

            Sun, Come shine my way
            May healing waters bury all my pain
            Wind, Carry me home
            The fabric of reality is tearing apart
            The piece of me that died
            Will return To live again

            Comment

            Working...
            X