No announcement yet.

Riderunner and C# .Net 4.5 and Visual Studio Express 2012

  • Filter
  • Time
  • Show
Clear All
new posts

  • Riderunner and C# .Net 4.5 and Visual Studio Express 2012

    Yesterday I converted all of my development to Visual Studio Express 2012 and changed to .Net 4.5 (from 3.5), all in preparation for some new work.

    I changed the .Net target on all of my RR code (8 plugins and 15 applications) to .Net 4.5 and recompiled.

    Everything worked from first time I ran Riderunner except for 2 plugins.

    Both of them simply don't start but the other plugins do.

    There are no debug.txt messages except as follows (which I expected) and neither of their log file contain anything.

    10:32:53.203: Plugin Manager: Plugin Found: RRMyPI(.NET)
    10:32:53.203: Plugin Manager: Plugin loaded (Global): RRMyPI
    I have re-registered both, checked structure of the code, and insured they build with no error.

    The plugins have basically the same structure as another one that works and I can see no obvious difference.

    Anyone have any thoughts?


  • #2
    Are these all things that you wrote? It is likely they are using code that has been replaced and no longer available. You will need to pull up the code and maybe do some code analysis and that sort of thing.

    I am not familiar enough to know if there is an easy way to detect if you are using old methods that have changed but I am sure there is a way to check. My guess is you may be using code that has been replaced or upgraded in 4.5 compared to 3.5.

    Have you tried to compile back in 3.5 on your new vs to ensure that it is a problem with .Net and not VS?

    We tinkered around a little bit with code analysis this past semester but I suspect if you are able to compile in 3.5 still and they run but not with 4.5 you may have compatibility issues with the newer .Net. If they compile and no change in symptoms then your VS 2012 might have something to do with it.

    Please excuse me if your version of VS doesn't have code analysis. As a student I get the ultimate version for free and I am unfamiliar with what is different between the ultimate version and the express version.


    • #3
      RR will typically attempt to load a compatible library provided it references the RR SDK regardless if its registered or not provided it's in the plugins folder. If not registered or another error occurs before the plugin has been fully initialized you will get an error in RR debug that says something like "plugin found but not loaded (likely not registered)". If RR doesn't see the plugin at all its likely a .net issue or the RR SDK is not properly referenced. Senior Tech Blogger (Want a product reviewed? Contact me.)
      Follow Me on Twitter or Facebook
      Live mp3Car Facebook Chat


      • #4
        Actually in my case, RR loaded the DLL and told me it was loaded but didn't appear to call Initialize.

        ProcMon also said they were loaded successfully.

        But I did work around the problem for now by recompiling the two plugins at the .Net 3.5 level.

        I don't have the time right now to figure out the problem was but I may try later.



        • #5
          Just realize that as new .net versions come out some older versions have functions that are depreciated and no longer fully supported. They may also have incorporated slightly different functions/methods that act slightly different than the old ones. Although the vast majority of stuff should work fine you may find some of the more specialized stuff hiccups. We had a couple of examples of this sort of thing in class where we used an older .net version and a function had a bug you had to work around. In the newer .net the bug was fixed and the workaround no longer worked so it did not work well.

          Good luck.