Announcement

Collapse
No announcement yet.

RR 2-20-05 ... Bug Fixes ...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RR 2-20-05 ... Bug Fixes ...

    My Radio Tuner still hasn't arrived, I decided to start work on the radio without it anyway..

    Changes as of February 20th, 2005:

    -Added Internationalization Support (Foreign Characters)
    -Added VIDEO_TS.IFO default support (don't use *.ifo for videos)
    -Fixed Gamma Red "tint" bug
    -Fixed GammaControl bug when using Built-In Gamma
    -Fixed Visualization "update" bug (behid full screen vis)
    -Fixed "QUIT" command by SDK
    -Fixed Album Text Art Bug
    -Fixed Map Monkey Re-Start Bug
    -Fixed Audio Browser showing on video player bug
    -Improved MPC support

    Just a few fixes and improvements.. Internationalization support comes to support foreign fonts propperly displayed in Playlists and Folder Browsing.. Although RR has now full support for those fonts, MPC does not it is not able to read playlist with non-standard character file names.. This comes to make me believe I might have to either make a small Video Player or make one Built-in RR. Both easy, but in no way it would have as much features/support as MPC has..

    Let me know your Thoughts..
    Thanks for your support!
    Guino.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  • #2
    Just downloaded and tryed at home. Only one problem found on this release. The font size results to be too big. Some texts overheads others... Why?
    Attached Files
    Fabio

    _______________________
    Travla C134
    Jetway J7F2WE 1Gb DDR2 - HD SATA 3.5" 80Gb + HD 2.5" 40Gb - Lilliput 7" TS - Holux GR-213 - Bluetooth - Belkin 802.11g WiFi - Silabs Radio - HTC Leo

    RoadRunner - PC Navigator 7.1 - FreeFone

    Comment


    • #3
      I went to this party tonight and someone jacked my dell PDA I just got, and I was all ****ed, and pretty much you and RoadRunner just made my night.
      http://jupiter.walagata.com/w/djpm05/sig.jpg

      Comment


      • #4
        Originally posted by ATXaccord05
        I went to this party tonight and someone jacked my dell PDA I just got, and I was all ****ed, and pretty much you and RoadRunner just made my night.
        This is another reason to purchase electronics on an AMEX Starwood Credit Card. If you bought it in the last 90 days, if anything happens to the item, they will reimburse you up to $300.

        -HD

        Comment


        • #5
          Thats not a bad deal, I figure once I actually find the guy who stole it, i'll get it back and he'll have to pay that much in some kind of medical bill, so it works out either way.

          one request I do have is a search function through your Mp3's. I have more than 20GB of songs on my computer, and if I could be driving and through navivoice start a search for a file name, and find the song, and play it, I would love that.
          http://jupiter.walagata.com/w/djpm05/sig.jpg

          Comment


          • #6
            Originally posted by Mr.Fabio
            Just downloaded and tryed at home. Only one problem found on this release. The font size results to be too big. Some texts overheads others... Why?
            looks nice, what skin is this?
            MII 6000; 256 MB; lilliput touchscreen; 40GB; bluetooth SE 68i; software still experimenting switched from mediacar to frodopayer, phonecontrol, destinator 3 (NM), and others.
            http://www.mp3car.com/vbulletin/showthread.php?t=31991

            Comment


            • #7
              Wahooo. The video_ts is working. I will have to move all my JPG files up one folder though :-( but it is doable.

              I'm having some serious issue with video playback all together though (not with just this release). When I select the video button I see the player start up screen and I struggle to get the control panel at the bottom to show up. When I get the panel to show up I then select a movie. The movie will start but I can't see it, I can hear the sound but I still see the video player start up screen.. When I finally manage to escape out of RR the video is now visible. It's like it does not get focus until I leave RR.

              Any idea?

              Thanks,
              Chuck

              Comment


              • #8
                If i launch the audio player and press the direct button of run GPS (MM) work ok , but if press the X button to eixt with MM , several bug of MM , error, and if i close RR and reopen , launch directly to main menu MM , its displayed wery strange,dont visualize the button add to RR , and MM don't work correctly.If i close RR when the EXIT button and MM running, RR closed ok , but MM its open hide.

                Mauri

                Comment


                • #9
                  Originally posted by aguila
                  looks nice, what skin is this?
                  This is the Dena skin for MapMonkey 1.13
                  You can Download here
                  http://www.shaunjones.uklinux.net/de.../dena/Dena.exe
                  Fabio

                  _______________________
                  Travla C134
                  Jetway J7F2WE 1Gb DDR2 - HD SATA 3.5" 80Gb + HD 2.5" 40Gb - Lilliput 7" TS - Holux GR-213 - Bluetooth - Belkin 802.11g WiFi - Silabs Radio - HTC Leo

                  RoadRunner - PC Navigator 7.1 - FreeFone

                  Comment


                  • #10
                    Originally posted by Mr.Fabio
                    This is the Dena skin for MapMonkey 1.13
                    You can Download here
                    http://www.shaunjones.uklinux.net/de.../dena/Dena.exe
                    well thanks, loos nice but on the version shown above you have the ETA on the bottom of the screen and the one I downloaded has it at the top. Is it a different version?
                    MII 6000; 256 MB; lilliput touchscreen; 40GB; bluetooth SE 68i; software still experimenting switched from mediacar to frodopayer, phonecontrol, destinator 3 (NM), and others.
                    http://www.mp3car.com/vbulletin/showthread.php?t=31991

                    Comment


                    • #11
                      This version still seems to load gama control when internal gamma is selected.

                      First time i press gamma button it's ok go bacxk to day then night and it turns into a redish colour.

                      Is it possible to select or create different aspect ratios for the video as i have a 16:9 screen but run at 800x600 so i don't want movies to be chopped on at the sides only the top and bottom.

                      Anyone know how to edit the rate of the spining car logos as i want it to spin slower.

                      This version feels more stable and responsive than the last one keey up the good work
                      www.vortexleather.com

                      Comment


                      • #12
                        new bug....
                        since 20-02 update the text screws up and become's arial even when not supposed to
                        not everywhere but in some places

                        see attached screenshot
                        Attached Files
                        Food goes in here..... that's right ... mmmmm

                        Comment


                        • #13
                          Originally posted by Mr.Fabio
                          Just downloaded and tryed at home. Only one problem found on this release. The font size results to be too big. Some texts overheads others... Why?
                          Originally posted by holistic
                          new bug....
                          since 20-02 update the text screws up and become's arial even when not supposed to not everywhere but in some places
                          You probably have "weird" or "different" regional settings that the "Arial Narrow" font does not support. So with the introduction of internationalization, the system (windows) "selects" which font will actually be able to display your characters..

                          If you wish to display your "foreign" characters correctly, you should adjust your Skin to allow enough space for them to display with the system font.

                          OR, you can go in Control Panel under Regional Settings and select the "Standards and Format" language into "English (United States)" and run RR again. you'll see all fonts in the correct size but will get weird characters when trying to display your foreign fonts (if any).

                          I may add a setting to select the Current Font Set (to prevent wrong size fonts from displaying).
                          Ride Runner RR's Myspace

                          "Being happy is not about having what you want, it's about wanting what you have."
                          "The best things in life are always free - but that doesn't mean money can't buy you good things."

                          Comment


                          • #14
                            Originally posted by ATXaccord05
                            one request I do have is a search function through your Mp3's. I have more than 20GB of songs on my computer, and if I could be driving and through navivoice start a search for a file name, and find the song, and play it, I would love that.
                            This will Come soon enough..
                            Ride Runner RR's Myspace

                            "Being happy is not about having what you want, it's about wanting what you have."
                            "The best things in life are always free - but that doesn't mean money can't buy you good things."

                            Comment


                            • #15
                              Originally posted by mauri
                              If i launch the audio player and press the direct button of run GPS (MM) work ok , but if press the X button to eixt with MM , several bug of MM , error, and if i close RR and reopen , launch directly to main menu MM , its displayed wery strange,dont visualize the button add to RR , and MM don't work correctly.If i close RR when the EXIT button and MM running, RR closed ok , but MM its open hide.

                              Mauri
                              The problem is, MM can only run one copy of itself.. if you were for instance running it in RR (old version), then you updated it, and re-run RR, you'd probably get that.. Please restart your machine and re-test it.. if anything, please make sure you have 2-20 version (by re-downloading it).

                              This is what this version does: First time going into GPS will run MM no matter what (so if you have it open already it will cause errors).
                              Then after that, if you leave RR, MM will close. If you use the Close button in RR, MM will close and re-entering the GPS screen will re-load MM. I have even added code to close the GPS screen when using the "EXIT" button in MM, but apperantely this works only on some machines (I assume it's a bug with MM's SDK).

                              In any case, as long as MM is not running before you run RR, it should work.
                              Ride Runner RR's Myspace

                              "Being happy is not about having what you want, it's about wanting what you have."
                              "The best things in life are always free - but that doesn't mean money can't buy you good things."

                              Comment

                              Working...
                              X