Announcement

Collapse
No announcement yet.

map monkey embedding problems?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • map monkey embedding problems?

    hi, just installed all stuff i've tried on my desk on my newly arrived carputer hw and i found some weird bugs:
    - flash logo spinning too fast (solved thanks to guino advice...)
    - map monkey strange behaviour. when i launch it from main menu it starts correctly but the skin shows only the half right part of the MM screen. When i switch back to main menu and then again to gps skin everything looks allright (don't know why or how to fix it, but don't like this vety much..)
    - when i close MM with its menu and then i try to turn it on again it doesn't come up but everything i see is a blank (black) screen where the MM window should appear.
    - if i close MM with Road Runner close (X) button everything goes well and i can turn it on again and again, but always with the same problem: in order to show it correctly i have (when MM is on ) to go back to main menu and then come back to gps screen!
    thank u for any suggestion.

  • #2
    I'm looking at the MM black border problem.. could you try open MM config then set it to restore size & position on startup to a custom position of 0 and 0 and size of 800 by 600 ? I want to have the input of some other people to see...

    Regarding closing MM from it's menu -- it will work IF and ONLY IF you enable the TCP/IP interface on its settings -- open Settings.ini (from Map Monkeys folder) then edit where it says [Plugins] to look exactly like below:

    [Plugins]
    //Allow custom apps to interact with the frontend?
    Enabled=Yes
    ListenPort=9913

    The above also allows for RR to pull up data from MM.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

    Comment


    • #3
      sorry

      excuse me but yesterday i had just the time to post that message.

      thank u for the tcp setting hint, i had completely missed it ...
      well, for visualisation issues i did what u said and everything works fine now (except that MM window cover the entire screen for a while before going embedded into the GPS skin.....)
      do u know if is possible to do something about this (very little) problem?

      p.s. i'm doing something for Cinergy 600 RDS integration (gathering RDS informations, i mean. Hope we'll find out something.)

      Comment


      • #4
        - if (after having set 800x600) the first time i close MM and RR, go back to MM conf and check restore previous then when i run RR and MM again everything goes well (MM window straight to its place). SO O.K.

        - if i uncheck set size and position on startup MM again starts in its place but with a black stripe on the right.... strange, but not so important since this problem can be solved with the above two steps procedure ...

        Comment


        • #5
          Yeah, I still have to test this more, but you could probably have set the correct area to display MM at first (instead of 0,0, - 800,600).. The black stripe is weird since if you check it, it actually has the window size correct but it simply shows transparent instead of showing the entire window as it should....
          Ride Runner RR's Myspace

          "Being happy is not about having what you want, it's about wanting what you have."
          "The best things in life are always free - but that doesn't mean money can't buy you good things."

          Comment


          • #6
            strange

            well, now (nothing changed it the settings), when i launch MM the window where it should be is completely black, until i go back to main menu and then come back to MM skin. then MM is shown correctly....
            i've noticed that song title in the upper part of the screen when MM doesn't display properly hasn't a smooth movement, is this a clue?

            Comment


            • #7
              have you tried to restart RR ?

              The issue can also be related to the fact that RR does NOT try to reset the window position if it is already in place. HAving MM restore it's last position will then prevent RR from making it show in the correct manner. The scrool not being smooth is a clue that RR is trying to do stuff (probably embbed MM or something) and it is not working for whatever reason... I really have to take a good look at it, but I have to work first..
              Ride Runner RR's Myspace

              "Being happy is not about having what you want, it's about wanting what you have."
              "The best things in life are always free - but that doesn't mean money can't buy you good things."

              Comment


              • #8
                well, sometimes we need to work i'm afraid .... just i don't keep in mind what time it is out there ...
                yes, i exit and restarted RR and MM and the behaviour is the same.
                by the way, with old_DESTINATOR.skin and GENERAL skins everything work perfectly (no black screen...).

                thanx for your great job.

                Comment


                • #9
                  Well, I still will look at it... especially because I don't get this on my laptop or desktop but I do get it in my car..
                  Ride Runner RR's Myspace

                  "Being happy is not about having what you want, it's about wanting what you have."
                  "The best things in life are always free - but that doesn't mean money can't buy you good things."

                  Comment


                  • #10
                    epia ?

                    the same happens to me. everything's good on my desk. i started facing this strange kind of problem when i installed al the stuff on my carputer. is it possible this issue related to epia MB chipset or unichrome integrated graphic?

                    Comment


                    • #11
                      I doubt it.. my carputer is based on asus MB with an integrated ATI Radeon 9100 ... prob just a bug in RR/MM...
                      Ride Runner RR's Myspace

                      "Being happy is not about having what you want, it's about wanting what you have."
                      "The best things in life are always free - but that doesn't mean money can't buy you good things."

                      Comment

                      Working...
                      X