Announcement

Collapse
No announcement yet.

external gps embedded

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • external gps embedded

    has the external gps embedding code changed at all in the past few releases?

    my gps screen used to work correctly but with version 4-01-05 the gps screen looks like this with the bottom of the screen cut off. every time the gps program opens for the first time it looks like this.


    if i exit and come back it looks the way it should as pictured below.


    i'm not sure which release date it last worked with because i haven't been keeping copies of the old releases. any ideas guino?
    my car: 2003 g35 coupe, 2.5ghz c2d cpu, gigabyte micro atx mb, dsatx
    wife's car: 2004 honda accord coupe 2.4ghz p4 cpu, asus micro atx mb, opus 150
    company car: 2006 chevy avalanche 2.0ghz p4 laptop, cnx p1900

  • #2
    I have not changed anything with the embbeding of applicationssince even before start working on mappoint.. chances are that your application doesn't take very kindly of resizing.. I'd recommend trying to set your application to run maximized or at least make it start with a bigger size (like opening it, setting its normal size to like almost the whole screen and closing it so it remembers that position/size). I am guessing there might be a bug in the border removal function because that used to happen with MM too.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

    Comment


    • #3
      I'm having trouble sometimes with MM, however it cuts off my zoom-bar on the right-side, and just gives me ablack area, i need to exit/reload or goto menu/gps a few times and then the zoom bar and rest of the "blacked" area on the right-side re-appears...

      Any ideas why it should do this sporadically?!
      Roy

      2005 Range Rover 4.4
      Any ideas for putting a PC in this? :)

      Comment


      • #4
        go in MM and set it to start Maximized OR to a specified size of at least as big as the embbeded area.. this should take care of that.. I have to see what's the issue here.. I believe the function that removes the border may be at fault..
        Ride Runner RR's Myspace

        "Being happy is not about having what you want, it's about wanting what you have."
        "The best things in life are always free - but that doesn't mean money can't buy you good things."

        Comment


        • #5
          I have the exact same problem with Routis
          4G64 5 SPEED
          MY CAR - MY 5SPD - MY CARPUTER - MY GARAGE SALE

          Comment


          • #6
            Yeah Same problem here too, :/ keep up the good work though, great app...

            Comment


            • #7
              hey guino,

              i just got my carputer back up and running and the version of roadrunner i have on there was back from march 2. in that version, iguidance embeds perfectly every time. my motherboard malfunctioned on me shortly after and had to be sent in for repairs so i don't know exactly when the embedding started acting funny but i hope this helps narrow it down somewhat.
              my car: 2003 g35 coupe, 2.5ghz c2d cpu, gigabyte micro atx mb, dsatx
              wife's car: 2004 honda accord coupe 2.4ghz p4 cpu, asus micro atx mb, opus 150
              company car: 2006 chevy avalanche 2.0ghz p4 laptop, cnx p1900

              Comment


              • #8
                If possible try to make your GPS application's window size as big as possible WITHOUT maximizing it.. if it starts up with a size "big enough" it will likely not show those symptoms .. I'm trying to figure out the issue..
                Ride Runner RR's Myspace

                "Being happy is not about having what you want, it's about wanting what you have."
                "The best things in life are always free - but that doesn't mean money can't buy you good things."

                Comment


                • #9
                  I was going to ask about this as well. I'm using FreeDrive and it used to embed fine. Now when i start it up its too big. Was thinking of going back to an older version if i can't remedy the problem.
                  Another Novice?
                  Progress so far <-------*-> 88%
                  Kenwood MPV5025 with Aux
                  Via MII10000
                  512MB Ram
                  LG Slim DVD\CDRW
                  Xenarc 700TS
                  M1ATX
                  Pharos GPS
                  SYBA USB2.0 4-port Hub
                  Bufalo 54Mbs Wirelessb/g PCMCIA card

                  Comment


                  • #10
                    If you guys use Routis (Iguidance also), the app will NOT run at full screen. The app always run about a "bar" height shorter than full screen. I don't know why, but that the way it is wether you run stand alone or embeded.
                    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
                    89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
                    Y2K Accord Dell GX150
                    RoadRunner is the best FE PERIOD
                    EmoRebellion is a SCAMMER

                    Comment


                    • #11
                      guino,

                      i tried doing what you said about making the window as big as possible and closing it, then running roadrunner but it doesn't make a difference.

                      matrixpc,

                      it has to do with the taskbar. if you set the taskbar to autohide you cut can cut down the "bar" distance by half. if you skin the external gps screen the way i have (pictured above) with player controls and song info across the bottom of the screen the program embeds more than one bar up to begin with. like others have said above, it used to work correctly. now to embed correctly the gps screen needs to be opened, exited and then when it is returned to, everything is right again.
                      my car: 2003 g35 coupe, 2.5ghz c2d cpu, gigabyte micro atx mb, dsatx
                      wife's car: 2004 honda accord coupe 2.4ghz p4 cpu, asus micro atx mb, opus 150
                      company car: 2006 chevy avalanche 2.0ghz p4 laptop, cnx p1900

                      Comment


                      • #12
                        very interesting.... I tried routis here and it worked fine, but then I'm trying on my desktop.. I'll make some tests with the screen full-sized. Have you giys tried the "hide-taskbar" option ?? It will not prevent you from using the taskbar while RR is minimized.
                        Ride Runner RR's Myspace

                        "Being happy is not about having what you want, it's about wanting what you have."
                        "The best things in life are always free - but that doesn't mean money can't buy you good things."

                        Comment


                        • #13
                          Yes, I am running with taskbar hide, I think i'll remove that to see what happens...

                          I put in MM "set size on startup" and selected MAXIMISED... now when I launch GPS it first appears to load in the correct space, then I get a borderless fullscreen MM window/map, then immediately it resizes to the correct space again...

                          Once it didnt resize until about 20secs after, and once it resized about 75% of correct height and width, but this time instead of having the black space on the right side, near the edge, I had it on the left and top... it is as if the window was too narrow, too short and aligned to the lower-right... I exited MM and relaunched and then it did the "embed/fullscreen/embed" routine
                          Roy

                          2005 Range Rover 4.4
                          Any ideas for putting a PC in this? :)

                          Comment


                          • #14
                            guino,

                            i have the hide taskbar option active for rr and i still get the same behaviour with iguidance. it only happens if rr is fullscreen. if i run on my desktop at 1600x1200 and rr is only 800x600, then the embedding works fine. It's only if i run my resolution at 800x600 and run an 800x600 skin that the embedding has a problem.
                            my car: 2003 g35 coupe, 2.5ghz c2d cpu, gigabyte micro atx mb, dsatx
                            wife's car: 2004 honda accord coupe 2.4ghz p4 cpu, asus micro atx mb, opus 150
                            company car: 2006 chevy avalanche 2.0ghz p4 laptop, cnx p1900

                            Comment


                            • #15
                              Originally posted by RoyN
                              I'm having trouble sometimes with MM, however it cuts off my zoom-bar on the right-side, and just gives me ablack area, i need to exit/reload or goto menu/gps a few times and then the zoom bar and rest of the "blacked" area on the right-side re-appears...
                              Ditto
                              '03 Sierra Denali

                              Comment

                              Working...
                              X