Announcement

Collapse
No announcement yet.

horm stuff

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • horm stuff

    Do you have roadroader re-loading the resume.ini file after hibernation (even rr was used to hibernate) with the hibernatereload=true ? Because the playlist and such is being saved/reloaded but rr always plays the same song # on the playlist.

  • #2
    The order of things RR is doing on resume is:

    WinAMP ClearPlaylist
    WinAMP Open Playlist (Winamp.m3u)
    RR Reload of playlist
    RR Reload Resume.INI
    RR Reopen Open COM Ports
    RR Restore Shuffle&Repeat Mode

    I'd suggest save your HORM save point with winamp STOPPED. This should allow RR to resume propperly when using HORM, because the Reload Resume.INI function does absolutely nothing if winamp is currently playing (and that's where the song number/position is set for resume playing)..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

    Comment


    • #3
      You also need to ensure your Road Runner installation is on a writable partition otherwise it will always resume playing the same track.

      Comment


      • #4
        is there any special reason that road runner always comes back from resume without any music playing? this happens when I am on the audio player screen... hibernate, resume from hibernate, msuic is stopped.. music status label says "STOP"...click PLAY, no music, status goes to "PAUSE", click play again, music starts playing normally...

        If i click on the menu as soonas I return from hib(without musc) it starts playing music... what gives?!
        Roy

        2005 Range Rover 4.4
        Any ideas for putting a PC in this? :)

        Comment


        • #5
          using the always resume option RR tries to resume when loading/changing screens.. when resuming from Hibernate, RR also tries to resume music. I think you're having an isoleted problem there.. resume on hibernate has always worked for me, independent of RR version.. I have to improve a few things but I'll try to do it later today for release..
          Ride Runner RR's Myspace

          "Being happy is not about having what you want, it's about wanting what you have."
          "The best things in life are always free - but that doesn't mean money can't buy you good things."

          Comment


          • #6
            Sorry I didnt realize this was HORM as in EWF... dur... how elese could it be...

            but just FYI, my setup is regular hibernate/resume, but still it doesnt resume playing until I change modules...

            If I dont put "resume music when coming back from hibernate" or whatever the correct name is, in rrconfig, then it works... What are the advantages of using that option?
            Roy

            2005 Range Rover 4.4
            Any ideas for putting a PC in this? :)

            Comment


            • #7
              I'd suggest save your HORM save point with winamp STOPPED. This should allow RR to resume propperly when using HORM, because the Reload Resume.INI function does absolutely nothing if winamp is currently playing (and that's where the song number/position is set for resume playing)..
              Ah... so Winamp shouldn't be playing a song when you set your hibernation point? Or winamp shouldn't be open at all? This is probably the problem.

              And yes, RR is on a seperate writable partition apart from the OS.

              Comment


              • #8
                winamp shoudn't be playing music (but probably open) -- just hit stop before making your save point.

                I'm adding a prevention against this for next version..
                Ride Runner RR's Myspace

                "Being happy is not about having what you want, it's about wanting what you have."
                "The best things in life are always free - but that doesn't mean money can't buy you good things."

                Comment


                • #9
                  I still cannot get this to work for the life of me. I have updated to the newest version of RR and I've set new save points with Winamp stopped and it seems that resume.ini isn't being reloaded after hibernation. I know for a fact that resume.ini is being saved with new information before shutting down but when I come out of hibernation, the playlist is corrected properly and such, but the resume.ini info isn't being reloaded. Any other ideas?

                  Comment


                  • #10
                    Tell me exactly what happens exactly by answering those questions one by one:

                    -Is winamp reloading the correctplaylist last used?
                    -Is the last song playing being re-selected in the list?
                    -What exactly are the contents of your resume.ini imediately after resuming from hib. ?

                    Depending on what is happening it will be a different issue to deal with.. I am also looking into a current issue where winamp doesn't seem to be found imediately after resuming from hibernation -- It's either that or winamp is resuming music on its own .. the problem you're having could be related to it..
                    Ride Runner RR's Myspace

                    "Being happy is not about having what you want, it's about wanting what you have."
                    "The best things in life are always free - but that doesn't mean money can't buy you good things."

                    Comment


                    • #11
                      -Is winamp reloading the correctplaylist last used?

                      Yes. The correct playlist is being reloaded most of the time (some times only part of the playlist will be reloaded or it will say AVS null as the only song for the playlist, yet this isn't the problem at hand.

                      -Is the last song playing being re-selected in the list?

                      Nope. This is the problem. It always plays the same song # on resume that was saved during the horm save.

                      -What exactly are the contents of your resume.ini imediately after resuming from hib. ?

                      -1
                      -1
                      false
                      false
                      skinpath


                      Hope this info helps, your doing a great job and RR gets better everday thanks to your hardwork and dedication.

                      Comment


                      • #12
                        yeah, well, then the problem is BEFORE hibernating.. the two first lines should be the song number and the second line should be the time played of the song. I'll take a look at why this is happening -- likely I might be sending the STOP command more than once before hibernating.
                        Ride Runner RR's Myspace

                        "Being happy is not about having what you want, it's about wanting what you have."
                        "The best things in life are always free - but that doesn't mean money can't buy you good things."

                        Comment


                        • #13
                          any progress?

                          Comment


                          • #14
                            well.. once we've stablished its an issue BEFORE the hibernate, you should try a normal hibernate and see if it works.. if then HORM hibernate still doesn't resume, then it is preventing the resume.ini file from being saved.. I know for sure the hibernate procedure is correct now -- it will not wrongfully save those -1s in the INI.
                            Ride Runner RR's Myspace

                            "Being happy is not about having what you want, it's about wanting what you have."
                            "The best things in life are always free - but that doesn't mean money can't buy you good things."

                            Comment


                            • #15
                              Just to help - I use HORM with my RR install, everything is working fine so I very much doubt that it is a coding issue, it resumes from hibernation perfectly everytime and resumes the song playing beforehand. Sorry Cornflake340.

                              How are you hibernating? Is it via RR or Shutdown controller?

                              Comment

                              Working...
                              X