Announcement

Collapse
No announcement yet.

Audio gatway issues with Road Runner and Phoco

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Audio gatway issues with Road Runner and Phoco

    I apriciate this is more of a RR and bluetooth issue than a phoco one but I was hoping you could help me to understand what is going on exactly.

    The situation is this. I have a SE V800, registered Phoco 1.6, Widcomm 5 drivers and road runner.

    If I use phoco by itself, everything is fine, on incomming and outgoing calls the audio gateway service connects and the service works as expected. The windows bluetooth config does tell me that the comm connection ends before the audio gateway service starts but I am not sure I trust this, it is certainly not shown in the phoco log. Anyway this all works fine and I can see the below line in the log file

    ----------------------------------------------------------------------------
    26/02/2006 15:39:01 Callers photo not found!
    ----------------------------------------------------------------------------
    26/02/2006 15:39:01 >ATD01256470489;
    ----------------------------------------------------------------------------
    26/02/2006 15:39:01 Bluetooth headset on device 'V800' connected!
    ----------------------------------------------------------------------------
    26/02/2006 15:39:02 <
    OK

    ----------------------------------------------------------------------------
    26/02/2006 15:39:11 >AT+CPAS
    ----------------------------------------------------------------------------
    26/02/2006 15:39:11 <
    +CPAS: 3

    OK

    ----------------------------------------------------------------------------
    26/02/2006 15:39:11 >AT+CSQ;+CBC
    ----------------------------------------------------------------------------
    26/02/2006 15:39:11 <
    +CSQ: 12,99

    +CBC: 0,46

    OK

    ----------------------------------------------------------------------------
    26/02/2006 15:39:30 >AT+CHUP
    ----------------------------------------------------------------------------
    26/02/2006 15:39:30 <
    OK

    ----------------------------------------------------------------------------
    26/02/2006 15:39:30 Bluetooth headset on device 'V800' disconnected!
    ----------------------------------------------------------------------------
    26/02/2006 15:39:31 >AT+CPAS
    ----------------------------------------------------------------------------
    26/02/2006 15:39:31 <
    +CPAS: 0

    OK

    However if I use phoco through road runner in the remote no design mode the audio gateway doesn't connect on outgoing or incomming calls. I can so no evidence of this in the trace

    OK

    ----------------------------------------------------------------------------
    26/02/2006 15:57:22 RemoteCommand: <PhoneControl.NET><Dial number="01256470489"/></PhoneControl.NET>
    ----------------------------------------------------------------------------
    26/02/2006 15:57:22 Callers photo not found!
    ----------------------------------------------------------------------------
    26/02/2006 15:57:22 >ATD01256470489;
    ----------------------------------------------------------------------------
    26/02/2006 15:57:22 <
    OK

    ----------------------------------------------------------------------------
    26/02/2006 15:57:28 >AT+CPAS
    ----------------------------------------------------------------------------
    26/02/2006 15:57:28 <
    +CPAS: 3

    OK

    ----------------------------------------------------------------------------
    26/02/2006 15:57:28 >AT+CSQ;+CBC
    ----------------------------------------------------------------------------
    26/02/2006 15:57:28 <
    +CSQ: 6,99

    +CBC: 0,45

    OK

    ----------------------------------------------------------------------------
    26/02/2006 15:57:48 >AT+CPAS
    ----------------------------------------------------------------------------
    26/02/2006 15:57:48 <
    +CPAS: 4

    OK

    ----------------------------------------------------------------------------
    26/02/2006 15:57:48 >AT+CSQ;+CBC
    ----------------------------------------------------------------------------
    26/02/2006 15:57:49 <
    +CSQ: 6,99

    +CBC: 0,46

    OK

    ----------------------------------------------------------------------------
    26/02/2006 15:57:50 RemoteCommand: <PhoneControl.NET><Hangup/></PhoneControl.NET>
    ----------------------------------------------------------------------------
    26/02/2006 15:57:50 >AT+CHUP
    ----------------------------------------------------------------------------
    26/02/2006 15:57:50 <
    OK

    So my question is obviously, why is this happening? Is it a lack of code on the RR side or the Phoco side? Also for my own piece of mind is the serial port disconnecting to allow the audio gateway or are both services running as they should on the SE phone.

    Many Thanks

  • #2
    Add this line in your rr.ini file "connecthsp=true" to see if it will be helpful
    _______________________________________
    Car installation 95% [■■■■■■■■■■■■■■■■■■■]
    Current project: Parking sensor USB interface

    Comment


    • #3
      Thanks for the idea robbie but that didn't seem to work. I haven't looked at the log files after making this change but it definatly doesn't turn the audio gateway on.

      Comment


      • #4
        Right, I have added the line you suggested and run rr in debug mode. I started by dialling a number a couple of time and then by calling my mobile, both with no luck.

        http://www.cruizer.plus.com/debug.txt
        http://www.cruizer.plus.com/debugnofd.txt

        Unfortunatly I ran the debug with freedrive running so there is alot of location rubbish in there. Debug.txt is the raw debug and debugnofd.txt is the same file but I have deleted all the fd lines to make it easier to read.

        I can't see any command that would turn the audio gateway on? Is there a command I can add to the accept call button to enable the audio gateway?

        I also double checked and the audiogateway and it doesn't seem to come on when I use phoco through rr but it does if I use phoco directly.

        Many Thanks

        Comment


        • #5
          I think a command need to be added to tell phoco to release the COM port in order for another BT connection to be made (using Phoco's SDK).. or so I heard.. this is the same with trying to dial the internet via BT when using Phoco... my condolences for all of you that own phones with crappy BT support.. not sure when I can look into it, specially since my phone doesn't have this limitation, so I could never be sure it's working when testing it... Making this change does affect the software in the way that you MUST end the call through the computer (since phoco won't be connected to the phone and wont be able to alert RR that the call has ended using the phone)...
          Ride Runner RR's Myspace

          "Being happy is not about having what you want, it's about wanting what you have."
          "The best things in life are always free - but that doesn't mean money can't buy you good things."

          Comment


          • #6
            Ah, but I dont have a phone with crappy bt support. My phone is able to maintain both serial port and audio gateway services at the same time, the problem is the audio gateway service doesn't start when going through rr. I am also chasing zorro to see if this is a limitation with the remotenodeisgn feature.

            Thanks

            Comment


            • #7
              Robby, Zorro has suggested I talk to you about this issue. It seems you are the newly apointed Phoco RR integrator.

              OK, so the ini seting you suggested doesn't seem to do anything, is there a command I can run to actually connect the audiogatway, I can then just include this on the recieve button?

              Comment


              • #8
                Cruizer, are you using your PC mic to speak to the caller?
                Current Vehicle: 2007 Dodge Nitro

                Second Vehicle: Sold it :( 2005 Dodge Ram 1500 Quad Cab

                First Vehicle: 2003 Ford Ranger

                Comment

                Working...
                X