Announcement

Collapse
No announcement yet.

Problem with RoadRunner, Phoco and Hibernation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with RoadRunner, Phoco and Hibernation

    I realize that this is a Phoco problem but please help me out.

    Phoco fails to connect to the COM port coming back from Hibernation. It will keep getting timeout and eventually stop trying.

    However, if I close Road Runner (and thereby closing Phoco), then restart RR (and Phoco), then it'll work.

    Is it possible for me, from RR, to restart Phoco without having to restart RR?

    Appreciate if anyone has a solution to this problem.
    iGMon - Integration between iGuidance and Road Runner
    CFX - Skin for Road Runner

  • #2
    Subscribed..

    Have some issue.
    Current Vehicle: 2007 Dodge Nitro

    Second Vehicle: Sold it :( 2005 Dodge Ram 1500 Quad Cab

    First Vehicle: 2003 Ford Ranger

    Comment


    • #3
      Seems to me like if that's consistent (always does it), then we should close Phoco before hibernating and restart it after resuming. I never had this problem, and likely to never have it since I got a "smart" phone that can't handle any GSM commands needed for Phoco to work.. really "dumb" phone in my opinion.. just a warning for all of you out there.. as far as I know ALL pocket pc phones based on windows mobile (any version so far), do not support the GSM command set and will not work with phoco.
      Ride Runner RR's Myspace

      "Being happy is not about having what you want, it's about wanting what you have."
      "The best things in life are always free - but that doesn't mean money can't buy you good things."

      Comment


      • #4
        yes, guino, it always does it. Is there a command in RR that can close and restart Phoco? I read through Skin Commands but couldn't find it.
        iGMon - Integration between iGuidance and Road Runner
        CFX - Skin for Road Runner

        Comment


        • #5
          there's nothing like that right now.. I'd have to add something and test..
          Ride Runner RR's Myspace

          "Being happy is not about having what you want, it's about wanting what you have."
          "The best things in life are always free - but that doesn't mean money can't buy you good things."

          Comment


          • #6
            G, that's not true. I have an MPX220 which is a Windows "smart" phone (I think) and it works..
            Current Vehicle: 2007 Dodge Nitro

            Second Vehicle: Sold it :( 2005 Dodge Ram 1500 Quad Cab

            First Vehicle: 2003 Ford Ranger

            Comment


            • #7
              Originally posted by guino
              Seems to me like if that's consistent (always does it), then we should close Phoco before hibernating and restart it after resuming. I never had this problem, and likely to never have it since I got a "smart" phone that can't handle any GSM commands needed for Phoco to work.. really "dumb" phone in my opinion.. just a warning for all of you out there.. as far as I know ALL pocket pc phones based on windows mobile (any version so far), do not support the GSM command set and will not work with phoco.
              I have the SMT5600 and read on the forums that it was now supported in the latest version. Which phone do you have? I was so close to getting phoco...


              Biostar M7NCG 400 ver 7.2 AMD Mobile Athlon 1.1GHz (@ 1GHz), Kingston PC2700 512mb WD 80gig HD Custom Case Opus 150W PS Lilliput 7" TS D-Link DBT-120 BT D-Link DWL-G122 WiFi Holux GR-231 GPS nLited XP Pro iGuidance RoadRunner frontend

              Comment


              • #8
                Guino, it is confirmed with me as well. Coming out of hibernation everytime PhoCo won't reconnect in RR unless I close RR and reopen.

                Thanks!
                Current Vehicle: 2007 Dodge Nitro

                Second Vehicle: Sold it :( 2005 Dodge Ram 1500 Quad Cab

                First Vehicle: 2003 Ford Ranger

                Comment


                • #9
                  Originally posted by tbird2340
                  G, that's not true. I have an MPX220 which is a Windows "smart" phone (I think) and it works..
                  That's cool.. at least some do work with it.. wondering why my windows mobile 5 phone doesnt support the GSM commands..

                  Regards to hibernation/resume.. I heard that it is normal for phoco to take a few minutes before it actually reconnects to the phone, so you may just not be giving it enough time ? if it doesn't come back within say 10 minutes, than it might be something to ask Robby_BMW to look at..
                  Ride Runner RR's Myspace

                  "Being happy is not about having what you want, it's about wanting what you have."
                  "The best things in life are always free - but that doesn't mean money can't buy you good things."

                  Comment


                  • #10
                    guino, Phoco will connect right away after hibernation but it will stop trying after 5 timed-out attemps. I already confirmed this with Zorro.

                    I think what we need is for RR to have a skin command that 1) shuts down Phoco, and 2) restarts it and reconnects to it. Something like a "hard" restart so we won't have to close and restart RR.

                    I'd appreciate it if you or Robby can add this to the next release.
                    iGMon - Integration between iGuidance and Road Runner
                    CFX - Skin for Road Runner

                    Comment


                    • #11
                      That would work but then would require us to do something to get it to reconnect each time we come back from hibernation.. Isn't is possible to just have RR kill PhoCo upon hibernating and then have it launch PhoCo when coming back from hibernation?
                      Current Vehicle: 2007 Dodge Nitro

                      Second Vehicle: Sold it :( 2005 Dodge Ram 1500 Quad Cab

                      First Vehicle: 2003 Ford Ranger

                      Comment


                      • #12
                        Hi evrybody, I'm come back from my dominican holidays and I've read of this issue.
                        I think there is some work for me
                        Give me a couple of day to make some test and verify how to solve this problem.
                        _______________________________________
                        Car installation 95% [■■■■■■■■■■■■■■■■■■■]
                        Current project: Parking sensor USB interface

                        Comment


                        • #13
                          Any progress on this? It really sucks having to close out and go back into RR every time..
                          Current Vehicle: 2007 Dodge Nitro

                          Second Vehicle: Sold it :( 2005 Dodge Ram 1500 Quad Cab

                          First Vehicle: 2003 Ford Ranger

                          Comment


                          • #14
                            Thanks Robby. Zorro may have a fix for this problem. I'll try it out.

                            Also, there's another thread about Phoco/RR bugs here.

                            http://www.mp3car.com/vbulletin/showthread.php?t=71188

                            Do you plan on adding the Caller Photo feature in the next release? That'd be great. Also, I bellieve Phoco standalone has a headset icon that tells you whether you're on Audio Gateway or not. Not sure if RR has that as well.
                            iGMon - Integration between iGuidance and Road Runner
                            CFX - Skin for Road Runner

                            Comment


                            • #15
                              I'm still working on it, please be patients.
                              _______________________________________
                              Car installation 95% [■■■■■■■■■■■■■■■■■■■]
                              Current project: Parking sensor USB interface

                              Comment

                              Working...
                              X