Announcement

Collapse
No announcement yet.

Guino: Add to High CPU Load FAQ

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guino: Add to High CPU Load FAQ

    Guino: I've got some instructions that I think that you should add to the High CPU Load, Buttons Fail to Respond, Flash Issues/Spins too Fast ?

    I experienced a high CPU load when using a skin with Flash. I followed your instructions per the FAQ. I updated Flash by downloading the full_flashplayer_win_ie file. (NOTE: RR cannot be running as the shell. You must be running explorer.exe as the shell. No exceptions!) I still experience high CPU usage. Then I followed the steps using Flash.zip. However, when I went to regsvr32 flash.ocx I got an error that said something about:
    DllRegisterServer in flash.ocx failed.
    Return code was: 0x8002801c
    A quick Google search lead me to HERE that basically said there was an access violation in the registry and I needed to figure out which key was giving me problems so I could grant myself permission to the key. Per their instructions, I downloaded RegMon32 from Sysinternals (which by the way makes some great little freeware applications that do not need to be installed to use!; check them out.)

    Because I ran into this problem I want to elobrate on the steps that I used to correct this problem. The above link does not go in to very good detail as how to find the problem keys. Here are my suggested steps that I used:

    1. Download and run RegMon32
    2. Hit CTRL+A to turn off Auto-Scroll
    3. Hit CTRL+L to bring up the filter/highlight options
    4. Next to Include type: regsvr32
    5. Next to highlight type: ACCESS DENIED
    6. Click Start > Run and enter CMD and press enter
    7. Type CD\Windows\System32
    8. Type regsvr32 flash.ocx
    9. If unsuccessful, switch over to RegMon and find the first entry that is highlighted and double click on it
    10. Regedit will open to the appropriate key.
    11. Click Edit > Permissions and select Everyone in the Group or usernames box
    12. Check the box that says Allow next to Full Control and hit OK.
    13. Close Regedit
    14. Switch back to the command prompt and hit the up arrow to repeat the last command and press enter (or just retype regmon32 flash.ocx)
    15. Repeat steps 9-14 until you get a successful response. (I personally had to do it three times before it worked for me).
    16. Reboot

    My CPU times when from 86% when idle to 6% (average) after completing these steps. I feel that it should be added to the FAQ because there is nothing in there saying when the regsvr is unsuccessful.

    Derek
    Progress [||-------]
    View my Worklog to see some of my progress.
    Downgraded Progress - Starting with another car... 09/13/06

  • #2
    I agree this should be added to the FAQ, I received the same error.

    Comment


    • #3
      I honestly had never seen regsvr32 ginving that message, but hey I'll def. post it.. thanks for the info..
      Ride Runner RR's Myspace

      "Being happy is not about having what you want, it's about wanting what you have."
      "The best things in life are always free - but that doesn't mean money can't buy you good things."

      Comment


      • #4
        thanks for the quick response

        Comment


        • #5
          Thanks for the suggestion, worked great!!!!


          Here's another one Guino, I don't know if its been discussed before.

          Often times, web sites suggest lowering the bit quality to improve performance.

          My experience however using laptops has been that the native BIT depth will yeild the lowest cpu usage.

          For instance:
          Using the new GPS gauges posted my 850mhz gets 100% cpu usage at 16bit. If I switch back to the native 32bit, I get 45-50% usage. I don't know if the CPU is involved in scaling down the native bit depth or what.

          On my 300mhz TinyXPrev04 touchscreen laptop, 16bit depth gives about 15% more cpu usage on the main BMV screen versus the native 24bit.

          Seems counterintuitive, but I in my case, higher display settings equal lower cpu usage with FLASH.

          Comment


          • #6
            This also happens with AVS for winamp, they suggest you use the native 32bit color as going to 16bit causes a performance loss.

            Comment


            • #7
              I still can't get flash to preform right on my dell c840 2.4ghz laptop. I have 512k ram and a 64meg nvida geforce 4 go. I have had grafics driver issues with this thing since day one though. There appears to be no correct driver for the thing. Some drivers will run one game but not another and if I switch drivers the game that did work doesn't work and the one that didn't does. About every 6 months I hit the web in search of updated drivers from dell but no luck so far. I even uograded the grafics card bios. I guess I will not be able to test full flash skins on this thing I must wait til I assemble my carputer
              APPS:
              "RR CD Drive Monitor"

              Skins:
              Download the "MAS" beta here...
              New! The Skin Skin community project.

              Comment


              • #8
                I'm also getting the '0x8002801c' error when I try to regsvr32...flash.ocx

                I have very slow response from RR with MC2.0 skin

                Just to clarify though - I have tried installing the flash8b.ocx (archived on macromedia's site) as well as tried Guino's recommended method in the FAQ of installing Flash 9 and then using his attached .zip file and copying the flash8.ocx file and renaming it to flash9.ocx (since flash 9 won't allow RR to load). Both methods result in the same '0x8002801c' error when I try the "regsvr32...flash.ocx" command.

                My question is: should I be performing the regsvr32 command on the file "flash.ocx" or on the "flash9.ocx" / "flash8.ocx" file? Both files are in the flash directory. The error only occurs when I try the command on the flash.ocx file.

                Hopefully I can get this sussed out before I leave on a roadtrip tomorrow...20+ hour roundtrip in a day and a bit will be a lot more fun if my software is working correctly

                Comment


                • #9
                  If you use d_sellers method (Regmon32), it'll work.

                  You should be using regsvr32 "".ocx with "" being whichever file you want to register. If its flash9.ocx then type flash9.ocx

                  Comment


                  • #10
                    Originally posted by Dylan98R/T
                    If you use d_sellers method (Regmon32), it'll work.

                    You should be using regsvr32 "".ocx with "" being whichever file you want to register. If its flash9.ocx then type flash9.ocx
                    That's what I'm wondering - what file needs to be registered? flash9.ocx or flash.ocx? They both are in the same directory....are they both used, or is flash.ocx just a leftover when I install the newer flash9.ocx file?

                    Edit: I deleted the entire flash directory and re-installed flash 8. Once that was done, flash8b.ocx is the only .ocx file in the directory. Something else is causing RR to be so slow then...

                    Edit 2: I was using Intel embedded drivers to achieve 800x480 on my Xenarc. I uninstalled the embedded drivers and gave the regular drivers a try. This fixed the problem - RR/MC2.0 respond without delay now. Strangely, the CPU usage is still the same as before though I wish I could still have 800x480 instead of 800x600 though...

                    Comment


                    • #11
                      I always use the flash.ocx from Guino's page or the rrdownload mirror page.

                      Comment


                      • #12
                        can someone please clarify the registration issue and when it occurs? i followed the instructions in the faq: http://www.mp3car.com/vbulletin/showthread.php?t=45529

                        I installed flash using the download given there, and then unzipped the files from the zip into the directory. I then renamed Flash8.ocx to Flash9.ocx. I did not receive any errors during this process, nor did I ever have to type regsvr32 flash.ocx. But my roadrunner still goes pretty slow (PIII 850mhz, 256mb ram) with the mc2.0 skin. Am I missing something, at what point was I supposed to do the regsvr? I dont even have a flash.ocx in my system32 directory, only in the system32/macromed/flash/ directory

                        Comment


                        • #13
                          Flash heavy skins (MC 2/Freedom etc) do require more processing power as flash has no hardware acceleration support. If you've followed all the suggestions on that FAQ thread than your computer is probably just too slow to run flash (850Mhz is not much). I'd suggest trying a non-flash skin or a light one at best.. see if it helps.
                          Ride Runner RR's Myspace

                          "Being happy is not about having what you want, it's about wanting what you have."
                          "The best things in life are always free - but that doesn't mean money can't buy you good things."

                          Comment


                          • #14
                            Try this,
                            In your display properties of windows, goto the troubleshooting tab, then under the hardware acceleration move it down a notch from full...

                            Comment

                            Working...
                            X