Announcement

Collapse
No announcement yet.

Restarting Winamp after Hibernation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Restarting Winamp after Hibernation

    May be a simple question/fix.... but I updated to the latest RR release, and now using the LSXvoid skin and when I come back out of hibernation Winamp doesn't start back, and thus no music. Everything runs great and when the car goes off it stops the music and goes into hibernation fine, and when it comes back on RR comes back ok, it's just looking like it's not starting Winamp back up.

    During hibernation is RR supposed to close and then restart Winamp? Is there a reason why RR isn't starting Winamp back up?

    Found an old thread with an app that'll close and restart winamp during hibernation but it's always worked in the past with RR, just now having this problem.


    Thanks,
    Nick
    Nick
    '99 Ford Escort ZX2 CarPC <-- RIP Feb '07

    2006 Chevy Equinox LS (Current Project)

    **VIA EPIA PD 1ghz Mobo, OPUS 150, 7" LinITX LCD touchscreen, 512 Ram, 60Gig HD, DLink Bluetooth, Belkin 802.11g wireless,

  • #2
    Originally posted by nkotch View Post
    May be a simple question/fix.... but I updated to the latest RR release, and now using the LSXvoid skin and when I come back out of hibernation Winamp doesn't start back, and thus no music. Everything runs great and when the car goes off it stops the music and goes into hibernation fine, and when it comes back on RR comes back ok, it's just looking like it's not starting Winamp back up.
    What version of Winamp are you using?
    HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

    Comment


    • #3
      The latest, 5.24 I think. And to be honest, I think that winamp was updated not too long ago and am not sure if the problem started around that time or not... it's always something.
      Nick
      '99 Ford Escort ZX2 CarPC <-- RIP Feb '07

      2006 Chevy Equinox LS (Current Project)

      **VIA EPIA PD 1ghz Mobo, OPUS 150, 7" LinITX LCD touchscreen, 512 Ram, 60Gig HD, DLink Bluetooth, Belkin 802.11g wireless,

      Comment


      • #4
        By default, Winamp isn't closed when hibernating.. RR merely stops the music, then resumes it. If winamp is not running when resurming from hibernation, most likely winamp is crashing. This could be caused by different reasons, from bad/unstable plugins to a driver issue with the sound card and/or sound card state after resuming (i.e. USB sound cards etc)..
        Ride Runner RR's Myspace

        "Being happy is not about having what you want, it's about wanting what you have."
        "The best things in life are always free - but that doesn't mean money can't buy you good things."

        Comment


        • #5
          I'll bet you this would help:
          Solution
          For Sale: Carputer (CarPC) & RCA Y-Adapter
          Newsflash: Take a look at my unsold stuff above, thanks!
          Up Next: Make an OBD to Serial cable & Redo the "MMI buttons"

          Comment


          • #6
            Wow, thanks. That worked....
            Nick
            '99 Ford Escort ZX2 CarPC <-- RIP Feb '07

            2006 Chevy Equinox LS (Current Project)

            **VIA EPIA PD 1ghz Mobo, OPUS 150, 7" LinITX LCD touchscreen, 512 Ram, 60Gig HD, DLink Bluetooth, Belkin 802.11g wireless,

            Comment


            • #7
              Originally posted by nkotch View Post
              Wow, thanks. That worked....
              Toldja!

              Guino, maybe you should add to the FAQ that if a user wishes to run Winamp v5.24, they have to update the Jump-to-File Plugin.
              For Sale: Carputer (CarPC) & RCA Y-Adapter
              Newsflash: Take a look at my unsold stuff above, thanks!
              Up Next: Make an OBD to Serial cable & Redo the "MMI buttons"

              Comment


              • #8
                Thanks, I'll post a note there.
                Ride Runner RR's Myspace

                "Being happy is not about having what you want, it's about wanting what you have."
                "The best things in life are always free - but that doesn't mean money can't buy you good things."

                Comment


                • #9
                  I think it's a seperate problem, but Winamp starts playing music when my PC first resumes from hibernation, and then stops after about 30 seconds. The only way to play music (without restarting RR) is to press stop (in RR), then play - pause and play doesn't work. If music is stopped when RR hibernates, it will play fine on resume.

                  I think the problem must be caused by the PC redetecting the soundcard on startup and doing something with Windows' sound devices. Presumably, Winamp is happily playing, then Windows destroys the output device its writing to - when I stop and start music Winamp picks up the correct output device again.

                  I'm using Winamp 5.12 with the DirectSound plugin - for those of you who have this working, are you using a different output plugin?

                  Comment

                  Working...
                  X