Announcement

Collapse
No announcement yet.

Radio works little bit strange. Need help please.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Radio works little bit strange. Need help please.

    Hello everyone !

    I have a small problem with my usb radio and RR.

    My setup is:

    RR (last version)
    IDrive skin (customized by me)
    USB FM D-Link DRU 100 (this radio has very bad reception )
    Drivers for Dlink (from DLink folder of RR)

    Let imagine: I am in main menu of RR (my skin) - everything works great, music from MP3 plays well, Video works well. Now I am pressing Radio button and loading Radio Player skin. Skin loaded well, I can see the setted frequency (let's say 95.9FM) but no sound. As I press Frequency Up or Frequency Down button and change tuning frequency for 0.1 MHZ (for example from 95.9 to 96.0 MHz) I immideately get sound and radio works well. After I can come back to Audio Player or Video player and after come back to radio skin - I will get sound from my FM immideately - so it works well after. It looks like this problem is just for first loading of Radio skin (or just for first change frequency in tuner).
    I am using Line In plugin for WinAmp and I am using MUTE option in RoadRunner. Also I am using Line-In input and everything is setted up in RR config well.
    Where can be this problem ? Is it in my skin (Actually I tried another skin and effect was the same) or the problem is in my tuner DLink ?

    Thank you very much for your help.
    -------------------------------------------------
    BMW X5 Carputer Project
    Finished: 85%
    http://www.mp3car.com/vbulletin/show...lots-pics.html

  • #2
    So as I thingk the Dlink radio driver does not UNMUTE the Dlink tuner until I change a frequency for the first time and after that once it done the radio is unmuted and works great.
    -------------------------------------------------
    BMW X5 Carputer Project
    Finished: 85%
    http://www.mp3car.com/vbulletin/show...lots-pics.html

    Comment


    • #3
      Going by the instructions on setting this up in the FAQ you either use the line-in plugin or the mute/un-mute but not both. You state that your using both.
      Note: You should either use the "line to unmute/mute feature" or the "line-in plugin" but NOT BOTH.
      Visit my site V8 Scimitar

      SP13000, 300GB SATA HD, 1GB DDR. Opus 150, K301 screen, Cisco WIFI, AQmax GPS, RoadRunner and FreeDrive, Sony MEX-R5 head unit. 4 years installed and it just keeps running!

      Comment


      • #4
        True, you should NOT use both -- one OR the other should be sufficient. Double check the radio FAQ. If anything, I would double check your drivers, there are a few different ones going around for the DLink tuner.. and yes, it has poor reception. If you want a USB tuner with good reception maybe you want to try the HQCT (yes it's more $$$).
        Ride Runner RR's Myspace

        "Being happy is not about having what you want, it's about wanting what you have."
        "The best things in life are always free - but that doesn't mean money can't buy you good things."

        Comment


        • #5
          When I played with this I found the drivers from the RR download site didn't work for me but the ones that come in the radiator download did. Ended up not using it as it just doesn't work well enough reception wise.
          Visit my site V8 Scimitar

          SP13000, 300GB SATA HD, 1GB DDR. Opus 150, K301 screen, Cisco WIFI, AQmax GPS, RoadRunner and FreeDrive, Sony MEX-R5 head unit. 4 years installed and it just keeps running!

          Comment


          • #6
            Guys thank you for our replays. I will double check the Radio FAQ and my settings. Also I will play with the drivers. Hope that finaly my proble will be solved
            -------------------------------------------------
            BMW X5 Carputer Project
            Finished: 85%
            http://www.mp3car.com/vbulletin/show...lots-pics.html

            Comment


            • #7


              I checked each step in FAQ about D-Link Radio setup - everything is correct.
              I am using a Line In plugin and I am NOT using Mute option.
              y DLink connected with Line In to my MB, and once again what's happend there:

              start pc=> Main Menu loaded, music playing=> load Radio skin => skin loaded but no soun from radio (like MUTED) => FREQ UP or FREQ DOWN button in Radio skin => we get sound => after come back to any another skin or turn back Audio Player and after come back to Radio skin - radio will work OK.

              So it is looks like when Radio skin is loaded DLink is still muted (maybe by it's driver) and only after I change FREQ Tuning I get sound (get it unmuted).

              Where am I wrong ? Is there any comand to make FREQ UP and FREQ DOWN during Radio skin load so I can just do this at the beginning.

              Thank you.
              -------------------------------------------------
              BMW X5 Carputer Project
              Finished: 85%
              http://www.mp3car.com/vbulletin/show...lots-pics.html

              Comment


              • #8
                This is definitely weird.. do you have any radio presets ?

                You can change the button code from "RADIO" to "RADIO||FREQ+||FREQ-" but you will likely hear it switching frequencies. You can also use variables to execute this only once.. you can do a search for that if you like.
                Ride Runner RR's Myspace

                "Being happy is not about having what you want, it's about wanting what you have."
                "The best things in life are always free - but that doesn't mean money can't buy you good things."

                Comment


                • #9
                  Yes, I have few preseted stations and if I choose any of them I get sound.
                  I will try to use these commands as a temporary fix because anyway I going to buy some good tuner (DLink is realy bad )

                  But it is interesting case, and I do not kow where to look for mistake.

                  And thank you very much for your help
                  -------------------------------------------------
                  BMW X5 Carputer Project
                  Finished: 85%
                  http://www.mp3car.com/vbulletin/show...lots-pics.html

                  Comment


                  • #10
                    would you please try this beta for your issue with the DLink:
                    www.rrdownloads.net/BETA/rr.exe
                    Ride Runner RR's Myspace

                    "Being happy is not about having what you want, it's about wanting what you have."
                    "The best things in life are always free - but that doesn't mean money can't buy you good things."

                    Comment

                    Working...
                    X