Announcement

Collapse
No announcement yet.

RR & Iguidance problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RR & Iguidance problem

    I did a search but didn't find an answer. I am using the latest version of RR and Iguidance 3. Everything works great except when I switch between screens on Iguidance to RR. For example I start RR, then hit the GPS button and I guidance loads. Then if I choose music and then go back to Iguidance, the map doesn't show unless I click on the map and drag it then it will show. Is there a reason for this? Anyway to fix this problem?

  • #2
    more info is needed.

    what skin are you using.

    what version of RR are you running

    Does IG embed into RR?

    what do you have in RRConfig for gps window name?

    Do you have ignative=True or False in RR.ini
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

    Comment


    • #3
      This sounds like the age old focus problem. This can also be machine specific, as my desktop PC does not have this problem, as where the CarPC does. In the case that this does happen, it may be necessary to send a command to iGuidance to bring the iG window back into view.
      Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

      My Fiero Build Thread

      Comment


      • #4
        I have the same problem on two machines with v2.1.2

        Now if in the truck and going down the road its ok but if I stop and switch screen no map.

        The only way I could get it to work was at the end of the load command.
        ||ACTIVATE;iGuidance||SENDKEY;{RIGHT}{RIGHT}”

        Or load IG with the window name !Intellinav so it will load like any other app but you will have the menu bar at the top.

        I think RR needs to send a redraw to IG some how - maybe
        2001 S10 ZR2

        Chucks Skin - to old

        Comment


        • #5
          How do I send a command back so the images comes back automatically instead of having to press and hold the screen somewhere? I'm using the latest RR and the skin that came with it. IG is embbed with no problem other then not showing up when I switch to something else (music, video, etc.) and back. Its not a real big deal but it does get annoying that I have to click and drag for the map to show up again.

          Comment


          • #6
            iGuidance Version Differences

            Originally posted by Chuck View Post
            The only way I could get it to work was at the end of the load command.
            ||ACTIVATE;iGuidance||SENDKEY;{RIGHT}{RIGHT}”
            That command will work in iGuidance 1.x, but on 3.x it will bring up the trip meter on the screen.

            For iGuidance 3.x try:
            ||ACTIVATE;iGuidance||SENDKEY;{SPACE}{SPACE}
            Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

            My Fiero Build Thread

            Comment


            • #7
              I have the same problem.

              Comment


              • #8
                Hi, so does anyone have a fix for this problem? Or is it just specificly some systems? or what causes this?

                Comment


                • #9
                  Same problem here. with the latest release only. Never had the issue in the past. Sucks.

                  Comment


                  • #10
                    If you can't understand what's been posted, just open RR.INI set (or add) ignative=false and call it the day.
                    Ride Runner RR's Myspace

                    "Being happy is not about having what you want, it's about wanting what you have."
                    "The best things in life are always free - but that doesn't mean money can't buy you good things."

                    Comment


                    • #11
                      If your version of iG haven't been alter (changing class name and caption text), it shouldn't have problem embedded it with option to set ignative=true. If you still have problem, do what guino suggested by setting it to false.
                      I don't know how to fix the problem when I can't reproduce the problem.
                      2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
                      89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
                      Y2K Accord Dell GX150
                      RoadRunner is the best FE PERIOD
                      EmoRebellion is a SCAMMER

                      Comment


                      • #12
                        One way to fix this would be add a command to RR that would activate a command every time RR calls for IG window.

                        That way it could be customized for each user

                        Ig v 2
                        “SHOWIG”,” ACTIVATE;iGuidance||SENDKEY;{RIGHT}{RIGHT}”



                        Ig v 3
                        “SHOWIG”,” ACTIVATE;iGuidance||SENDKEY;{SPACE}{SPACE}”
                        2001 S10 ZR2

                        Chucks Skin - to old

                        Comment


                        • #13
                          I have tried everything under the sun to fix this.
                          ignative=false true and everything in between

                          The map is embedded and it is there but you cannot see it till you
                          1 Start moving in the car
                          2 Send a command to IG
                          3 Click the map area and move the map a little

                          If you clip the area it will just show the desktop.

                          For some reason the map just will not redraw on screen switches but it is there and embedded.

                          This is what I am doing now to eliminate the problem on both of my machines so the map will show on start, menu exits, lastscreens and screen switches.

                          What a pain in the a$$

                          /,63A--------------------GPS Exit from stuff to show map-------------------------------------
                          "LASTSCR","TEMPLASTSCR||RETURNMAP"
                          "TEMPLASTSCR","LASTSCR"
                          "EXIT","TEMPEXIT||RETURNMAP"
                          "TEMPEXIT","EXIT"
                          "RETURNMAP","SHOWMAP",EXTERNAL_GPS_IG.skin
                          "RETURNMAP","SHOWMAP",EXTERNAL_GPS_ig_FS.skin
                          "RETURNMAP","SHOWMAP",ATI tv GPS.skin
                          "RETURNMAP","SHOWMAP",Audio_GPS.skin
                          "RETURNMAP","SHOWMAP",Radio_GPS.skin
                          "RETURNMAP","SHOWMAP",SIRIUS GPS.skin
                          "RETURNMAP","SHOWMAP",XM GPS.skin
                          "SHOWMAP","ACTIVATE;iGuidance||SENDKEY;{RIGHT}{RIG HT}"

                          And on all GPS loads I added "SHOWMAP" to the end of the command.
                          2001 S10 ZR2

                          Chucks Skin - to old

                          Comment


                          • #14
                            Did you guys try other front end such as Freeway? Once way to figure out if it is RR specific or machine setting.
                            2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
                            89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
                            Y2K Accord Dell GX150
                            RoadRunner is the best FE PERIOD
                            EmoRebellion is a SCAMMER

                            Comment


                            • #15
                              I will venture out on a limb here, but I am 99% sure, to bet that this is RR specific. The front end itself is in charge of showing the screen and how it is handled. Right? We know iGuidance is just another "window" and on it's own, it never disappears when it is used standalone. Logically then, it HAS to be something, somewhere between RR and iG that is causing this.

                              I am not saying there is something wrong with RR, as it is the best of the best out there as far as Front Ends are concerned. It is just some sort of small code problem, to do with the way the iG window is either called, brought to the front, focused ect.

                              With the addition of the iG code in Road Runner to trim the menu/borders ect, That has been a FANTASTIC improvement. Now, to do that, when iGuidance is detected, it has to "realize" this to trim the borders/menu each time right? If this is the case, is is possible to put some sort of focus command into that area of code? Like Chuck's sollution to send UP,UP / Space Space, so that it done automatically whenever the iG screen is "detected"?

                              The idea being, Switch to iG screen, the code is accessed to trim the menu's/borders. THEN send the Up Up or whatever to ensure that it is brought to the front.

                              This has been a problem for just about everyone at some point, and I have just learned to deal with it, and make HEAVY use of the "North" button on my screen to make iG show back up again when this happens.

                              EDIT:
                              Thinking throug this a bit further, if the sollution to stop this from happening, is to:

                              If you can't understand what's been posted, just open RR.INI set (or add) ignative=false and call it the day.
                              Then that, 100% tells me that is HAS to be something to do with the trimming of the menu's and borders to embed it natively. As, this problem never once occured, on my systems at least, when iG's borders and menu were showing.

                              This is not pointing fingers, blaming code, just trying to narrow it down, and see if collectively we can come up with a sollution for a problem that seems to be pretty much all iG 2.x and 3.x users, which is about 60% of the CarPC users in this forum according to that GPS poll a while back.




                              .
                              Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                              My Fiero Build Thread

                              Comment

                              Working...
                              X