Announcement

Collapse
No announcement yet.

iGuidance Integration Problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • iGuidance Integration Problems

    I am using iGuidance v 3.0, and it works fine in windows. I am also using the latest version of RoadRunner with a scion tc skin.

    In road runner config, I have setup the GPS section for it to have the GPS window in road runner.. but it doesn't work for me.

    In RRConfig, I have the following settings:
    GPS Mode: External
    GPS Path: C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe" "nowarning
    GPS Window Name: !IntellisnavWCls!IGuidance

    I have also tried removing and switching the window names, i have tried setting the parameters for the GPS path differently, ie:
    GPS Path: "C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe" nowarning

    ...and everything else I can think of..

    The ONLY way I can get it to work, is if I already have iGuidance running when I startup Road Runner. When I click GPS, it works and comes up fine.. then if I go to close Road Runner, and exit back to windows, I see that the iGuidance window is gone, but the iGuidanceUMPC.exe process is still in the task manager.

    Yes, I've tried searching for similar problems, but can't find much - and by the way this forums search methods are awful!



    Brett
    www.QRXX.com

  • #2
    http://www.mp3car.com/vbulletin/showthread.php?t=95213
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

    Comment


    • #3
      Thanks for the link.
      I looked through the threads that were in the threads you linked to, but still cannot get this working. Maybe it is a skin problem? I've tried editing the rr.ini with the suggested settings, but it still doesn't properly work. I'm not sure what else to try.

      Brett
      www.QRXX.com

      Comment


      • #4
        Post the GPS portion of rr.ini
        what skin are you using?
        What is the code to run GPS? Remember, some skin, the skinner hard code the GPS button to use LOAD command instead of just "GPS".
        2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
        89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
        Y2K Accord Dell GX150
        RoadRunner is the best FE PERIOD
        EmoRebellion is a SCAMMER

        Comment


        • #5
          Not sure if this is the problem or not, but in GPS Window title in RRConfig, I simply have "iGuidance". I am also using iG 3.0. With the window "disappearing" it sounds like a window title problem, and RR is not able to get a "lock" on it.

          This is from my RR.ini:

          Code:
          gpsmode=2
          gpspath=C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe
          gpsname=iGuidance
          Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

          My Fiero Build Thread

          Comment


          • #6
            Originally posted by MatrixPC View Post
            Post the GPS portion of rr.ini
            what skin are you using?
            What is the code to run GPS? Remember, some skin, the skinner hard code the GPS button to use LOAD command instead of just "GPS".

            The skin i'm using is from another mp3car memeber's thread..
            Its called "system error (blue)".
            http://www.mp3car.com/vbulletin/showthread.php?t=69105


            My complete rr.ini file is here:
            http://qrxx.com/carpc/rr.ini

            The GPS Parts are:

            Code:
            gpsmode=2
            mapmonkeypath=
            gpspath=C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe|nowarning
            gpsname=Iguidance
            Note that I have tried the gpspath different ways.
            I don't have any setting for ignative, although i have seen that posted, but i was under the impression it was not needed.
            I've also changed around the gpsname using winspector, to IntellinavWCls.. i think that was it, anyway it still doesn't work unless iguidance is already running.


            Thanks,
            Brett
            www.QRXX.com

            Comment


            • #7
              Originally posted by JohnWPB View Post
              Not sure if this is the problem or not, but in GPS Window title in RRConfig, I simply have "iGuidance". I am also using iG 3.0. With the window "disappearing" it sounds like a window title problem, and RR is not able to get a "lock" on it.

              This is from my RR.ini:

              Code:
              gpsmode=2
              gpspath=C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe
              gpsname=iGuidance
              Still doesn't work.
              But thanks.
              www.QRXX.com

              Comment


              • #8
                Originally posted by zzzBrett View Post
                Still doesn't work.
                But thanks.
                Hmmmm not sure what it is then. I can tell you you can remove the |NOWARNING from the end of the line, as RR now takes care of that since around the end of October. I doubt this is the problem, but it can be removed anyways.
                Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                My Fiero Build Thread

                Comment


                • #9
                  Its fixed!

                  I downloaded and setup another skin, used it.. and the gps worked.
                  Then, I went back to the system error skin, and it worked too!

                  Kind of weird, but i'm just glad it works now.


                  Thanks for the help,
                  Brett
                  www.QRXX.com

                  Comment

                  Working...
                  X