Announcement

Collapse
No announcement yet.

When starting Iguidance, sometimes desktop show instead

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • When starting Iguidance, sometimes desktop show instead

    It seems that when i start Iguidance through rr it sometimes shows the rr skin bar at the top and instead of the iguidance screen showing up it just shows the desktop. then sometimes if i press the back button and open the X button and then open the gps back up it works again. its wierd.

    Anyone ever run into this issue before.

  • #3
    Originally posted by Enforcer View Post
    look at the external_gps.skin and put a '/' before anyline that starts with a C
    I cant find this anywhere. And how is it possible to modify a skin file with text?

    Comment


    • #4
      Originally posted by lexdiamond20 View Post
      I cant find this anywhere. And how is it possible to modify a skin file with text?
      When you try to open the file it asks you if you want to search the internet for a program to open it with or if you want to choose a program from a list right? Choose a program from the list and choose Wordpad but first go to the bottom and UNCHECK the box that says you want to use the same application every time. Then click OK and it'll open as a text file.

      Now I have a question. In my external_gps.skin file I have this line:
      C01,15,60,655,445
      and in my external_gps_small.skin file I have this line:
      C01,235,62,547,373
      and those are the only lines in any of the GPS skin files that start with a C. So just put a / before those lines? Can you explain why? I'm a software developer but I don't get why it would matter for the letter C. Thanks!
      Ampie Case
      2.5" Hard Drive 80GB Samsung 5400RPM
      256 MB DDR2 PC5400
      Xenarc 700TSV - VGA Monitor
      Intel D945GCLF Motherboard
      M2-ATX-HV

      2005 Honda Civic

      Comment


      • #5
        Okay here you go. If you do some search regarding to iGuidance native in RoadRunner thread, you found the answer already.
        C in RR skin definition mean clip area. RR will cut that area to show the desktop. Also, clip area is the same area as Application area (A).
        Now in RR.ini if your gps is iGuidance and you set iGnative=true, iGuidance will became a child windows of RR. And when RR clips that area, it cut out the application as well (because iG is part of RR).
        If you set iGnative=false, iG isn't part of RR and thus iG isnt' affect when RR clip that area.
        Now you ask what the different between setting iGnative = true/false.
        True: smoother transaction between GPS screen and other screen. Look better.
        False: flicker when switching from GPS screen to other screen (menu, music...). Clip area help eliminate/reduce the flicker. So, with clip area, the screen flick less or none, but you see the desktop during the transaction.
        The option is yours.
        2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
        89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
        Y2K Accord Dell GX150
        RoadRunner is the best FE PERIOD
        EmoRebellion is a SCAMMER

        Comment


        • #6
          I don't have the iGnative=true line in my rr.ini file. Did I do something wrong? Here is my file.

          voice=false
          musicpath=C:\Documents and Settings\me\Desktop\Danny\Songs\Car\
          videopath=C:\Documents and Settings\me\Desktop\Danny\Downloads\Videos\
          dvdpath=Internal
          launchpath=Click here to set path
          winamppath=C:\Program Files\Winamp\
          skinpath=C:\Program Files\Roadrunner\skins\Steel Blues\
          nightskin=C:\Program Files\Roadrunner\skins\Steel Blues\
          mpcpath=C:\Program Files\Windows Media Player\wmplayer.exe
          screentype=16:9
          videoautohide=true
          videohidetime=4
          videofiles=mpeg, mpg, avi, divx, asf
          hidemouse=false
          coverfile=*.jpg
          albumart=*.txt
          useid3=1
          showid3playlist=false
          showid3browse=false
          gpsmode=2
          gpsport=0
          mapmonkeypath=Click here to set path
          gpspath=C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe
          gpsname=
          exitmode=0
          showicons=false
          showextensions=false
          titlesafter=
          listfollowssong=true
          resumemusic=2
          audiorepeat=off
          audioshuffle=on
          gammamode=2
          dateformat=Short Date
          timeformat=Long Time
          id3listformat=%title%
          id3browseformat=%title%
          mastervolmap=0
          listnumbers=true
          noformat=true
          hidewinamp=true
          visuname=MilkDrop
          overspeed=55
          scrollmode=1
          builtinvideo=true
          disableinternat=false
          locale=0
          hidetaskbar=true
          hidedesktop=true
          radiomode=0
          radioline=0
          lazytag=false
          allowallfreqs=false
          browsertype=0
          browserpath=Click here to set path
          standardphonebook=0
          maxcalllistentries=100
          debugmode=false
          hibernateaware=true
          enableclipping=true
          soundcard=0
          nozoom=0
          ipoddrive=Click here to set drive
          usegestures=true
          leavemousealone=false
          hibernatereload=true
          forcehibernate=false
          closeapps=false
          cityweather=CALGARY,CA
          weatherunits=WORLD
          Ampie Case
          2.5" Hard Drive 80GB Samsung 5400RPM
          256 MB DDR2 PC5400
          Xenarc 700TSV - VGA Monitor
          Intel D945GCLF Motherboard
          M2-ATX-HV

          2005 Honda Civic

          Comment


          • #8
            I posted it last year, the thread is still here somewhere. Not to hijack the thread, but with me I boot my computer (which I don't do often) and it loads XP. I don't have it set to boot into Roadrunner yet, so I then load Roadrunner and everything starts perfect, I go into music and it all works. Then I go into the navigation screen (small navigation screen) and it loads the iGuidance warning about not using it while driving even though I piped nowarning to the exe file when loading it. But whatever, so I touch OK and it loads my desktop in the window for the GPS and loads the iGuidance window externally outside and on top of Roadrunner. Just like if I loaded iGuidance on my own. So I close that window and I'm left with my desktop showing in the little window which should have the GPS in it. Then I click for the full screen GPS window and it works perfect. And when I move back to the small window it works perfect. Everything is fine after that, I turn off the car, it hibernates, turn on the car, it comes back, everything works still. But as soon as I reboot, I have to do it all again. I'll look for my original screenshots I posted in another thread.
            Ampie Case
            2.5" Hard Drive 80GB Samsung 5400RPM
            256 MB DDR2 PC5400
            Xenarc 700TSV - VGA Monitor
            Intel D945GCLF Motherboard
            M2-ATX-HV

            2005 Honda Civic

            Comment


            • #9
              Here they are. So when I load the navigation screen, I get the warning like this. I've since upgraded to iGuidance 3 so it's a different warning box but you get the idea.


              Then it loads the actual iGuidance window inside Roadrunner as you can see here. I have to drag the window over far enough to click the X to close it.


              Then I switch to the full screen mode and it works perfect.
              <no picture for this>

              Then I switch back to the small GPS screen and it still works perfect. And will will continue to work perfect until I reboot.
              Ampie Case
              2.5" Hard Drive 80GB Samsung 5400RPM
              256 MB DDR2 PC5400
              Xenarc 700TSV - VGA Monitor
              Intel D945GCLF Motherboard
              M2-ATX-HV

              2005 Honda Civic

              Comment


              • #10
                Put "/,(space)" (without quotes) in front of the "C" lines and add ignative=true to rr.ini..It'll work perfect everytime..
                ****************************************
                OLD SYSTEM (DEAD)
                Intel D945GCLF2 Dual Core ATOM
                Lilliput 7" 629GL 2008 LED Backlight
                BU-353 USB GPS Receiver / iGuidance / IGO8
                M2-ATX Power Supply
                RideRunner Front End / Various Skins
                Windows XP SP3

                Comment


                • #12
                  Originally posted by treetop777 View Post
                  Put "/,(space)" (without quotes) in front of the "C" lines and add ignative=true to rr.ini..It'll work perfect everytime..
                  Didn't work. I tried every combination of the following:

                  1. added ignative=true to rr.ini
                  2. added /, before the C line in external_gps_small.skin
                  3. added /, before the C line in external_gps.skin
                  4. changed the GPS path to IGLaunch.exe|nowarning instead of iguidance.exe|nowarning
                  5. ran roadrunner.exe instead of rr.exe

                  I was at it for over an hour, nothing changed. It still works exactly the same as it has since the first day I installed it all over a year ago. Nobody's been able to help me fix it.
                  Ampie Case
                  2.5" Hard Drive 80GB Samsung 5400RPM
                  256 MB DDR2 PC5400
                  Xenarc 700TSV - VGA Monitor
                  Intel D945GCLF Motherboard
                  M2-ATX-HV

                  2005 Honda Civic

                  Comment


                  • #13
                    Originally posted by Enforcer View Post
                    pics don't show.
                    Still? I need to know if people can see them so I can find out if there's something up with my server.
                    Ampie Case
                    2.5" Hard Drive 80GB Samsung 5400RPM
                    256 MB DDR2 PC5400
                    Xenarc 700TSV - VGA Monitor
                    Intel D945GCLF Motherboard
                    M2-ATX-HV

                    2005 Honda Civic

                    Comment


                    • #14
                      So my DNS registration expired last night, super. Pictures will return once I get it sorted out.
                      Ampie Case
                      2.5" Hard Drive 80GB Samsung 5400RPM
                      256 MB DDR2 PC5400
                      Xenarc 700TSV - VGA Monitor
                      Intel D945GCLF Motherboard
                      M2-ATX-HV

                      2005 Honda Civic

                      Comment


                      • #15
                        Originally posted by Maheriano View Post
                        Still? I need to know if people can see them so I can find out if there's something up with my server.

                        Your domain name has been jacked,, probably expired.
                        Attached Files

                        Comment

                        Working...
                        X