Announcement

Collapse
No announcement yet.

CURRENTTRACKTIME skips seconds?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • CURRENTTRACKTIME skips seconds?

    ok just noticed that, i don't know if it is the current version + the one before, or it goes way back..
    the "CURRENTTRACKTIME" label actually skips seconds !!!
    sometimes it skips 1-2-3-4-5 seconds.. i mean it is "00:45 then it goes "00:50: lol
    it happens randomly mostly it skips 1 second or so..
    any ideas why, isn't RR supposed to update that once a second??

  • #2
    OK, no worrys, i got it, it seems that i was having a variable updated 4 times in one second in some screens, that made RR have trouble keep up updating the rest of the labels.. ok now

    but it keeps missing a second every 10 seconds or so.. in all skins.. i wonder if there is a solution for that

    Comment


    • #3
      its all relative to your cpu usage.. higher the load the more numbers get skipped
      mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
      Follow Me on Twitter or Facebook
      Live mp3Car Facebook Chat

      Comment


      • #4
        yeah i guess thats it.. but even in BMV without any flash in it it still skips 1 sec every 10... and i am using a sempron 2800+
        i also believe it might be down to the number of labels defined in a .skin

        Comment


        • #5
          yes that plays a role too.. basically labels are updated every 100th (or 1000th) of a second... but the more labels u have defined the more labels it has to update in that amount of time.
          mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
          Follow Me on Twitter or Facebook
          Live mp3Car Facebook Chat

          Comment


          • #6
            as flash objects in various skins continue to play even if we change the .skin this produces more stress to the cpu.. and too bad we can't use /discardable as it does not work on skins that have flash.. any news on that.. that might help that issue a bit

            Comment


            • #7
              I've noticed that when the clock misses seconds, the videos are playing asyncronized.
              If I restart RR, or restart the whole PC, both of them seem to work fine.

              This usually happens after waking up from hibernation.

              Comment


              • #8
                during high-load periods of CPU this stuff tends to happen.. RR only updates the screen once per second exactly to save CPU load, so it's expected that with any delays by hardware/other applications, that it might skin a second every now and then.
                Ride Runner RR's Myspace

                "Being happy is not about having what you want, it's about wanting what you have."
                "The best things in life are always free - but that doesn't mean money can't buy you good things."

                Comment


                • #9
                  welcome back mate and thanks..

                  Comment

                  Working...
                  X