Announcement

Collapse
No announcement yet.

Hibernate and Vis and Resume

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hibernate and Vis and Resume

    My Vis button stopped working upon resume from hibernate, if I close and reopen RR it works (running AVS)

    Also, resumemusic=2 doesn't resume music upon resume from hibernate

  • #2
    AVS is somewhat buggy (the winamp code itself) and how it starts/stops sometimes depends on the skin you're using. Try Changing the VIS Setting in RRConfig to "Other" and putting this in: !Winamp Ge!AVS

    For the resume music, a lot of the times this has to do with some touchscreen driver or USB Audio device installed (including Bluetooth devices), which interfere with the windows mixer and thus winamp playback. Sometimes adding this to RR.INI fixes it:
    hibernateaware=false
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

    Comment


    • #3
      is it possible to make RR VIS aware?
      so that it can take the vis off fullscreen or kill the vis or both, before it goes into hibernate.

      I find that mine hangs the PC if it hibernates when the vis is Fullscreen.

      Comment


      • #4
        yes, RR is "vis aware" already.. but it would be best to keep that task to the player, so what I recommend is to do something like this in your "VISU" button:

        "BYVAR;VISON;VISUON<<VISUOFF"

        In ExecTBL:
        "VISUON","VISU||SETVAR;VISUON;1"
        "VISUOFF","VISU||SETVAR;VISUON;0"
        "ONSUSPEND","BYVAR;VISUON;<<VISUOFF"

        With a little more work, you can even get the vis to restart after resuming.
        Ride Runner RR's Myspace

        "Being happy is not about having what you want, it's about wanting what you have."
        "The best things in life are always free - but that doesn't mean money can't buy you good things."

        Comment


        • #5
          Originally posted by guino View Post
          Try Changing the VIS Setting in RRConfig to "Other" and putting this in: !Winamp Ge!AVS
          That was the line already

          Originally posted by guino View Post
          For the resume music, Sometimes adding this to RR.INI fixes it:
          hibernateaware=false
          Tried that, still no joy...if it was paused when it went into hibernate, it'll be paused coming out, no matter what i have resume set for.

          Both of these situations are since the 9-2 release btw, was working before that.

          Rich

          Comment


          • #6
            Originally posted by RichP714 View Post
            That was the line already
            I highly doubt it -- there's normally a "N" in there -- compare what I told you and what you have carefully.
            Ride Runner RR's Myspace

            "Being happy is not about having what you want, it's about wanting what you have."
            "The best things in life are always free - but that doesn't mean money can't buy you good things."

            Comment


            • #7
              Originally posted by guino View Post
              I highly doubt it -- there's normally a "N" in there -- compare what I told you and what you have carefully.
              Ooops, missed that, but when I take out the 'n' it appears, but not embedded (the window frame and title (AVS) are there)

              Comment


              • #8
                Exactly the same result in this thread as well.
                Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

                My Fiero Build Thread

                Comment

                Working...
                X