Announcement

Collapse
No announcement yet.

Possible bug in the EXEC command:

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Possible bug in the EXEC command:

    RR v9/10/07

    An extra set of quotes is showing up after using the EXEC command.

    ExecTBL.ini:
    Code:
    "CHANGESETUPRRDRIVEPATH","LOAD;SETUPRR_CHANGEPATH.skin"
    
    
    .
    Command1:
    Code:
    L14,155,89,492,38,0,0,0,18,"Arial","EXEC;CHANGESETUPRRDRIVEPATH",
    
    
    .
    debug.txt
    Code:
    10/10/2007 1:51:51 PM: Que Exec: True, setuprr_skin1.skin, "SETUPRRDRIVEPATH", False
    10/10/2007 1:51:51 PM: Executing: LOAD;SETUPRR_DRIVEPATH.skin
    10/10/2007 1:51:52 PM: Leave Exec: False, setuprr_skin1.skin, LOAD;SETUPRR_DRIVEPATH.skin, False
    10/10/2007 1:51:52 PM: Enter Exec: False, setuprr_drivepath.skin, "CHANGESETUPRRDRIVEPATH"", False
    10/10/2007 1:51:52 PM: Que Exec: True, setuprr_drivepath.skin, "CHANGESETUPRRDRIVEPATH"", False
    10/10/2007 1:51:52 PM: Executing: CHANGESETUPRRDRIVEPATH"
    10/10/2007 1:51:52 PM: Leave Exec: False, setuprr_drivepath.skin, CHANGESETUPRRDRIVEPATH", False
    10/10/2007 1:51:55 PM: Enter Exec: False, setuprr_drivepath.skin, "QUIT", False
    10/10/2007 1:51:55 PM: Que Exec: True, setuprr_drivepath.skin, "QUIT", False
    10/10/2007 1:51:55 PM: Executing: SendMsg;RRCDRip;showplugin
    10/10/2007 1:51:55 PM: Que Exec: True, setuprr_drivepath.skin, "bye", False
    10/10/2007 1:51:55 PM: Executing: QUIT
    10/10/2007 1:51:56 PM: Shutdown
    Command2
    Code:
    L14,155,89,492,38,0,0,0,18,"Arial","EXEC;LOAD;SETUPRR_CHANGEPATH.skin",
    
    
    .
    debug.txt
    Code:
    10/10/2007 1:53:52 PM: Que Exec: True, setuprr_skin1.skin, "SETUPRRDRIVEPATH", False
    10/10/2007 1:53:52 PM: Executing: LOAD;SETUPRR_DRIVEPATH.skin
    10/10/2007 1:53:53 PM: Leave Exec: False, setuprr_skin1.skin, LOAD;SETUPRR_DRIVEPATH.skin, False
    10/10/2007 1:53:54 PM: Enter Exec: False, setuprr_drivepath.skin, "LOAD;SETUPRR_CHANGEPATH.skin"", False
    10/10/2007 1:53:54 PM: Que Exec: True, setuprr_drivepath.skin, "LOAD;SETUPRR_CHANGEPATH.skin"", False
    10/10/2007 1:53:54 PM: Executing: LOAD;SETUPRR_CHANGEPATH.skin"
    10/10/2007 1:53:54 PM: Invalid Skin file: setuprr_changepath.skin"
    10/10/2007 1:53:54 PM: Leave Exec: False, setuprr_drivepath.skin, LOAD;SETUPRR_CHANGEPATH.skin", False
    10/10/2007 1:53:58 PM: Enter Exec: False, setuprr_drivepath.skin, "QUIT", False
    10/10/2007 1:53:58 PM: Que Exec: True, setuprr_drivepath.skin, "QUIT", False
    10/10/2007 1:53:58 PM: Executing: SendMsg;RRCDRip;showplugin
    10/10/2007 1:53:58 PM: Que Exec: True, setuprr_drivepath.skin, "bye", False
    10/10/2007 1:53:58 PM: Executing: QUIT
    10/10/2007 1:53:59 PM: Shutdown
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  • #2
    I'll check it out.. probably a wrong size calculating the command size. I believe EXEC is normally used followed by || in labels, that's probably why it most of the time works.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

    Comment

    Working...
    X