Announcement

Collapse
No announcement yet.

load playlist on startup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • load playlist on startup

    Ok So I seached, couldn't find this one:
    When RR starts it does not autoplay the last song that was playing when RR was shutdown. Also the playlist does not load, so when i manually start the music (by pushing the play button) RR starts playing the last song play from the beginning, and no album or song info is shown. RR says one song in the play list but when I hit fast forward it goes to the next song that would be in the playlist.

    This only happens when RR was playing from my 'All music' playlist. My 'all music' playlist has 51700 songs. When I load a playlist with 10 songs or so, then shutdown RR then restart, the music plays on restart and the song info is shown. I was thinking that it was just taking a long time to load my large playlist. so I waited 3 minutes after RR started and It never starts playing or load the playlist.

    If i go to the playlist screen it takes about 15 seconds then shows all the songs and says 51700 songs in playlist.

    I have changed the settings to 'always resume' the RR config tool.

    I am using digitalfx2.0 via m10000 512 mb ram winamp 2.xx (whatever the stable release is). My RR version is from aug/2007

    RR behaves as it should with small playlists, just not large ones

    Edit: The big playlist does not send CPU usage way high, and RR does not sit with 'not responding'
    My OLD carputer page
    My NEW carPC



    Via Epia M10000, 512 PC2100, Opus 150, 8" lilly touch, 320 GB 7200 WD Caviar

  • #2
    can you try the LOADLIST command to load the playlist to see how/if it works right ?

    This should not be happening -- as far as limitations go, RR should be able to handle at least a few million songs in the playlist (even if that's absurd).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

    Comment


    • #3
      Guino, I have some extra information that may help you:

      I created a test playlist
      I loaded 15,387 songs into it, When RR starts it behaves perfectly
      the loading screens appear, then my skin appears, and a 4 second delay before the music starts with all of the info loaded properly. The time (of day) displays at the exact same moment as the music starts
      I added songs to make the playlist have 20,217, same behavior only a 6 second delay between my skin and when music started
      27,210 songs = 11 second delay, but proper behavior
      37,663 songs= 18 second delay
      44,619 songs = 23 second delay
      49,344 songs = Time showed up immediately and music never started and info never properly loaded. The time appearing immediatly makes me think RR is making to effort to load the playlist

      When i hit the music Icon on my skin the music began playing, but the player said 'one song' in the playlist. I could still skip through songs as though the whole playlist was there, but there was no song or album info/art

      So RR can handle millions of songs, but there might be something wrong with the code somehwere around 44,619-49,344 songs in a single playlist

      The only other thing I can think of is that one of my songs may be causing the problem

      When I get more time I'll try to see if I can narrow the rang of songs down to pintpoint where the functionality goes berzerk.

      Also is there anyway to reduce the delay while the playlist loads.
      My OLD carputer page
      My NEW carPC



      Via Epia M10000, 512 PC2100, Opus 150, 8" lilly touch, 320 GB 7200 WD Caviar

      Comment


      • #4
        guino,
        I'm being that guy

        The guy who takes the free software that someone has spent 1000's of hours coding. Software that is so functional and great. That guy who still has to nitpick

        Any developments on this, did you get a chance to look at my follow up post detailing exactly where the problem occurs

        If you don't feel like looking into this, or are busy doing other stuff... then that makes sense

        Great peice of software btw, it took a=me about 10 hours of just using RR to see how great it is, b/c i hated it at first. Had to switch b/c it looks as though the next version of FP is vaporware
        My OLD carputer page
        My NEW carPC



        Via Epia M10000, 512 PC2100, Opus 150, 8" lilly touch, 320 GB 7200 WD Caviar

        Comment


        • #5
          I'm traveling till the 22nd.. won't look at anything till then.
          Ride Runner RR's Myspace

          "Being happy is not about having what you want, it's about wanting what you have."
          "The best things in life are always free - but that doesn't mean money can't buy you good things."

          Comment


          • #6
            Originally posted by Moneyfink View Post
            49,344 songs
            WOW!!!!

            Comment


            • #7
              I should have remembered, I saw that in another thread!!
              My OLD carputer page
              My NEW carPC



              Via Epia M10000, 512 PC2100, Opus 150, 8" lilly touch, 320 GB 7200 WD Caviar

              Comment


              • #8
                IF IG4 is open and I rate a song, RR crashes



                Still can't have a playlist with more than 45,000 songs
                My OLD carputer page
                My NEW carPC



                Via Epia M10000, 512 PC2100, Opus 150, 8" lilly touch, 320 GB 7200 WD Caviar

                Comment


                • #9
                  Just did a test here with winamp 2.95 here.. loaded about 100 thousand songs into the playlist (see pic) and had no issues handling it. Both on Standard lists and iLists. I would assume winamp 5.xx would work the same way...

                  My best guess is that something installed or one of your files is crashing either winamp or a plugin you may have installed in winamp (thus crashing winamp as well)..
                  Attached Files
                  Ride Runner RR's Myspace

                  "Being happy is not about having what you want, it's about wanting what you have."
                  "The best things in life are always free - but that doesn't mean money can't buy you good things."

                  Comment


                  • #10
                    Thanks, i never thought of it being a corrupted file or song....
                    I'll troubleshoot up that direction and report back.

                    Something installed, like a startup program somehow interferes?

                    Do you think the skin may have anything to do with it?
                    I'll also try another machine, see what it does?!
                    My OLD carputer page
                    My NEW carPC



                    Via Epia M10000, 512 PC2100, Opus 150, 8" lilly touch, 320 GB 7200 WD Caviar

                    Comment


                    • #11
                      those are all good troubleshooting steps.. try also a different version of winamp to see..
                      Ride Runner RR's Myspace

                      "Being happy is not about having what you want, it's about wanting what you have."
                      "The best things in life are always free - but that doesn't mean money can't buy you good things."

                      Comment


                      • #12
                        No probs here either, got 160gb drive full.


                        wow Guino, on holiday and still trouble shooting


                        I must say, thankyou for an excellent peice of software.

                        I thought it was complicated to start with,but perserverence is the key.

                        Now be on with ya, and enjoy yer holiday

                        Comment


                        • #13
                          Guino is like the mail; rain, sleet, snow, hurricane, toranato, holidays he's always here to help and to deliver the updates...
                          RideRunner...The #1 FE, PERIOD.

                          Current Project: DFXVoice [v1.0 Released]
                          Next in line: RRMedia v2.0

                          DFX 5.1.1 Skin
                          Appstore Link

                          My RideRunner Plugins
                          RRMedia
                          RRExtended
                          DFXVoice

                          "There are no bugs - only undocumented features."

                          Comment


                          • #14
                            Yer i noticed that by reading through the various threads on here..... Top man....Respect.

                            Comment

                            Working...
                            X