Announcement

Collapse
No announcement yet.

My RR/DFX 4.0 100% CPU usage issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • My RR/DFX 4.0 100% CPU usage issue

    I'm starting a new thread since I'm still unable to get this issue resolved in the other threads its spread across.

    Hopefully I will get this resolved, and others might be able to reference this thread should they have a similar issue.

    Background.

    I have a brand new install of XP on a new machine. I installed the latest Version of RR via the New Official RR installer Thread (10-11-08) located here --> http://www.mp3car.com/vbulletin/road...installer.html

    I've had some issues with High CPU usage at an Idle state. At this time, I would not be happy with this install in my car since its performing pretty poorly, especially since others report their CPU usage is under 10% most of the time. I'm often pegged at 100% (or close to it).

    I've posted a small vid showing the high CPU usage and if you look closely you can see what I can only describe as a "laggy" feel to RR. There seems to be a small delay each second (you can see this if you watch the clock).

    http://s8.photobucket.com/albums/a18...t=CIMG1738.flv

    I've changed the Clock logo to just the playlist and still have the same issues.

    When I switch to XM radio, the CPU% does drop some, but into the high 60% range. Not sure if this is a clue to the problem or not.

    Here are the steps I have taken to try and fix this issue so far:

    Update my video drivers from VIA's site
    Install RR
    Install DFX 4.0
    Uninstall flash and get the latest from Adobe.com using IE (Step 10 in How to Speed up RR FAQ)
    Turned down hardware acceleration (Step 5 in How to Speed up RR FAQ)
    Turned off iList (then turned it back on by setting Usedx=true when it had no effect)
    Install DirectX 9c

    Just to throw it out there, this is the Motherboard/ CPU I have:

    http://www.logicsupply.com/products/ms_7199

    Any help would be very much appreciated.

  • #2
    Have you tried setting localdatacaptureinterval=0 in rr.ini? For some reason, I have never been able to use this feature in RR without it pegging my system.

    Comment


    • #3
      Have not tried that one, I just read up on it earlier as I was doing more reading here.

      I'll check it out when I get home and test it.

      Comment


      • #4
        Minoritydan,

        I've got a VIA M10K and my CPU usage is similar to yours when running RR. I'm not sure how much more you can do get the CPU usage down. I am interested to see what you find.

        Originally posted by barnyard View Post
        Have you tried setting localdatacaptureinterval=0 in rr.ini? For some reason, I have never been able to use this feature in RR without it pegging my system.
        Barnyard, looks like you have the same mobo as mine. What's your CPU usage look like while running RR?
        Car PC Progress

        (>>>>>>>>>>>>---) 90%


        "Don't speak about it, be about it"

        Comment


        • #5
          Originally posted by barnyard View Post
          Have you tried setting localdatacaptureinterval=0 in rr.ini? For some reason, I have never been able to use this feature in RR without it pegging my system.

          This value is already set by default in rr.ini (I did not change it, and its a fresh install so I assume its the default).

          Comment


          • #6
            Another Video.

            This one shows how long it takes to transition between screens (XM and Menu).

            http://s8.photobucket.com/albums/a18...t=CIMG1740.flv

            I guess I should pick up another Mobo/CPU, unless there are other suggestions.

            Comment


            • #7
              Originally posted by CARLOS_CET View Post
              Minoritydan,

              I've got a VIA M10K and my CPU usage is similar to yours when running RR. I'm not sure how much more you can do get the CPU usage down. I am interested to see what you find.



              Barnyard, looks like you have the same mobo as mine. What's your CPU usage look like while running RR?
              It averages around 20%-30% under 'normal' usage

              Comment


              • #8
                Have you tried turning off screen transitions? It's under [Skins].
                Off is transition=-1
                It made a small diference on mine, not huge, but it was noticible.

                Also, maybe try turning off iLists, I've read in other posts that it sometimes doesn't work well
                on MB's with onboard graphics.

                Comment


                • #9
                  That clock on the main menu probably isn't helping. Also it's behaving appropriately for those screen transitions that you have set.

                  Strgazr is dead on though, turn off the transitions and maybe ilists.

                  Comment


                  • #10
                    Originally posted by Strgazr View Post
                    Have you tried turning off screen transitions? It's under [Skins].
                    Off is transition=-1
                    It made a small diference on mine, not huge, but it was noticible.

                    Also, maybe try turning off iLists, I've read in other posts that it sometimes doesn't work well
                    on MB's with onboard graphics.
                    I've already tried both, but I'll do it again just to check


                    In my RR ini, transitions is set to -1 already (at the time I took the video is was -1). However, i see TransitionTime=0.2 - should I get rid of this?

                    And turning of Ilist is as simple at Usedx=false , correct?

                    Comment


                    • #11
                      Looks like your transitions are set correctly. No need to change the transition time.

                      and yes Usedx=false for disabling Ilists.

                      Comment


                      • #12
                        Bah!

                        I give up. I am going to order a Intel D945GCLF2 Little Falls 2 Mainboard and plop that in my case.

                        If it makes a huge difference I guess we should put a note in the FAQ or a DFX guide that there may be issues with some mainboards running the skin. Cause I have about exhausted all other options in controlling the CPU load.

                        Comment


                        • #13
                          I have the MII10000 w/1GB of Ram and 2 HDs (one for OS and one for apps) running DFX4.0 with Stationary logo. I get between 20-30% with nothing going and with music 35% (no visualization);thats what shows on the screen. When I go to Task Manager it is 20% without music and 25% with music. I also have tried a Geforce FX5500 video card in hopes of reducing the CPU load but it did not make a difference at all. I have disabled, set to manual many services to get to this point. I am using ilists but not transitions. I have downloaded all of the latest drivers, updated bios, did the suggestion things to speed up RoadRunner along with the latest Flash (v10).

                          One thing that helped me was I turned off the Gamma slider option in the exectbl.ini in DFX4.0. This did help with the CPU load.

                          I would suggest going to Task Manager to see what it says on the load for RoadRunner and other services; to see spikes.

                          I know my board has limitations so I will look at upgrading later. One of the main reasons I got this board was for the PCMCIA slot but I will look at some of the newer boards suggested on the forum.
                          Gee

                          Comment


                          • #14
                            Originally posted by navputer View Post
                            I have the MII10000 w/1GB of Ram and 2 HDs (one for OS and one for apps) running DFX4.0 with Stationary logo. I get between 20-30% with nothing going and with music 35% (no visualization);thats what shows on the screen. When I go to Task Manager it is 20% without music and 25% with music. I also have tried a Geforce FX5500 video card in hopes of reducing the CPU load but it did not make a difference at all. I have disabled, set to manual many services to get to this point. I am using ilists but not transitions. I have downloaded all of the latest drivers, updated bios, did the suggestion things to speed up RoadRunner along with the latest Flash (v10).

                            One thing that helped me was I turned off the Gamma slider option in the exectbl.ini in DFX4.0. This did help with the CPU load.

                            I would suggest going to Task Manager to see what it says on the load for RoadRunner and other services; to see spikes.

                            I know my board has limitations so I will look at upgrading later. One of the main reasons I got this board was for the PCMCIA slot but I will look at some of the newer boards suggested on the forum.
                            Thanks for the info. I've done the comparison in task manager too, its pretty spot on for me.

                            How did you turn off the gamma slider?

                            I saw this in the exectbl.ini

                            "GammaSlider","RUNQ;$SkinPath$Scripts\GammaSlider\ GammaSlider.exe"

                            Did you just delete it, or comment it out?

                            There is alot of info in there, I just don't know how to read it all or what it does.

                            Comment


                            • #15
                              Originally posted by Minoritydan View Post
                              Thanks for the info. I've done the comparison in task manager too, its pretty spot on for me.

                              How did you turn off the gamma slider?

                              I saw this in the exectbl.ini

                              "GammaSlider","RUNQ;$SkinPath$Scripts\GammaSlider\ GammaSlider.exe"

                              Did you just delete it, or comment it out?

                              There is alot of info in there, I just don't know how to read it all or what it does.
                              Thats its...I commented the line out by putting a "/" (without quotes) in front of it
                              Gee

                              Comment

                              Working...
                              X