Announcement

Collapse
No announcement yet.

LOADIMG bug?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • LOADIMG bug?

    Hello:
    I'm using Chuck's skin, and particularly like the weather screen with detailed maps, downloaded from weather.com. It seems there is a bug in the LOADIMG command: using Chuck's original code, the image is shifted to the right and down when loaded in the same place as the image that is first loaded using IMG. If I exit the screen and then re-enter (keeping it in memory) the second image then appears to be in the correct place. If I artificially adjust the position used by LOADIMG on first load, when I return to the screen those images will be shifted to the left (first compensated for shift to right by moving to left, result is shift to left).
    The arguments for LOADIMG are simple, pretty sure I got that right. Am I missing something? Thanks!

    Chuck's skin code:
    /, I, x, y, w, h, Code;INDICATORCODES
    IMG,199,98,806,415,"600.jpg",,,,,,,,,
    /, B, x, y, w, h, Command;COMMANDCODES, Tooltip
    B,23,100,150,60,"LOADIMG;199,98,806,415;600.JPG;OU T",""
    B,23,157,150,60,"LOADIMG;199,98,806,415;100.JPG;OU T",""
    B,23,329,150,60,"LOADIMG;199,98,806,415;TEMP.JPG;O UT",""
    B,22,386,150,60,"LOADIMG;199,98,806,415;FOR.JPG;OU T",""
    B,23,214,150,60,"LOADIMG;199,98,806,415;SAT.JPG;OU T",""
    B,23,272,150,60,"LOADIMG;199,98,806,415;THUN.JPG;O UT",""
    B,23,444,150,60,"LOADIMG;199,98,806,415;PRE.JPG;OU T",""

  • #2
    Your commands are WRONG. You're using commas as separators for the loading position, but instead you should be using semi-colons ( ; ). I can only assume that it would the images in the wrong place (if at all).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

    Comment


    • #3
      Thanks for the response. Nope, that's not it. I notice that if move focus away from Road Runner then back to it the images are magically resized and placed where they should be. This happens on my test system (IBM T41) and the machine in my car. Try it out with Chuck's skin and let me know if you experience the same problem. Or just take my word for it that there is another problem.

      Comment


      • #4
        I'll take a look when I have a chance ... sounds like I need to add a screen refresh to the LOADIMG command.
        Ride Runner RR's Myspace

        "Being happy is not about having what you want, it's about wanting what you have."
        "The best things in life are always free - but that doesn't mean money can't buy you good things."

        Comment


        • #5
          Thanks, that would be great. -- Ryan

          Comment


          • #6
            While we're on this topic, I've found a bug with the IMG command.

            In resized skins (for example, those originally 800x480 that are resized on the fly to 800x600 through a setting in general.ini), the IMG command for ON and DOWN layers don't work properly. The image is not shown where it's supposed to be.

            To recreate this bug, you can use my 800x480 CFX skin and edit general.ini to stretch it out to 800x600. Then hit the "MUTE" button (third one from bottom left). you should see a blinking Red X over that button but it's not there.

            Now edit general.ini to put it back to 800x480 and this problem is gone. Now, you'll see the blinking red X.

            This is the code where I define that red X.
            IMG,158,437,41,29,"mute_indicator.gif",ON
            IMG,158,437,41,29,"mute_indicator.gif",DOWN
            iGMon - Integration between iGuidance and Road Runner
            CFX - Skin for Road Runner

            Comment


            • #7
              That sounds like a more accurate (and logical) description of the problem, as the skin I am using is Chuck's, resized from very big to 640x480. Thanks for chiming in!

              Comment


              • #8
                Just to resurrect an ancient thread and to verify that this bug is still active. The bug comes to the surface when the skin has been resized. The problem is as described above (post#6).
                The road is long but we are getting there.

                Comment


                • #9
                  Just fixed this bug, thanks.
                  Ride Runner RR's Myspace

                  "Being happy is not about having what you want, it's about wanting what you have."
                  "The best things in life are always free - but that doesn't mean money can't buy you good things."

                  Comment

                  Working...
                  X