Announcement

Collapse
No announcement yet.

RR Slider Style issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RR Slider Style issue

    I've found a little issue with sliders style in RR. In Skin Commands.txt is indicated an images range from 0 to 20 (21 images), but i've noticed that in some sliders (main volume, balance, and all the mixer levels) the real range is from 0 to 19 (20 images).
    I think that the problem is caused by some rounded values inside the code.

    Guino, may I suggest these changes in modMixer.bas:

    Public Sub DoVol(ByVal Idx As Integer, Optional ByVal UP As Boolean = True)
    ...
    'Get Vol%
    VolPct = MixerState(Idx).MxrVol / 655.36

    'If No Volume Table
    If UBound(VolTable, 2) = 0 Then
    ...
    'Set Volume
    MixerState(Idx).MxrVol = VolPct * 655.36
    AdjustOutput Idx: GetMixerInfo
    ...


    and these ones in frmSkin.frm:

    Public Sub UpdateSliders()
    ...
    Case "balance"
    Value = Balance * 655.36
    ...
    Case "freq1", "freq2", "freq3", "freq4", "freq5", "freq6", "freq7", "freq8", "freq9", "freq10"
    Value = 65536 - WinAMP_GetEQValue(Val(Mid(.CODE, 6)) - 1) * 1040.25
    ...
    Case "preampvol"
    Value = 65536 - WinAMP_GetPreAmpValue * 1040.25
    ...
    'Set Background (if any)
    If .Style <= UBound(Styles) Then
    BackPath = Replace(SKIN_PATH + Styles(.Style), "*", CStr(Value \ 3120.76))
    ...
    _______________________________________
    Car installation 95% [■■■■■■■■■■■■■■■■■■■]
    Current project: Parking sensor USB interface

  • #2
    I've applied the changes. Thanks.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

    Comment


    • #3
      I'm still seeing a similar problem - not all images are shown in the right order. The sequence seems to show image 3 twice, and not show 20 at all.

      It appears that there are 21 steps between bottom and top - just not the correct images associated with them all.

      Does anybody else see this behaviour?

      Ian

      Comment


      • #4
        What slider code are you using to test it ?

        Also, the above could easily happen for instance if RR could not load image 20 for instance. I have seen compressed GIF files that don't work in RR for instance, so in doubt, swap the number of two files and see if both files do work in different positions.
        Ride Runner RR's Myspace

        "Being happy is not about having what you want, it's about wanting what you have."
        "The best things in life are always free - but that doesn't mean money can't buy you good things."

        Comment


        • #5
          I'm seeing it with all the mixer sliders in the E36 skin.

          I've tried renaming the affected gif images, and deleting them and recreating them, but there is no change

          Ian

          Comment


          • #6
            I hate to wake up a dead topic but this fits my problem to a T. I can't seem to find an answer to this problem. All the sliders seem to repeating postion 0 twice or something and position 20 is isn't being read. It also does this for the clicking position...for example if I click on a region in a song the bar moves to the region previous to the one I click on. Anyone else having this problem?

            Comment


            • #7
              This issue can be fixed easily by changing this two lines in the code, but this could cause that the previous skins need to be fixed.

              Case "songpos"
              If XMON Then
              If XMTrackTime > 0 Then Value = ((XMTime + Timer - XMTimer) / XMTrackTime) * 65535 Else Value = 0
              If Value > 65535 Then Value = 65335
              Else
              Value = (Player.GetTrackPosition / Player.GetTrackLength) * 65536
              If Value > 65536 Then Value = 65336 <-- ADD THIS LINE
              End If
              .
              .
              .
              .
              'Set Background (if any)
              If .Style <= UBound(Styles) Then
              BackPath = Replace(SKIN_PATH + Styles(.Style), "*", CStr(Value \ 3120.76)) <--CHANGE THIS VALUE
              If ImgBack(c).Tag <> BackPath Then
              'Load new image
              Set ImgBack(c) = New cBitmap
              ImgBack(c).FromFile BackPath
              ImgBack(c).Tag = BackPath
              End If
              'Draw Back
              DrawIMG DCPic(4).HDC, (.x * W) / OW, (.y * H) / OH, (.W * W) / OW, (.H * H) / OH, ImgBack(c), &HFF00FF
              End If
              _______________________________________
              Car installation 95% [■■■■■■■■■■■■■■■■■■■]
              Current project: Parking sensor USB interface

              Comment


              • #8
                Umm....thanks Robby. Excellent skin by the way! I just wish I knew how to get to the code to fix it

                Comment


                • #9
                  Seriously....how do I get to that code to fix it? I assume it's in the RoadRunner exe but I did some searching and from what I can tell it's rather difficult to change a compiled exe. I know nothing about coding.

                  Comment


                  • #10
                    The changes must be applied in the source code, then recompiled in a new binary.
                    _______________________________________
                    Car installation 95% [■■■■■■■■■■■■■■■■■■■]
                    Current project: Parking sensor USB interface

                    Comment


                    • #11
                      I searched through all the .bas files with notepad and couldn't find that particular bit of code. Am I searching in the wrong place or something?

                      Comment


                      • #12
                        OK...found it in frmSKIN.frm. As I said I know nothing about coding so I just changed those lines with notepad. Robby, what compiler do you use?

                        Comment

                        Working...
                        X