Announcement

Collapse
No announcement yet.

RR Extension Plug-In - RRFadeVolume

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RR Extension Plug-In - RRFadeVolume

    I whipped up a PLUG-IN

    just add

    X,RRFadeVolume

    to your menu.skin, or plugins.txt or wherever your skin keeps em

    I did some updates to this while back...
    now that i did some work internally to RR audio, i might improve this
    its been a while, but i think i added ramp back up after un-mute!

    -Mitch
    Attached Files
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  • #2
    You star.
    P4 2.8 HT, 512Mb Ram, 60Gb 2.5 HD, M4-ATX, SB Audigy2, BU353, Lilliput TS,Soundgraph Imon VFD,SONY Optiarc dvd Burner,RideRunner, iGo8, Custom Freedom 2.1

    Comment


    • #3
      mitch you are the man!
      mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
      Follow Me on Twitter or Facebook
      Live mp3Car Facebook Chat

      Comment


      • #4
        I'm having some trouble with this and i've just noticed why...it's .net dependant!
        Just proves it doesn't it really,Be careful what you wish for.

        So it looks like you have me cornered Mitch,lol.

        So this net framework,do i actually need it beyond registering these objects?

        EDIT: No,Its not the framework that is the problem,just installed that and everything reg'd ok but it screws my audio up completely after resume.

        Very slow motion and very synthesized and seems to affect all of windows audio after rr is closed until rr is restarted

        EDIT 2: Even after i un reg your plugin this DEV pc keeps doing it so it's probably just an issue on this machine,i don't have cause to hibernate this 1 so i've never noticed it.
        I'll stick it in the car later and i'll let you know how it goes.
        P4 2.8 HT, 512Mb Ram, 60Gb 2.5 HD, M4-ATX, SB Audigy2, BU353, Lilliput TS,Soundgraph Imon VFD,SONY Optiarc dvd Burner,RideRunner, iGo8, Custom Freedom 2.1

        Comment


        • #5
          I ONLY PROGRAM IN .NET, i dont program anything on a pc other then C#

          u did disable the "built-in" fadevolume?

          in rr.ini
          fadeinvolume=false



          mitch
          -Thanks
          Mitch
          www.rush2112.net

          "Did you test it in carwings??"

          Sun, Come shine my way
          May healing waters bury all my pain
          Wind, Carry me home
          The fabric of reality is tearing apart
          The piece of me that died
          Will return To live again

          Comment


          • #6
            Works great here. Thank you!
            The Car 2005 Scion xB

            The Truck 2004 GMC Canyon

            Comment


            • #7
              Originally posted by mitchjs View Post
              u did disable the "built-in" fadevolume?

              in rr.ini
              fadeinvolume=false



              mitch
              Yes i did,like i said i think its this pc but can't be sure till later.
              P4 2.8 HT, 512Mb Ram, 60Gb 2.5 HD, M4-ATX, SB Audigy2, BU353, Lilliput TS,Soundgraph Imon VFD,SONY Optiarc dvd Burner,RideRunner, iGo8, Custom Freedom 2.1

              Comment


              • #8
                anyone out there using this?
                do i need to add/change anything?

                mitch
                -Thanks
                Mitch
                www.rush2112.net

                "Did you test it in carwings??"

                Sun, Come shine my way
                May healing waters bury all my pain
                Wind, Carry me home
                The fabric of reality is tearing apart
                The piece of me that died
                Will return To live again

                Comment


                • #9
                  I never could get it to do anything, but I'm sure I was doing something wrong. I'm getting ready to start building my house, so I'm not really worried with it right now.

                  Comment


                  • #10
                    Originally posted by mitchjs View Post
                    anyone out there using this?
                    do i need to add/change anything?

                    mitch
                    I am using it with no problems.
                    The Car 2005 Scion xB

                    The Truck 2004 GMC Canyon

                    Comment


                    • #11
                      Still not got chance to test as the car's in for some work,will be back tomorrow so i'll get to it asap.

                      I can see trouble ahead though,this flash intro i'm running tries to mute winamp while it plays its audio clip then un pause and allow rr control of winamp,always seems to screw up,tried to troublshoot it a couple of times (special thanks to Sonicxtacy) and its more well behaved now but we couldn't find a bullet proof solution.

                      What actually happens is the pause/unpause gets messed up and rr pause's the track its trying to resume to,i think this being a seperate process is gonna compound the problem.

                      Anyway this has nothing to do with your plugin,i see no reason that it won't do what it says it will but i think that bloody intro's gonna screw it up.
                      P4 2.8 HT, 512Mb Ram, 60Gb 2.5 HD, M4-ATX, SB Audigy2, BU353, Lilliput TS,Soundgraph Imon VFD,SONY Optiarc dvd Burner,RideRunner, iGo8, Custom Freedom 2.1

                      Comment


                      • #12
                        If RR does this natively why do we need a plugin?
                        New Age Garmin - Skin for RR
                        New Age Slider - RR SKin In Progress
                        "It's called CODE because I don't want you to know"

                        Comment


                        • #13
                          thunder, it DOES NOT do it right!

                          it does it completly wrong, by a mix of mixer INPUTS and winamp volume!!
                          very very bad!!!

                          if you got xm, hd, sirius, or any radio for that matter,
                          and music resumes, the fade will screw up the mixer

                          course this only applies to my builds and 9/10 offical merge build
                          since they are the ONLY builds that resume correctly!

                          mitch
                          -Thanks
                          Mitch
                          www.rush2112.net

                          "Did you test it in carwings??"

                          Sun, Come shine my way
                          May healing waters bury all my pain
                          Wind, Carry me home
                          The fabric of reality is tearing apart
                          The piece of me that died
                          Will return To live again

                          Comment


                          • #14
                            fadeinvolume=false

                            ^^ this just fixed my problem where my winamp volume would sometimes go to zero when I come out of hibernation. Woo Hoo! Of course I never had a problem like this before until I added HD Radio and latest RR version. I'll test out this plug in next as it's a nice feature to have.

                            Comment


                            • #15
                              just ran across this after doing a quick search on how to fix my volume fade issues...

                              works great!!!

                              thanks mitch!

                              Comment

                              Working...
                              X