Announcement

Collapse
No announcement yet.

New to skinning...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New to skinning...

    ...so please be patient with me

    So I am using RR skin editor and have created a basic skin with just the main menu off and main menu down screens.

    I saved it to see how it would look, but roadrunner says invalid skin...

    Any cliffs notes for a newbie?
    Thanks!

  • #2
    not sure why its saying invalid skin, prob some bad info in the header of the file. Post your .skin file and ill take a look at it.
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

    Comment


    • #3
      hey liquid...doing some war driving with my new setup. guess its working
      i will try to post some pics of my new install when i get a chance. ......damn its hard to type on this small keyboard.
      Um, I guess this is where you put something witty.WITTY

      My Web site, in the design stage. http://home.comcast.net/~cstrachn

      Modified RRSkinEditor http://www.mp3car.com/vbulletin/showthread.php?t=65723

      Comment


      • #4
        sorry to use up this thread.....hd to mve to a better location. apartment complexes are the best to borow from
        Um, I guess this is where you put something witty.WITTY

        My Web site, in the design stage. http://home.comcast.net/~cstrachn

        Modified RRSkinEditor http://www.mp3car.com/vbulletin/showthread.php?t=65723

        Comment


        • #5
          MEDIACAR Skin
          MEDIACAR subaruoem Skin
          MENU_MAIN_OFF.jpg,,MENU_MAIN_DOWN.jpg

          /, B, x, y, w, h, Command;COMMANDCODES, Tooltip
          B,476,137,287,116,,
          B,41,132,272,120,,

          END



          Thanks, I appreciate the help

          Comment


          • #6
            A problem that I was having is that RR Skin editor was adding an extra .skin at the end of the file name. So it would read:

            Menu.skin.skin

            Also I don't know if it matters but try changing:

            MEDIACAR subaruoem Skin

            to

            MEDIACAR subaruoem.Skin

            Comment


            • #7
              Hi Sebberry,

              I think you will still need to identify the empty and on skins like so,

              MEDIACAR Skin
              MEDIACAR KPJ Skin
              Menu_Empty.jpg,Menu_Off.jpg,Menu_On.jpg,Menu_Down. jpg

              also I think you will have to lose the MAIN_ element. I think RR looks for Menu_xxx.skin to start. You may be able to change this, but I don't know how.

              Also if this doesn't work, check you have a general.ini in the directory where you have your skin.


              Good Luck
              KPJUK
              M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
              DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

              Comment


              • #8
                yeah, you will have to list all of the state images like above, thats prob why its giveing you that error. If you dont want to create images for those states you can just point them to the same images. Like in my skins, the on state and down state use the same images. The nameing dosent matter, just has to be something there to point to.

                are you using the latest or recent version of the skin editor? I know older versions would keep adding Skin at the end, im using V0.1.003. I think you have to download this version from a thread in here somewhere, not sure if the latest version of the Skineditor comes with the current RR updates and whatnot.
                01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
                01101101 01101111 01101011 01100101

                beer replenishment fund
                http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
                mp3car live search

                i have joost invites, just hit me up for one.

                Comment


                • #9
                  Thanks, but none of those worked

                  Comment


                  • #10
                    Do you have general.ini in the skin's folder ?
                    Ride Runner RR's Myspace

                    "Being happy is not about having what you want, it's about wanting what you have."
                    "The best things in life are always free - but that doesn't mean money can't buy you good things."

                    Comment


                    • #11
                      ok, do this.
                      zip up your entire skin and send it to me (not the images) and ill take a look at it. You can just post it here, but if you dont want to do that PM me and ill reply with my addy.
                      01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
                      01101101 01101111 01101011 01100101

                      beer replenishment fund
                      http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
                      mp3car live search

                      i have joost invites, just hit me up for one.

                      Comment


                      • #12
                        This is far from done, in fact I only have the main menu screen done, but as I said above I just wanted to see how it looks and if it even loaded. Maybe I am mistaken assuming that it will work with just the menu?? I can build and repair computers until the cows come home but this stuff just stumps me.




                        General.ini:

                        OriginalWidth=800
                        OriginalHeight=600
                        ShowWidth=800
                        ShowHeight=600
                        XPosition=0
                        YPosition=0
                        ApplyToVideo=False
                        ApplyToVisu=False
                        AutoSwitch=False
                        DayTime=8:00:00 AM
                        NightTime=6:00:00 PM
                        GammaDayRed=1
                        GammaDayGreen=0
                        GammaDayBlue=0
                        GammaNightRed=-40
                        GammaNightGreen=-40
                        GammaNightBlue=-40


                        Menu.skin:

                        MEDIACAR Skin
                        MEDIACAR subaruoem Skin
                        MENU_MAIN_OFF.jpg,,MENU_MAIN_DOWN.jpg

                        /, B, x, y, w, h, Command;COMMANDCODES, Tooltip
                        B,476,137,287,116,,
                        B,41,132,272,120,,

                        END

                        Comment


                        • #13
                          Mate, you didn't read post #7

                          The startup menu screens have to be named as per the below extract

                          MEDIACAR Skin
                          MEDIACAR KPJ Skin
                          Menu_Empty.jpg,Menu_Off.jpg,Menu_On.jpg,Menu_Down. jpg

                          Rename your jpgs, and change the header in Menu.skin, and don't post again until you have tried this. Your Menu skin will then appear as if by magic. You can use the same jpg if you want, but you must identify four files, try it like this if you want

                          MEDIACAR Skin
                          MEDIACAR subaruoem Skin
                          MENU_OFF.jpg,MENU_OFF.jpg,MENU_DOWN.jpg,MENU_DOWN. jpg

                          But rename your jpg's !

                          KPJUK
                          M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
                          DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

                          Comment


                          • #14
                            Oops, sorry.. I posted an old version of my skin file - it was late

                            Ok, I created two more files and renamed them and it loaded up ok except with a big black bar below my jpeg in the RR window.

                            Also, the behavior is weird... it loads my down image first and clicking does nothing to change the image. Mousing over the buttons changes part of the image, but doesn't change it completley (I used a lighting effect to make the button look pressed in, but RR only applied the "pressed in" look to part of the button.

                            Just so I understand, can I use the same text on my buttons for up and down images? The way I look at it, RR simply loads the portion of the "down" image that is marked with the button area I created in the skin editor over top of the "up" image? Or am I totally out to lunch here?

                            Thanks again guys... I am almost at the point where I want to send my jpegs to someone and pay to have it done!!!

                            Comment


                            • #15
                              How big are your jpegs ? are they 800 x 600 ? I have had a vertical bar appear, but this was because I had the wrong jpeg names. You need to make sure you declare four jpg names in your skin, even if they are the same jpg name.

                              RR uses the off image for general display, the on image when the mouse goes over the defined button area, and the down image when you click in the defined button area. The button command is only executed when the defined area is clicked.

                              You get used to the syntax of RR, and I am by no means an expert. Guys like Liquid Smoke, Chuck and of course Guino are among a number of masters that will be only too happy to help. If your still stuck, take LS up on his offer. He has been skinning for a while and can give good solid tips on graphics, and advise on syntax.

                              cheers
                              KPJUK
                              M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
                              DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

                              Comment

                              Working...
                              X