Announcement

Collapse
No announcement yet.

Transparency help...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Transparency help...

    Hi,

    I got an osk that i want to place on a certain place on the screen, therefor i have made a bmp file with the osk, and pink background (ff00ff) like this:



    and i want the screen to be like this:



    but it only shows up like this:



    anyone got this transperrency thing working...?
    i need some help please...

  • #2
    Hello marazi,

    I never did get the transparency option working ! Their are two new commands now to position a MENU, /POSX and /POSY. Check out the help file at RRHelpv004.chm for syntax.

    cheers
    KPJUK
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

    Comment


    • #3
      I think you have to make a truly transparent image, not one with a background color.
      Have you looked in the FAQ yet?
      How about the Wiki?



      Under normal circumstances, a signature would go here.

      Comment


      • #4
        this is what you need to do/check to get it to work.

        1. only use .bmp format for the image, other formats will compress the image and the pink color will not end up being 100% pink which will lead to artifacts in the transparent area.

        2.The pink goes only on the EMPTY image. So it should be something like this.
        myosk_empty.jpg
        myosk_off.jpg
        myosk_on.jpg
        myosk_down.jpg

        down image is optional, you can just use the "on" image if you want.

        3. Only the Empty image should contain the PINK, all other images should look normal, you can just fill the empt areas with black, and all images should be the same resolution.



        side notes about your image. You are going to want to remove the drop shadow from the image. The transparency is only OFF or ON there is no in between or different levels of transparency. So if the pixel is not 100% pink it will not be transparent. So where the drop shadow is it will be pink under it. You'll see what i mean if you try to do it.
        If you want a working example, i use this quite a bit in the lsxvoid skin for popups and menus.
        01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
        01101101 01101111 01101011 01100101

        beer replenishment fund
        http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
        mp3car live search

        i have joost invites, just hit me up for one.

        Comment


        • #5
          Thanks LS,

          I was putting pink on all images! If you have a good example, mail it to me, and I will include it in the help file.

          cheers
          KPJUK

          M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
          DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

          Comment


          • #6
            Also make sure you have NOT disable clipping in RR.INI. For simple images as yours (it's a rectangle), I would suggest you make a .skin with only the keyboard and use /POSX and /POSY to position it (it should be faster than using the clipping transparency).
            Ride Runner RR's Myspace

            "Being happy is not about having what you want, it's about wanting what you have."
            "The best things in life are always free - but that doesn't mean money can't buy you good things."

            Comment


            • #7
              I think the easiest way to do this now with the /POSX and /POSY commands.
              Just make your OSK skin the way you like it and use those two commands in that screen to position it where you like to have it popup.
              Example. Popup Menu at /POSX=025 and /POSY=025
              Attached Files

              Comment


              • #8
                @guino

                where is the anchor point when you use the POS XY?

                also, i know the clipping is slower, but is it only slow on those screens that use it or does it just generally make RR slower across the board?
                01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
                01101101 01101111 01101011 01100101

                beer replenishment fund
                http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
                mp3car live search

                i have joost invites, just hit me up for one.

                Comment


                • #9
                  probably it's me who makes errors... but when I set POSX=0 it doesn't work correctly... I have to set POSX=1 to make it work...
                  1 pixel isn't a problem... just for my knowledge...
                  Live today like it is your last day, and behave as though you will live forever...

                  my WEBSITE

                  MapMonkey Dalai skin-preview-download ITA-email me for ENG
                  Road Runner CrystalBlue skin-preview-beta release

                  Comment


                  • #10
                    You need this command."/POSX=25" san quotes and you need the forward shlash.

                    Comment


                    • #11
                      Originally posted by liquid_smoke View Post
                      @guino

                      where is the anchor point when you use the POS XY?

                      also, i know the clipping is slower, but is it only slow on those screens that use it or does it just generally make RR slower across the board?
                      The anchor point is where your skin definition starts in gerneral.ini
                      If you start at X=0 and Y=0 this is your anchor point. If you start at X=10 and Y=10 then this is your anchor point.

                      Comment


                      • #12
                        ok, I have to explain better my doubt...
                        ...I'm sorry if my english is a problem or it could induce in error...
                        I have ancor point at x=0 y=0,
                        I want a popup menu at x=0 y=100
                        if I use /POSX=0 /POSY=100 it doesn't work
                        if I use /POSX=1 /POSY=100 it works (even if 1 pixel on the right of the point at which I want it to appeare (0,0) ...
                        Live today like it is your last day, and behave as though you will live forever...

                        my WEBSITE

                        MapMonkey Dalai skin-preview-download ITA-email me for ENG
                        Road Runner CrystalBlue skin-preview-beta release

                        Comment


                        • #13
                          For some reason it does not take the /POSX=0.
                          I tryed it and I had to use /POSX=1
                          The closest was /POSX=1 and /POSY=1

                          Comment


                          • #14
                            tanx for all the feedback, will try it out now

                            Comment


                            • #15
                              Originally posted by MGD View Post
                              For some reason it does not take the /POSX=0.
                              I tryed it and I had to use /POSX=1
                              The closest was /POSX=1 and /POSY=1
                              I'm happy to know it's not my fault...
                              Live today like it is your last day, and behave as though you will live forever...

                              my WEBSITE

                              MapMonkey Dalai skin-preview-download ITA-email me for ENG
                              Road Runner CrystalBlue skin-preview-beta release

                              Comment

                              Working...
                              X