No announcement yet.

Navigation and BT GPS in SD download

  • Filter
  • Time
  • Show
Clear All
new posts

  • Navigation and BT GPS in SD download

    Do I have to wait for the DVD to arrive before I can install the Navigation software? Anytime I gesture N I just get the message that Nav is not installed.

    I'm trying to get SD working with my bluetooth GPS but it keeps coming up with "A valid device could not be found on any of the COM ports". Searching the forums for COM returns nothing (COM is too short I guess). Searching for "A valid device" finds nothing The device is connected on COM7 and SD never finds it. Am I doing something wrong here?

  • #2
    Run sd with -allcomm parameter and you should be able to select your com port


    • #3
      There's nothing even close to an all comm parameter under Navigation options and Select the GPS Port.

      I've tried a number of them and each returns A Valid Device Could Not Be Found. I'm running the latest version from the last post in the Sticky.


      • #4
        No, you need to modify the shortcut you use to launch streetdeck and include the -allcomm parameter.

        There are instructions for this in the StreetDeck FAQ forum, I'm pretty certain.
        Have you looked in the FAQ yet?
        How about the Wiki?

        Under normal circumstances, a signature would go here.


        • #5
          This still wouldn't allow a connection. So after uninstalling and reinstalling my bluetooth drivers, damn Widcom, I was able to get it to connect on COM7.

          Now I need to figure out why Navigation isn't available from the install. I uninstalled and reinstalled SD and it's not showing as available.


          • #6
            By the way, the error I'm getting is "The Navigation component is not installed! Please consult the program log for more details".

            I've been searching using Google because the search on your site just isn't working for me. I found a post relating the Unbound #4 button and having MS S&T preinstalled. I'm seeing this button and I have S&T 2006 installed.


            • #7
              Sorry to keep responding to my own posts but I'm finding more information. In the log I see:
              WARNING: CAppData::Exec - Unregistered module called (CNAVFullScreenModule)

              Do I need a separate MapPoint install?


              • #8
                There is nothing in the MapPoint reg hive! On XP TPC Ed. my hive looks like:
                Windows Registry Editor Version 5.00


                [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MapPoint\Add ins]

                [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MapPoint\Add ins\StreetDeckMappoint.Connect]

                That's all that's there!

                Looking at this thread here:
                it would appear that I'm totally hosed since I had MS S&T installed. In order to get this to work I would have to reinstall Windows after paying $200 for this software. A restore point is just not an option.

                Someone please tell me this isn't the case!?


                • #9
                  Finally worked - Hint: I got the disc today

                  Ok, what I had to do was uninstall both Streets & Trips 2006 and Location Finder after uninstall all vestiges of SD. I then tried to install SD from my download last night and still could not get navigation to work. I uninstalled it and removed every SD dir I could find.

                  When my disc came today I ran the install on the computer in the same state I left it in last night. Low and behold, the install took much longer and I was able to see MapPoint actually installing. I wasn't seeing this from the downloaded install. I guess I did need the disc install after all.

                  Thank for all that tried to help.