Announcement

Collapse
No announcement yet.

SD Initializiation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SD Initializiation

    So does SD take 18 seconds to start for everyone? Below is an excerpt from the log file. Also, i have similar delay when accessing the navigation module. I have the initializing navigation module up for around 10-15 seconds.

    What comprises Folder init??? It says initializing navigation at that time:

    INFO: ************************************************** ******************************
    INFO: StreetDeck Application Data Log
    INFO: Log started: Saturday, August 25, 05:29 PM
    INFO: Application Version: 1.1.0.0
    INFO: Command Line: -testmode
    INFO: ************************************************** ******************************
    INFO:

    OnPreCreate - Initialization time 0.030 / 0.030 seconds.


    WARNING: UV_GetUpdateList - The system cannot find the path specified.00000003
    INFO:

    Direct3DCreate9 - Initialization time 0.010 / 0.040 seconds.


    INFO:

    PreEnumerate - Initialization time 0.000 / 0.040 seconds.


    INFO:

    Enumerate - Initialization time 0.000 / 0.040 seconds.


    INFO:

    BrushCreate - Initialization time 0.000 / 0.040 seconds.


    INFO:

    RenderWindow PreCreate - Initialization time 0.000 / 0.040 seconds.


    INFO:

    RenderWindow Create - Initialization time 0.020 / 0.060 seconds.


    INFO:

    Init Loading Logo - Initialization time 0.000 / 0.060 seconds.


    INFO: CUVAppData::OnCreate - Navigation controller successfully initialized!
    INFO:

    Window / Direct3D Create - Initialization time 0.000 / 0.060 seconds.


    WARNING: CAuthorize::ReadPhysicalDriveInNTWithZeroRights - DeviceIOControl IOCTL_STORAGE_GET_MEDIA_SERIAL_NUMBER error = The request is not valid for this device.
    INFO:

    LoadRegInfo - Initialization time 0.060 / 0.120 seconds.


    WARNING: UV_GetFileList - The system cannot find the file specified.00000002
    INFO:

    Init Plugins - Initialization time 0.000 / 0.120 seconds.


    INFO:

    OneTimeDOne - Initialization time 0.030 / 0.150 seconds.


    INFO:

    OneTimeSceneInit - Initialization time 0.000 / 0.150 seconds.


    INFO:

    FindBestWindowedMode - Initialization time 0.000 / 0.150 seconds.


    INFO: CDrawWnd::Initialize3DEnvironment...
    INFO: CDrawWnd::Initialize3DEnvironment - Successfully created D3D device!
    INFO: CRenderEngine::InitDeviceObjects...
    INFO:

    RenderEngine Init - Initialization time 0.120 / 0.270 seconds.


    INFO:

    PreInitDeviceObjects - Initialization time 0.050 / 0.320 seconds.


    INFO:

    StatsFont - Initialization time 0.000 / 0.320 seconds.


    INFO: Initializing POI database...
    INFO:

    OnInitDeviceObjects Start - Initialization time 0.141 / 0.461 seconds.


    WARNING: CInfillOverlay::OnStartup - Error opening infill device hardware (1), trying again! (Audio Open Error, FirmwareComm Open Error)
    WARNING: CInfillOverlay::OnStartup - Error opening infill device hardware (2), trying again! (Audio Open Error, FirmwareComm Open Error)
    WARNING: CInfillOverlay::OnStartup - Error opening infill device hardware (3), trying again! (Audio Open Error, FirmwareComm Open Error)
    INFO:

    Folder Init - Initialization time 14.661 / 15.122 seconds.

    INFO: CSoundController::InitDeviceObjects...
    INFO: Loading Textures...
    INFO: CTextureBag::LoadTextures...
    INFO:

    Load Textures - Initialization time 0.050 / 15.172 seconds.


    INFO:

    Load Logo Texture - Initialization time 0.010 / 15.182 seconds.


    INFO: Initializing Textures...
    INFO:

    Initialize Textures - Initialization time 0.000 / 15.182 seconds.


    INFO: Initializing Speech Controller...
    INFO:

    Init Speech - Initialization time 0.000 / 15.182 seconds.


    INFO: Initializing Media Event Processor...
    INFO:

    Init Media Event Processor - Initialization time 0.000 / 15.182 seconds.


    INFO: Initializing Volume Control Textures...
    INFO:

    Init POI DB - Initialization time 0.000 / 15.182 seconds.


    INFO:

    Init Media Managers - Initialization time 0.000 / 15.182 seconds.


    INFO:

    Enumerate Apps - Initialization time 0.000 / 15.182 seconds.

    Theres more, but i didnt copy the rest.

  • #2
    find and delete T3DevControl.dll and let us know how it goes.
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

    Comment


    • #3
      it didnt work. In fact it made things much worse. The MSI Installer came up and i couldn't find my SD cd. So after 2 hours of pure hell, i was able to restore SD to the way it was before. Now, everytime i delete the T3dev file, the MSI installer kicks in the background and reinstalls the file. Yep, its still slow as ever when loading SD.

      No, i dont have Infill. I'm using a laptop.

      Comment


      • #4
        Unplug any USB devices that are plugged in and try restarting SD from shutdown. I can notice a difference when I use a USB thumb drive with music.

        Comment


        • #5
          nope, no luck. So how do i delete T3....dll without it being automatically reinstalled?

          Comment


          • #6
            Originally posted by Sinabl View Post
            nope, no luck. So how do i delete T3....dll without it being automatically reinstalled?
            Create an empty text file and rename it to T3DevControl.dll
            StreetDeck.com Developer (I am Chuck)
            Get StreetDeck at http://www.streetdeck.com
            The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

            Comment


            • #7
              Chuck, my good man, it worked!!

              Thanks!

              Comment

              Working...
              X