No announcement yet.

StreetDeck GSP, Radio & Phone Problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • StreetDeck GSP, Radio & Phone Problems

    I have an Infill G4 with english XP sp2 and current windows updates installed. I also have streetdeck north america full version and the parrot bluetooth dongle (they only have one).

    Problem 1)
    GSP initalizes but displays "no signal from gps" thus no showing a moving map. But i can create a route and it will give me correct directions. I can browse and that map show the route just fine. So, why does it tell me there is no signal and how do I fix it so it shows me intransit?

    2) Radio: "No radio hard ware can be found"
    In device manager it shows all devices to be working correctly. Also when first installed SD I did the G4 install should that have given me the drives for the radio then?

    3) Phone function in SD error "No compatable hardware can be found"
    I have all of the bluetooth software installed and configured and pairred with my ppc6700 phone through windows.

  • #2
    1) does the GPS get signal when not in SD? Download gpsviewer.exe (google it) and verify that it can see satellites when not in SD. Note that the first time you plug in a GPS it can take up to 15 minutes for it to lock onto satellites.

    2) no idea

    3) phone stuff should stay in the private testers forum while still in beta. there are instructions there to make sure the drivers are correctly loaded. Double-check those and compare to your settings. In summary: in device manager, nothing should show up under Bluetooth radios, but the SD/Parrot bluetooth dongle should be listed under USB devices. The way you get that to happen, is to follow the instructions step by step.

    EDIT: you MUST use the Streetdeck bluetooth dongle. Others will not work with SD. It sounds like you perhaps purchased a different one???

    Hope it helps,


    • #3
      GPS continued....

      I have used and gpsviewer.exe on com1 and baud:9600 and I see the data comming through just fine.

      What's my next step?


      • #4
        does it show you locking on satellites? i forget the UI for that exe...just looked on my PC and I have GPS Info (there's a bunch of these utilities out there) which has a second tab that gives a visual of # of satellites it sees and locks on. You need to verify that it's locking onto satellites.


        • #5
          1)Here is an image of why gpsviewer looks like. I don't know how it shows a lock. It shows roughly 8 satellites with blue bars and a few with red. Take a look at the image and please give me some feed back.

          2) I do I get logging turned on from SD
          3) where is the error log located after it is created.


          • #6
            gps viewer looks good. the gps unit is working and seeing satellites; the problem is in SD. Have you verified the correct port in SD for the GPS unit? try setting baud rate to 4800 once also.


            • #7
              Yes, the port is correct in the nav config, even in the log it shows the gps com1 opened successfully.

              I will give the 4800 baud a shot.

              Thanks for your help.


              • #8
                the way i fixed the low signal gps error was by restarting my comp and letting SD run for a bit before i tried navigation again... it has worked ever since. also, when the g4 resumes from standby it sometimes does not reboot the receiver in SD and that is fixed with a restart.


                • #9
                  I have preformed many reboots, and will try opening navigation periodically while driving around 15 + min. it doesn't seem to change anything.

                  1)Is the grayed out screen with the message "no signal from gps" really mean low signal

                  2) is there any way to see that SD is recieving the gps data at all? (not thru gpsviewer or any other third party app)


                  • #10
                    there wa a GPS info digital mod for streetdeck... it should be on the wiki page that you can install and it will show you what information streetdeck has for the GPS
                    Pentium 4m 1.5GHz|MB896|Roadie Extreme|XM-Direct|Rikaline 6010|T-View 7"|Streetdeck|160gb Western Digital|1Gb DDR2-533 Ram


                    • #11
                      ...and it no longer works after the last update. sigh, would be nice to get it addressed.


                      • #12
                        Correct I tried out the GPS digital mod and it doesn't work as stated in this thread

                        But, the great news is I have my GPS working.
                        When I ran streetdeck.exe -RecordGPS -GPSBaud:9600
                        I did this as a touble shooting process to see that I was getting data and the nav started working.

                        I had tried -GPSBaud:9600 before with the first version I downloaded from mp3car store website with the dvd nav installed and got nothing. I have upgraded since then so that is the key variable that has changed.

                        Recap of solution for navigation error message "no signal from gps" in the navigation window:
                        1)Streetdeck navigation settings: com port 1
                        2)use the -GPSBaud:9600 switch when running streetdeck
                        my computer :infill G4
                        gps: OEM unit (came with infill g4)

                        Thanks to all


                        • #13
                          Thank god for this thread, I finally got my GPS working thanks to the last Streetdeck update and the GPSBaud:9600 argument.

                          The only problem I'm having now is that with this last update Streetdeck gives an error and quits when coming out of standby.


                          • #14
                            PArdon my newbieness but how do you change the baud rate in SD. I installed the demo version of SD from their site and i'm having that "no signal from gps" error, I thought it was because it was a demo. I set the com to 1 but how do i change the baud rate in SD2?