Announcement

Collapse
No announcement yet.

OBDII Module doesn't work in streetdeck

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OBDII Module doesn't work in streetdeck

    I just purchased a full version of streetdeck and also an ELM Scan 5 OBDII scanner from webstore a couple weeks ago and I have been having trouble getting the OBDII Module working with Streetdeck. I used ELMScan's software and it works fine and I can read all the sensors and the error codes however when I use it in streetdeck doesn't work. I have the right plugin selected. I also checked and made sure I have the right com port as well. Is When I go to the module in SD after a short time it says cannot query OBDII please see Log for details. I have no idea where this log or how I can go about troubleshooting this. Please help!

  • #2
    Same here. I have OBDII interface ELM-323. With its original (free) software it works fine always. With SD it works sometimes, but most of the time immideately after start or in couple of minutes saying that can not connect to ELM interface. If I go right away to other software and try it - it's gonna work with no problems. That is strange, may be SD does not reset ELM contorller properly, or loosing communication for some reason.
    -------------------------------------------------
    BMW X5 Carputer Project
    Finished: 85%
    http://www.mp3car.com/vbulletin/show...lots-pics.html

    Comment


    • #3
      check the "Where is the log?" thread in the Streetdeck F.A.Q. section.

      i would close streetdeck...restart it with the -verbose command line switch (there's also a FAQ on the different command line switches), and go to the obdII module and reproduce the error. then close SD, then find the right log (timestamp should be from when you last started SD, I believe).

      post the log and have chuck take a look.

      Comment


      • #4
        I have the same problem, having just rec'd my ELMscan in the mail last night.

        Any updates?

        S4Per... how do I 'find the right log'?? I've never had to do any advanced troubleshooting with streetdeck, but am willing to help with this if someone will explain.
        A car without turbo is a car with perpetual lag.

        My Ride
        My New Page

        Comment


        • #5
          Maxxell its located in C:\Documents and Settings\YOURUSERNAME\My Documents\Streetdeck\Log. The logs are listed by date and time, respectively. Once you run the program and exit out you should see a log created for that specific date and time (looks something like 2008-02-26 12_23.txt). I have already taken the liberty to submit my log to chuck in the new streetdeck bug reporting thread ID # 76. http://www.mp3car.com/vbulletin/tracker.php?projectid=4

          Comment


          • #6
            Lok, thanks for the info. Since you've already done it, should I not waste time doing the same or is there benefit to seeing the log from more than one machine?
            A car without turbo is a car with perpetual lag.

            My Ride
            My New Page

            Comment


            • #7
              I am not sure if it will help, but I guess if Chuck has info from multiple machines it may help him troubleshoot the issue. Make sure you type in "-verbose" at the end of the command line parameter so you get the extended log info. You can also reference my bug ID (#76) so that way he knows its the same issue.

              Comment


              • #8
                Thanks for taking the time to submit this to the bug reporting system. Please follow this post for updates.

                http://www.mp3car.com/vbulletin/tracker.php?itemid=76

                Comment


                • #9
                  How are those updates going? Looks like a lot of people are having this issue. Does Streetdeck work with the OBD module for ANYBODY? Is this a systemic problem?

                  I find it very disingenuous for Streetdeck to continue offering the Elmscan hardware and advertise it as compatible with the software when it's clear there is a big problem and nobody seems to be doing anything about it.
                  A car without turbo is a car with perpetual lag.

                  My Ride
                  My New Page

                  Comment


                  • #10
                    Originally posted by maxxell View Post
                    I find it very disingenuous for Streetdeck to continue offering the Elmscan hardware and advertise it as compatible with the software when it's clear there is a big problem and nobody seems to be doing anything about it.
                    get used to it... it's the way they work. This company is an absolute joke. I am filing a BBB complaint shortly.

                    Comment


                    • #11
                      Hey guys it looks like MP3car has given up on us all together. Anyways I wrote a nasty email to them this morning hopefully it will get them moving...But I doubt it.... (its below)

                      Hello Mp3car,

                      I have been waiting for a response on my issue with interfacing Streetdeck and ELM Scan for over a month. I have used all means you have suggested including forurms and the bug reporting system. I am not sure why have a bug reporting system if you are not going to fix the bugs. I am also not the only one out there with this issue and let me quote someone from your forums just to let you know what people are thinking about this matter. Maxxell wrote on Mar 23:

                      "How are those updates going? Looks like a lot of people are having
                      this issue. Does Streetdeck work with the OBD module for ANYBODY? Is
                      this a systemic problem?

                      I find it very disingenuous for Streetdeck to continue offering the
                      Elmscan hardware and advertise it as compatible with the software when
                      it's clear there is a big problem and nobody seems to be doing anything
                      about it."

                      After the inital response of "check you com port" I have not recieved a reply of any sort regarding this matter. Please tell me what you plan on doing otherwise I would like a refund on my purchase, including shipping as it is not my problem that you can not commit to what you advertise.

                      I have even attempted to call for the past 2 weeks only to get the response from your automated system that you are closed (by the way when are you open? are you ever open?). Not to mention that your mailbox is always full.

                      If this is support then it is a joke. It seems as if your company as taken my money and then sat back and laughed at me for falling for the bait. For $200 I expect someone to pick up the phone at the very least especially when someone is a brand new customer and is having issues with supported hardware and software. For a company that relies on word of mouth and forums for a majority of their sales I would say you are on your path to failure.

                      Please respond.

                      Thank You

                      Alok Patel

                      Comment


                      • #12
                        Lok,

                        According to our records you are using a non-supported hardware configuration. It is unfortunate you have decided to criticize us when we are trying to help support you on hardware that is not designed for StreetDeck.

                        "I have a 600MHz ULV embedded processor, 2 GB ram, 128 MB Onboard Video, USB 2.0, 40 GB HD, etc. Custom made computer"

                        We are doing our best to solve this even though this is outside the range of what we support. There are many people successfully using the elmscan products on StreetDeck.

                        Perhaps you should try them elmscan on a laptop or other supported hardware as a troubleshooting step. Run StreetDeck in demo mode and try the proper com port.

                        Please report your findings in the post i mentioned before.

                        http://www.mp3car.com/vbulletin/tracker.php?itemid=76

                        Comment

                        Working...
                        X