No announcement yet.

Irritated... no GPS in Streetdeck

  • Filter
  • Time
  • Show
Clear All
new posts

  • Irritated... no GPS in Streetdeck

    Simple issue I've fixed before, can't figure out how to do it now.

    I use an Earthmate LT-40 GPS antenna and get it to work with SD. USB to Serial Emulator shows everything good on ports 2, 4, and 5. SD only shows options of COM 1 (unused) and COM 3 (XMDirect adapter.)

    Added Xport. Xport Inputs COM 2, outputs COM 6,7. SD only sees 1 and 3.

    Subtracted Xport, added GPS gate. GPSgate sees COMM 2, outputs COMM 9,10, ****load of others. SD only sees 1 and 3.

    WTF does it take to get SD to see my damn GPS? I'm on leave in Texas and don't have time to research this for more than the 2 hours I already have. Any help would be appreciated. Thanks.

    P.S. I didn't post at the SD forum because there seem to be more experts here than there.

    EDIT: I remember that the GPS used to show up in device manager when using the serial emulator, that isn't happening now. Thanks.

  • #2
    GOT IT! Finally found a post by God of CPU from 2006 that fixed the issue. By using -AllCOMM command line parameter I was able to select the correct port. Wouldn't be a bad idea to add this to FAQ. Thanks anyway.



    • #3
      Post a link to it so others can find it.
      Originally posted by ghettocruzer
      I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
      Want to:
      -Find out about the new iBug iPad install?
      -Find out about carPC's in just 5 minutes? View the Car PC 101 video


      • #4
        It's actually in the manual under "Common problems". No excuse for missing that on my part, it's what I get for skimming.

        "4. My COMM port doesn’t show up in StreetDeck
        Some virtual COM ports and USB Serial devices don't show up in

        You can fix this by running StreetDeck with the -allcomm command line
        parameter. This will force all ports from 1 to 99 to show up.
        i.e. StreetDeck.exe –allcomm""

        I actually had to change the case to "-AllCOMM" before it would work. Hope it helps someone.