Announcement

Collapse
No announcement yet.

No GPS in streetdeck 2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No GPS in streetdeck 2

    I just purchased the full version of SD2 along with a sirf III Usb Receiver. I cant get Streetdeck to recognize the receiver. I have a gps information program (Global Sat?) that recognizes it on com 3 but only with a baud rate of 57600. When I close the program, and enter Sd2, The navigation option menu lists a com1 and prolific usb to serial comm port (com 3), when I click detect it says a valid device could not be detected on any of the comm ports,please try selecting the port manually. I am a newbie any help would be greatly appreciated. Also to be clear, in the gps information program it shows a fix on 9 out of 10 satellites. The other was in red. So i dont think the receiver an issue. Thanks.

  • #2
    Select com port 3. GlobalSat uses Prolific's USB to Serial driver for their GPS.

    Comment


    • #3
      When I select the com3 it says a valid device could not be detected on any of the com ports. Please try selecting one of the com ports manually

      Comment


      • #4
        Close all programs that are using the gps. Open your task manager and make sure those programs are killed and aren't just idle. Then try it. Also kill any gpsgate programs you might be running or anything accessing the comport.

        Comment


        • #5
          I made sure all programs were closed. I tried changing the com port. Streetdeck always lists whatever com port that I change it to, but won't detect it even if I try and select it manually. The navigation screen always says no signal received from gps, even after I double check it with the other program and get a fix on 9 satellites. Navigation was the major reason for purchasing SD2. Everytime I open the other program I make sure that it isnt running anymore, and that SD is the only program trying to access the GPS.

          Comment


          • #6
            Originally posted by Curtis513 View Post
            I made sure all programs were closed. I tried changing the com port. Streetdeck always lists whatever com port that I change it to, but won't detect it even if I try and select it manually. The navigation screen always says no signal received from gps, even after I double check it with the other program and get a fix on 9 satellites. Navigation was the major reason for purchasing SD2. Everytime I open the other program I make sure that it isnt running anymore, and that SD is the only program trying to access the GPS.
            Ok. No Signal Received means that it's detecting it properly. Put the baud rate to 4800 or 9600. Also, download SirfDemo (google it) and play around with the NMEA/SirfIII settings of the receiver. It sounds like it's putting out information in the wrong format for SD to read. I don't recall off hand what my settings in the car are, but I know your baud rate is definitely too high.

            Doc

            Comment


            • #7
              Doc, I downloaded sirfDemo, and got the same results. For some reason if i change the baud rate to 4800 or 9600, then it says no gps receiver in the globalsat program, and in sirfdemo it just doesn't show anything. If I switch the baud to 57600 than it shows the receiver and the information. In SirfDemo when I use the synchronzie protocol and baud rate button it scans over the 4800 and 9600 and locks onto the 57600 and starts working. Does this meen that I will have to purchase a different receiver? It seems like it will only work at a baud rate of 57600. I tried changing some of the nmea settings only to find the same results with the 57600.Thanks, Curtis

              Comment


              • #8
                Originally posted by Curtis513 View Post
                Doc, I downloaded sirfDemo, and got the same results. For some reason if i change the baud rate to 4800 or 9600, then it says no gps receiver in the globalsat program, and in sirfdemo it just doesn't show anything. If I switch the baud to 57600 than it shows the receiver and the information. In SirfDemo when I use the synchronzie protocol and baud rate button it scans over the 4800 and 9600 and locks onto the 57600 and starts working. Does this meen that I will have to purchase a different receiver? It seems like it will only work at a baud rate of 57600. I tried changing some of the nmea settings only to find the same results with the 57600.Thanks, Curtis
                That's really strange. Go to Control Panel -> System -> Device Manager -> Com Ports (or something similar...not on a machine with anything connected to it now) and then find the Prolific Serial to USB device. Open it and check the Baud rate settings. Lower it to 4800 or 9600. Then check again in sirfdemo and SD.

                Doc

                Comment


                • #9
                  Doc, I have gps now. Thank you! I opened up device manager and changed it to 4800, then opened up sirfdemo and selected nmea protocol and changed the baud rate to 4800, then did the same for the global sat program, and am now cruising with gps. Thanks again, Curtis.

                  Comment


                  • #10
                    SD2 GPS problem!

                    I have a same problem
                    It doesn't see my gps. I have to use a com port 1 because I have a build in gps in my laptop.
                    I changed a baud rate to 9600 and was working fine with my Centrafuse 2.0, but I like better a SD2 . I tried with 4800 as well , nothing. It is just a trial version for 30 days,because I don't want to buy it if it will not work!
                    Any Idea?
                    Thank You!

                    Comment

                    Working...
                    X